~chromium-team/chromium-browser/artful-beta

« back to all changes in this revision

Viewing changes to debian/patches/5-desktop-integration-settings.patch

  • Committer: Chad MILLER
  • Date: 2014-08-28 16:59:07 UTC
  • Revision ID: chad.miller@canonical.com-20140828165907-i3gnn72j3gqopspi
* Upstream release 37.0.2062.94. There is no official tarball.
  - CVE-2014-3165: Use-after-free in Blink websockets.
  - CVE-2014-3176, CVE-2014-3177: A combination of bugs in V8, IPC, sync, and
    extensions that can lead to remote code execution outside of the sandbox.
  - CVE-2014-3168: Use-after-free in SVG.
  - CVE-2014-3169: Use-after-free in DOM.
  - CVE-2014-3170: Extension permission dialog spoofing.
  - CVE-2014-3171: Use-after-free in bindings.
  - CVE-2014-3172: Issue related to extension debugging.
  - CVE-2014-3173: Uninitialized memory read in WebGL.
  - CVE-2014-3174: Uninitialized memory read in Web Audio.
  - CVE-2014-3175: Various fixes from internal audits, fuzzing and other
    initiatives.
  - CVE-2014-3176, CVE-2014-3177: Interaction of extensions, IPC, the sync
    API, and Google V8 to execute arbitrary code.
* debian/checkout-orig-source.mk: Don't include src/ prefix in orig tarball.
* debian/patches/*: refresh line numbers.
* debian/patches/search-credit.patch,
  debian/patches/additional-search-engines.patch: Track source files moved.
* debian/patches/arm-neon.patch, debian/patches/ffmpeg-gyp-config.patch,
  debian/patches/fix-gyp-space-in-object-filename-exception.patch,
  debian/patches/gyp-icu-m32-test:
  Disabled. No longer needs fixing.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
1
--- a/chrome/app/generated_resources.grd
2
2
+++ b/chrome/app/generated_resources.grd
3
 
@@ -7731,6 +7731,35 @@ The following plug-in is unresponsive: <
 
3
@@ -7661,6 +7661,35 @@ Keep your key file in a safe place. You
4
4
         Reload
5
5
       </message>
6
6
 
36
36
       <!-- Mac and ChromeOS users do not close their browser. Mac users quit it and ChromeOS users log out. -->
37
37
       <if expr="not is_macosx and not chromeos">
38
38
         <message name="IDS_COOKIES_CLEAR_WHEN_CLOSE_CHKBOX" desc="A checkbox in the Content Settings dialog for removing all cookies on when browser is closed.">
39
 
@@ -11734,6 +11763,9 @@ Some features may be unavailable.  Pleas
 
39
@@ -11809,6 +11838,9 @@ Some features may be unavailable.  Pleas
40
40
       <message name="IDS_OPTIONS_ADVANCED_SECTION_TITLE_CONTENT">
41
41
         Web content
42
42
       </message>
48
48
       </message>
49
49
--- a/chrome/browser/resources/options/browser_options.html
50
50
+++ b/chrome/browser/resources/options/browser_options.html
51
 
@@ -439,6 +439,20 @@
 
51
@@ -444,6 +444,20 @@
52
52
     </div>
53
53
   </section>
54
54
 </if>  <!-- chromeos -->
71
71
     <div class="checkbox">
72
72
--- a/chrome/browser/resources/options/browser_options.js
73
73
+++ b/chrome/browser/resources/options/browser_options.js
74
 
@@ -441,6 +441,23 @@ cr.define('options', function() {
 
74
@@ -450,6 +450,23 @@ cr.define('options', function() {
75
75
             [String(event.target.options[event.target.selectedIndex].value)]);
76
76
       };
77
77
 
95
95
       // Languages section.
96
96
       var showLanguageOptions = function(event) {
97
97
         OptionsPage.navigateToPage('languages');
98
 
@@ -1390,6 +1407,24 @@ cr.define('options', function() {
 
98
@@ -1414,6 +1431,24 @@ cr.define('options', function() {
99
99
     },
100
100
 
101
101
     /**
120
120
      * Set the checked state of the metrics reporting checkbox.
121
121
      * @private
122
122
      */
123
 
@@ -1763,6 +1798,7 @@ cr.define('options', function() {
 
123
@@ -1800,6 +1835,7 @@ cr.define('options', function() {
124
124
   [
125
125
     'addBluetoothDevice',
126
126
     'deleteCurrentProfile',
128
128
     'enableCertificateButton',
129
129
     'enableFactoryResetSection',
130
130
     'getCurrentProfile',
131
 
@@ -1779,6 +1815,7 @@ cr.define('options', function() {
 
131
@@ -1816,6 +1852,7 @@ cr.define('options', function() {
132
132
     'setFontSize',
133
133
     'setNativeThemeButtonEnabled',
134
134
     'setHighContrastCheckboxState',
524
524
 <link rel="stylesheet" href="do_not_track_confirm_overlay.css">
525
525
 <link rel="stylesheet" href="font_settings.css">
526
526
 <link rel="stylesheet" href="handler_options.css">
527
 
@@ -111,6 +112,7 @@
 
527
@@ -112,6 +113,7 @@
528
528
   <include src="home_page_overlay.html">
529
529
   <include src="hotword_confirm_overlay.html">
530
530
   <include src="import_data_overlay.html">
532
532
   <include src="language_options.html">
533
533
   <include src="manage_profile_overlay.html">
534
534
   <include src="managed_user_create_confirm.html">
535
 
@@ -140,6 +142,7 @@
 
535
@@ -141,6 +143,7 @@
536
536
   <include src="autofill_edit_creditcard_overlay.html">
537
537
   <include src="content_settings_exceptions_area.html">
538
538
   <include src="cookies_view.html">
551
551
 var CreateProfileOverlay = options.CreateProfileOverlay;
552
552
 var EditDictionaryOverlay = cr.IsMac ? null : options.EditDictionaryOverlay;
553
553
 var FactoryResetOverlay = options.FactoryResetOverlay;
554
 
@@ -133,6 +135,13 @@ function load() {
 
554
@@ -134,6 +136,13 @@ function load() {
555
555
   OptionsPage.registerOverlay(FontSettings.getInstance(),
556
556
                               BrowserOptions.getInstance(),
557
557
                               [$('fontSettingsCustomizeFontsButton')]);
567
567
                                 ContentSettings.getInstance(),
568
568
--- a/chrome/browser/resources/options/options_bundle.js
569
569
+++ b/chrome/browser/resources/options/options_bundle.js
570
 
@@ -78,6 +78,8 @@ var CertificateImportErrorOverlay = opti
 
570
@@ -79,6 +79,8 @@ var CertificateImportErrorOverlay = opti
571
571
 <include src="content_settings_ui.js"></include>
572
572
 <include src="cookies_list.js"></include>
573
573
 <include src="cookies_view.js"></include>
578
578
 <if expr="enable_google_now">
579
579
--- a/chrome/browser/ui/webui/options/browser_options_handler.cc
580
580
+++ b/chrome/browser/ui/webui/options/browser_options_handler.cc
581
 
@@ -202,6 +202,8 @@ void BrowserOptionsHandler::GetLocalized
 
581
@@ -201,6 +201,8 @@ void BrowserOptionsHandler::GetLocalized
582
582
       IDS_OPTIONS_ADVANCED_SECTION_TITLE_CERTIFICATES },
583
583
     { "advancedSectionTitleContent",
584
584
       IDS_OPTIONS_ADVANCED_SECTION_TITLE_CONTENT },
587
587
     { "advancedSectionTitleLanguages",
588
588
       IDS_OPTIONS_ADVANCED_SECTION_TITLE_LANGUAGES },
589
589
     { "advancedSectionTitleNetwork",
590
 
@@ -219,6 +221,10 @@ void BrowserOptionsHandler::GetLocalized
 
590
@@ -218,6 +220,10 @@ void BrowserOptionsHandler::GetLocalized
591
591
     { "defaultFontSizeLabel", IDS_OPTIONS_DEFAULT_FONT_SIZE_LABEL },
592
592
     { "defaultSearchManageEngines", IDS_OPTIONS_DEFAULTSEARCH_MANAGE_ENGINES },
593
593
     { "defaultZoomFactorLabel", IDS_OPTIONS_DEFAULT_ZOOM_LEVEL_LABEL },
598
598
 #if defined(OS_CHROMEOS)
599
599
     { "disableGData", IDS_OPTIONS_DISABLE_GDATA },
600
600
 #endif
601
 
@@ -292,6 +298,8 @@ void BrowserOptionsHandler::GetLocalized
 
601
@@ -290,6 +296,8 @@ void BrowserOptionsHandler::GetLocalized
602
602
     { "profilesManage", IDS_PROFILES_MANAGE_BUTTON_LABEL },
603
603
     { "profilesSupervisedDashboardTip",
604
604
       IDS_PROFILES_SUPERVISED_USER_DASHBOARD_TIP },
977
977
   AddOptionsPageUIHandler(localized_strings, new GeolocationOptionsHandler());
978
978
--- a/chrome/chrome_browser_ui.gypi
979
979
+++ b/chrome/chrome_browser_ui.gypi
980
 
@@ -2284,6 +2284,8 @@
 
980
@@ -2296,6 +2296,8 @@
981
981
         'browser/ui/webui/options/core_options_handler.h',
982
982
         'browser/ui/webui/options/create_profile_handler.cc',
983
983
         'browser/ui/webui/options/create_profile_handler.h',
986
986
         'browser/ui/webui/options/font_settings_handler.cc',
987
987
         'browser/ui/webui/options/font_settings_handler.h',
988
988
         'browser/ui/webui/options/font_settings_utils.h',
989
 
@@ -2666,6 +2668,7 @@
 
989
@@ -2674,6 +2676,7 @@
990
990
           ],
991
991
         }],
992
 
         ['use_aura==1 and use_ash==0 and use_ozone==0 and OS=="linux"', {
 
992
         ['use_aura==1 and chromeos==0 and use_ozone==0 and OS=="linux"', {
993
993
+          'cflags': [ '<!@(pkg-config --cflags glib-2.0)', ],
994
994
           'dependencies': [
995
995
             # gtk2 is the only component that can interact with gtk2 in our new
996
996
             # world.
997
 
@@ -3043,6 +3046,7 @@
 
997
@@ -3048,6 +3051,7 @@
998
998
           ],
999
999
         }],
1000
1000
         ['OS=="linux"', {