~chromium-team/chromium-browser/artful-beta

« back to all changes in this revision

Viewing changes to debian/patches/additional-search-engines.patch

  • Committer: Chad MILLER
  • Date: 2014-08-28 16:59:07 UTC
  • Revision ID: chad.miller@canonical.com-20140828165907-i3gnn72j3gqopspi
* Upstream release 37.0.2062.94. There is no official tarball.
  - CVE-2014-3165: Use-after-free in Blink websockets.
  - CVE-2014-3176, CVE-2014-3177: A combination of bugs in V8, IPC, sync, and
    extensions that can lead to remote code execution outside of the sandbox.
  - CVE-2014-3168: Use-after-free in SVG.
  - CVE-2014-3169: Use-after-free in DOM.
  - CVE-2014-3170: Extension permission dialog spoofing.
  - CVE-2014-3171: Use-after-free in bindings.
  - CVE-2014-3172: Issue related to extension debugging.
  - CVE-2014-3173: Uninitialized memory read in WebGL.
  - CVE-2014-3174: Uninitialized memory read in Web Audio.
  - CVE-2014-3175: Various fixes from internal audits, fuzzing and other
    initiatives.
  - CVE-2014-3176, CVE-2014-3177: Interaction of extensions, IPC, the sync
    API, and Google V8 to execute arbitrary code.
* debian/checkout-orig-source.mk: Don't include src/ prefix in orig tarball.
* debian/patches/*: refresh line numbers.
* debian/patches/search-credit.patch,
  debian/patches/additional-search-engines.patch: Track source files moved.
* debian/patches/arm-neon.patch, debian/patches/ffmpeg-gyp-config.patch,
  debian/patches/fix-gyp-space-in-object-filename-exception.patch,
  debian/patches/gyp-icu-m32-test:
  Disabled. No longer needs fixing.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
--- a/chrome/browser/search_engines/prepopulated_engines.json
2
 
+++ b/chrome/browser/search_engines/prepopulated_engines.json
 
1
--- a/chrome/browser/search_engines/template_url_prepopulate_data.cc
 
2
+++ b/chrome/browser/search_engines/template_url_prepopulate_data.cc
 
3
@@ -49,7 +49,7 @@ namespace {
 
4
 
 
5
 // Default (for countries with no better engine set)
 
6
 const PrepopulatedEngine* engines_default[] =
 
7
-    { &google, &bing, &yahoo, };
 
8
+    { &google, &bing, &yahoo, &duckduckgo, };
 
9
 
 
10
 // United Arab Emirates
 
11
 const PrepopulatedEngine* engines_AE[] =
 
12
@@ -141,7 +141,7 @@ const PrepopulatedEngine* engines_CZ[] =
 
13
 
 
14
 // Germany
 
15
 const PrepopulatedEngine* engines_DE[] =
 
16
-    { &google, &bing_de_DE, &yahoo_de };
 
17
+    { &google, &bing_de_DE, &yahoo_de, &duckduckgo, };
 
18
 
 
19
 // Denmark
 
20
 const PrepopulatedEngine* engines_DK[] =
 
21
@@ -181,11 +181,11 @@ const PrepopulatedEngine* engines_FI[] =
 
22
 
 
23
 // France
 
24
 const PrepopulatedEngine* engines_FR[] =
 
25
-    { &google, &bing_fr_FR, &yahoo_fr, };
 
26
+    { &google, &bing_fr_FR, &yahoo_fr, &duckduckgo, };
 
27
 
 
28
 // United Kingdom
 
29
 const PrepopulatedEngine* engines_GB[] =
 
30
-    { &google, &bing_en_GB, &yahoo_uk, &ask_uk, };
 
31
+    { &google, &bing_en_GB, &yahoo_uk, &ask_uk, &duckduckgo, };
 
32
 
 
33
 // Greece
 
34
 const PrepopulatedEngine* engines_GR[] =
 
35
@@ -453,7 +453,7 @@ const PrepopulatedEngine* engines_UA[] =
 
36
 
 
37
 // United States
 
38
 const PrepopulatedEngine* engines_US[] =
 
39
-    { &google, &bing_en_US, &yahoo, &aol, &ask, };
 
40
+    { &google, &bing_en_US, &yahoo, &aol, &ask, &duckduckgo, };
 
41
 
 
42
 // Uruguay
 
43
 const PrepopulatedEngine* engines_UY[] =
 
44
@@ -491,6 +491,7 @@ const PrepopulatedEngine* kAllEngines[]
 
45
   &bing_fr_FR,   &bing_it_IT,   &bing_ja_JP,   &bing_lv_LV,   &bing_nb_NO,
 
46
   &bing_nl_BE,   &bing_pl_PL,   &bing_pt_BR,   &bing_pt_PT,   &bing_ru_RU,
 
47
   &bing_sv_SE,   &bing_tr_TR,   &bing_zh_HK,   &bing_zh_TW,   &daum,
 
48
+  &duckduckgo,
 
49
   &google,       &kvasir,       &mail_ru,      &najdi,        &naver,
 
50
   &onet,         &seznam,       &sogou,        &vinden,       &virgilio,
 
51
   &yahoo,        &yahoo_ar,     &yahoo_at,     &yahoo_au,     &yahoo_br,
 
52
--- a/components/search_engines/prepopulated_engines.json
 
53
+++ b/components/search_engines/prepopulated_engines.json
3
54
@@ -14,6 +14,7 @@
4
55
 //    88, 89, 91+
5
56
 //
34
85
     "google": {
35
86
       "name": "Google",
36
87
       "keyword": "google.com",
37
 
--- a/chrome/browser/search_engines/search_engine_type.h
38
 
+++ b/chrome/browser/search_engines/search_engine_type.h
 
88
--- a/components/search_engines/search_engine_type.h
 
89
+++ b/components/search_engines/search_engine_type.h
39
90
@@ -22,6 +22,7 @@ enum SearchEngineType {
40
91
   SEARCH_ENGINE_DAUM,
41
92
   SEARCH_ENGINE_DELFI,
44
95
   SEARCH_ENGINE_FUNMOODS,
45
96
   SEARCH_ENGINE_GOO,
46
97
   SEARCH_ENGINE_GOOGLE,
47
 
--- a/chrome/browser/search_engines/template_url_prepopulate_data.cc
48
 
+++ b/chrome/browser/search_engines/template_url_prepopulate_data.cc
49
 
@@ -52,7 +52,7 @@ namespace {
50
 
 
51
 
 // Default (for countries with no better engine set)
52
 
 const PrepopulatedEngine* engines_default[] =
53
 
-    { &google, &bing, &yahoo, };
54
 
+    { &google, &bing, &yahoo, &duckduckgo, };
55
 
 
56
 
 // United Arab Emirates
57
 
 const PrepopulatedEngine* engines_AE[] =
58
 
@@ -144,7 +144,7 @@ const PrepopulatedEngine* engines_CZ[] =
59
 
 
60
 
 // Germany
61
 
 const PrepopulatedEngine* engines_DE[] =
62
 
-    { &google, &bing_de_DE, &yahoo_de };
63
 
+    { &google, &bing_de_DE, &yahoo_de, &duckduckgo, };
64
 
 
65
 
 // Denmark
66
 
 const PrepopulatedEngine* engines_DK[] =
67
 
@@ -184,11 +184,11 @@ const PrepopulatedEngine* engines_FI[] =
68
 
 
69
 
 // France
70
 
 const PrepopulatedEngine* engines_FR[] =
71
 
-    { &google, &bing_fr_FR, &yahoo_fr, };
72
 
+    { &google, &bing_fr_FR, &yahoo_fr, &duckduckgo, };
73
 
 
74
 
 // United Kingdom
75
 
 const PrepopulatedEngine* engines_GB[] =
76
 
-    { &google, &bing_en_GB, &yahoo_uk, &ask_uk, };
77
 
+    { &google, &bing_en_GB, &yahoo_uk, &ask_uk, &duckduckgo, };
78
 
 
79
 
 // Greece
80
 
 const PrepopulatedEngine* engines_GR[] =
81
 
@@ -456,7 +456,7 @@ const PrepopulatedEngine* engines_UA[] =
82
 
 
83
 
 // United States
84
 
 const PrepopulatedEngine* engines_US[] =
85
 
-    { &google, &bing_en_US, &yahoo, &aol, &ask, };
86
 
+    { &google, &bing_en_US, &yahoo, &aol, &ask, &duckduckgo, };
87
 
 
88
 
 // Uruguay
89
 
 const PrepopulatedEngine* engines_UY[] =
90
 
@@ -494,6 +494,7 @@ const PrepopulatedEngine* kAllEngines[]
91
 
   &bing_fr_FR,   &bing_it_IT,   &bing_ja_JP,   &bing_lv_LV,   &bing_nb_NO,
92
 
   &bing_nl_BE,   &bing_pl_PL,   &bing_pt_BR,   &bing_pt_PT,   &bing_ru_RU,
93
 
   &bing_sv_SE,   &bing_tr_TR,   &bing_zh_HK,   &bing_zh_TW,   &daum,
94
 
+  &duckduckgo,
95
 
   &google,       &kvasir,       &mail_ru,      &najdi,        &naver,
96
 
   &onet,         &seznam,       &sogou,        &vinden,       &virgilio,
97
 
   &yahoo,        &yahoo_ar,     &yahoo_at,     &yahoo_au,     &yahoo_br,