~chromium-team/chromium-browser/artful-beta

« back to all changes in this revision

Viewing changes to debian/patches/arm.patch

  • Committer: Chad MILLER
  • Date: 2014-08-28 16:59:07 UTC
  • Revision ID: chad.miller@canonical.com-20140828165907-i3gnn72j3gqopspi
* Upstream release 37.0.2062.94. There is no official tarball.
  - CVE-2014-3165: Use-after-free in Blink websockets.
  - CVE-2014-3176, CVE-2014-3177: A combination of bugs in V8, IPC, sync, and
    extensions that can lead to remote code execution outside of the sandbox.
  - CVE-2014-3168: Use-after-free in SVG.
  - CVE-2014-3169: Use-after-free in DOM.
  - CVE-2014-3170: Extension permission dialog spoofing.
  - CVE-2014-3171: Use-after-free in bindings.
  - CVE-2014-3172: Issue related to extension debugging.
  - CVE-2014-3173: Uninitialized memory read in WebGL.
  - CVE-2014-3174: Uninitialized memory read in Web Audio.
  - CVE-2014-3175: Various fixes from internal audits, fuzzing and other
    initiatives.
  - CVE-2014-3176, CVE-2014-3177: Interaction of extensions, IPC, the sync
    API, and Google V8 to execute arbitrary code.
* debian/checkout-orig-source.mk: Don't include src/ prefix in orig tarball.
* debian/patches/*: refresh line numbers.
* debian/patches/search-credit.patch,
  debian/patches/additional-search-engines.patch: Track source files moved.
* debian/patches/arm-neon.patch, debian/patches/ffmpeg-gyp-config.patch,
  debian/patches/fix-gyp-space-in-object-filename-exception.patch,
  debian/patches/gyp-icu-m32-test:
  Disabled. No longer needs fixing.

Show diffs side-by-side

added added

removed removed

Lines of Context:
9
9
           'sources': [
10
10
             '../third_party/skia/src/opts/memset.arm.S',
11
11
           ],
12
 
--- a/third_party/skia/gyp/skia_lib.gyp
13
 
+++ b/third_party/skia/gyp/skia_lib.gyp
14
 
@@ -10,6 +10,7 @@
15
 
       'ports.gyp:ports',
16
 
       'sfnt.gyp:sfnt',
17
 
       'utils.gyp:utils',
18
 
+      "<!(echo <(skia_arch_type) <(skia_os) 1>&2)"
19
 
     ],
20
 
     'conditions': [
21
 
       [ 'skia_arch_type == "x86" and skia_os != "android"', {
22
 
@@ -17,7 +18,7 @@
23
 
           'opts.gyp:opts_ssse3',
24
 
         ],
25
 
       }],
26
 
-      [ 'arm_neon == 1', {
27
 
+      [ '1', {
28
 
         'component_libs': [
29
 
           'opts.gyp:opts_neon',
30
 
         ],
31
12
--- a/ui/base/resource/data_pack.cc
32
13
+++ b/ui/base/resource/data_pack.cc
33
 
@@ -147,9 +147,11 @@ bool DataPack::LoadImpl() {
 
14
@@ -148,9 +148,11 @@ bool DataPack::LoadImpl() {
34
15
   // 2) Verify the entries are within the appropriate bounds. There's an extra
35
16
   // entry after the last item which gives us the length of the last item.
36
17
   for (size_t i = 0; i < resource_count_ + 1; ++i) {