~chromium-team/chromium-browser/artful-beta

« back to all changes in this revision

Viewing changes to debian/patches/display-scaling-default-value

  • Committer: Chad MILLER
  • Date: 2014-08-28 16:59:07 UTC
  • Revision ID: chad.miller@canonical.com-20140828165907-i3gnn72j3gqopspi
* Upstream release 37.0.2062.94. There is no official tarball.
  - CVE-2014-3165: Use-after-free in Blink websockets.
  - CVE-2014-3176, CVE-2014-3177: A combination of bugs in V8, IPC, sync, and
    extensions that can lead to remote code execution outside of the sandbox.
  - CVE-2014-3168: Use-after-free in SVG.
  - CVE-2014-3169: Use-after-free in DOM.
  - CVE-2014-3170: Extension permission dialog spoofing.
  - CVE-2014-3171: Use-after-free in bindings.
  - CVE-2014-3172: Issue related to extension debugging.
  - CVE-2014-3173: Uninitialized memory read in WebGL.
  - CVE-2014-3174: Uninitialized memory read in Web Audio.
  - CVE-2014-3175: Various fixes from internal audits, fuzzing and other
    initiatives.
  - CVE-2014-3176, CVE-2014-3177: Interaction of extensions, IPC, the sync
    API, and Google V8 to execute arbitrary code.
* debian/checkout-orig-source.mk: Don't include src/ prefix in orig tarball.
* debian/patches/*: refresh line numbers.
* debian/patches/search-credit.patch,
  debian/patches/additional-search-engines.patch: Track source files moved.
* debian/patches/arm-neon.patch, debian/patches/ffmpeg-gyp-config.patch,
  debian/patches/fix-gyp-space-in-object-filename-exception.patch,
  debian/patches/gyp-icu-m32-test:
  Disabled. No longer needs fixing.

Show diffs side-by-side

added added

removed removed

Lines of Context:
6
6
 
7
7
--- a/ui/views/widget/desktop_aura/desktop_screen_x11.cc
8
8
+++ b/ui/views/widget/desktop_aura/desktop_screen_x11.cc
9
 
@@ -378,11 +378,13 @@ std::vector<gfx::Display> DesktopScreenX
 
9
@@ -395,11 +395,13 @@ std::vector<gfx::Display> DesktopScreenX
10
10
       gfx::Display display(display_id, crtc_bounds);
11
11
 
12
12
       // An integer that forces discrete steps.