~chromium-team/chromium-browser/artful-beta

« back to all changes in this revision

Viewing changes to debian/patches/linker-asneeded-bug.patch

  • Committer: Chad MILLER
  • Date: 2014-08-28 16:59:07 UTC
  • Revision ID: chad.miller@canonical.com-20140828165907-i3gnn72j3gqopspi
* Upstream release 37.0.2062.94. There is no official tarball.
  - CVE-2014-3165: Use-after-free in Blink websockets.
  - CVE-2014-3176, CVE-2014-3177: A combination of bugs in V8, IPC, sync, and
    extensions that can lead to remote code execution outside of the sandbox.
  - CVE-2014-3168: Use-after-free in SVG.
  - CVE-2014-3169: Use-after-free in DOM.
  - CVE-2014-3170: Extension permission dialog spoofing.
  - CVE-2014-3171: Use-after-free in bindings.
  - CVE-2014-3172: Issue related to extension debugging.
  - CVE-2014-3173: Uninitialized memory read in WebGL.
  - CVE-2014-3174: Uninitialized memory read in Web Audio.
  - CVE-2014-3175: Various fixes from internal audits, fuzzing and other
    initiatives.
  - CVE-2014-3176, CVE-2014-3177: Interaction of extensions, IPC, the sync
    API, and Google V8 to execute arbitrary code.
* debian/checkout-orig-source.mk: Don't include src/ prefix in orig tarball.
* debian/patches/*: refresh line numbers.
* debian/patches/search-credit.patch,
  debian/patches/additional-search-engines.patch: Track source files moved.
* debian/patches/arm-neon.patch, debian/patches/ffmpeg-gyp-config.patch,
  debian/patches/fix-gyp-space-in-object-filename-exception.patch,
  debian/patches/gyp-icu-m32-test:
  Disabled. No longer needs fixing.

Show diffs side-by-side

added added

removed removed

Lines of Context:
4
4
 
5
5
--- a/build/common.gypi
6
6
+++ b/build/common.gypi
7
 
@@ -3253,7 +3253,7 @@
8
 
                   '-Wl,--as-needed',
 
7
@@ -3394,7 +3394,7 @@
 
8
                   '-fomit-frame-pointer',
9
9
                 ],
10
10
               }],
11
11
-              ['OS=="linux" and target_arch=="ia32"', {
13
13
                 'ldflags': [
14
14
                   '-Wl,--no-as-needed',
15
15
                 ],
16
 
@@ -3301,7 +3301,6 @@
 
16
@@ -3441,7 +3441,6 @@
17
17
               # Specifically tell the linker to perform optimizations.
18
18
               # See http://lwn.net/Articles/192624/ .
19
19
               '-Wl,-O1',
21
21
             ],
22
22
             'conditions' : [
23
23
               ['no_gc_sections==0', {
24
 
@@ -3345,6 +3344,11 @@
 
24
@@ -3490,6 +3489,11 @@
25
25
               }, {
26
26
                 'cflags': ['-fno-unwind-tables', '-fno-asynchronous-unwind-tables'],
27
27
               }],