~chromium-team/chromium-browser/artful-beta

« back to all changes in this revision

Viewing changes to debian/patches/search-credit.patch

  • Committer: Chad MILLER
  • Date: 2014-08-28 16:59:07 UTC
  • Revision ID: chad.miller@canonical.com-20140828165907-i3gnn72j3gqopspi
* Upstream release 37.0.2062.94. There is no official tarball.
  - CVE-2014-3165: Use-after-free in Blink websockets.
  - CVE-2014-3176, CVE-2014-3177: A combination of bugs in V8, IPC, sync, and
    extensions that can lead to remote code execution outside of the sandbox.
  - CVE-2014-3168: Use-after-free in SVG.
  - CVE-2014-3169: Use-after-free in DOM.
  - CVE-2014-3170: Extension permission dialog spoofing.
  - CVE-2014-3171: Use-after-free in bindings.
  - CVE-2014-3172: Issue related to extension debugging.
  - CVE-2014-3173: Uninitialized memory read in WebGL.
  - CVE-2014-3174: Uninitialized memory read in Web Audio.
  - CVE-2014-3175: Various fixes from internal audits, fuzzing and other
    initiatives.
  - CVE-2014-3176, CVE-2014-3177: Interaction of extensions, IPC, the sync
    API, and Google V8 to execute arbitrary code.
* debian/checkout-orig-source.mk: Don't include src/ prefix in orig tarball.
* debian/patches/*: refresh line numbers.
* debian/patches/search-credit.patch,
  debian/patches/additional-search-engines.patch: Track source files moved.
* debian/patches/arm-neon.patch, debian/patches/ffmpeg-gyp-config.patch,
  debian/patches/fix-gyp-space-in-object-filename-exception.patch,
  debian/patches/gyp-icu-m32-test:
  Disabled. No longer needs fixing.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
1
Description: Add Ubuntu id into search queries to get credit.
2
2
Author: Chad Miller <chad.miller@canonical.com>
3
3
 
4
 
--- a/chrome/browser/search_engines/prepopulated_engines.json
5
 
+++ b/chrome/browser/search_engines/prepopulated_engines.json
6
 
@@ -76,7 +76,7 @@
7
 
       "name": "\u767e\u5ea6",
8
 
       "keyword": "baidu.com",
9
 
       "favicon_url": "http://www.baidu.com/favicon.ico",
10
 
-      "search_url": "http://www.baidu.com/#ie={inputEncoding}&wd={searchTerms}",
11
 
+      "search_url": "http://www.baidu.com/#ie={inputEncoding}&tn=ubuntuu_cb&wd={searchTerms}",
12
 
       "type": "SEARCH_ENGINE_BAIDU",
13
 
       "id": 21
14
 
     },
15
4
--- a/chrome/browser/search_engines/template_url.cc
16
5
+++ b/chrome/browser/search_engines/template_url.cc
17
 
@@ -954,7 +954,7 @@ std::string TemplateURLRef::HandleReplac
 
6
@@ -1016,7 +1016,7 @@ std::string TemplateURLRef::HandleReplac
18
7
 
19
8
       case GOOGLE_SEARCH_CLIENT: {
20
9
         DCHECK(!i->is_post_param);
23
12
         if (!client.empty())
24
13
           HandleReplacement("client", client, *i, &url);
25
14
         break;
 
15
--- a/components/search_engines/prepopulated_engines.json
 
16
+++ b/components/search_engines/prepopulated_engines.json
 
17
@@ -76,7 +76,7 @@
 
18
       "name": "\u767e\u5ea6",
 
19
       "keyword": "baidu.com",
 
20
       "favicon_url": "http://www.baidu.com/favicon.ico",
 
21
-      "search_url": "http://www.baidu.com/#ie={inputEncoding}&wd={searchTerms}",
 
22
+      "search_url": "http://www.baidu.com/#ie={inputEncoding}&tn=ubuntuu_cb&wd={searchTerms}",
 
23
       "type": "SEARCH_ENGINE_BAIDU",
 
24
       "id": 21
 
25
     },