~chromium-team/chromium-browser/artful-beta

« back to all changes in this revision

Viewing changes to debian/patches/disable-sse2

  • Committer: Chad MILLER
  • Date: 2016-10-13 13:47:45 UTC
  • Revision ID: chad.miller@canonical.com-20161013134745-mvj8bxk2uhh3m0mv
* Move to using GN to build chromium.
  - debian/known_gn_gen_args
  - debian/rules
  patches
* debian/rules, lintians, installs, script: Move component libs out of
  libs/, to /usr/lib/chromium-browser/ only.
* debian/patches/do-not-use-bundled-clang: Use clang from path.
* debian/control: Express that binary packages could be on "any"
  architecture.
* Upstrem release of 54.0.2840.59:
  - CVE-2016-5181: Universal XSS in Blink.
  - CVE-2016-5182: Heap overflow in Blink.
  - CVE-2016-5183: Use after free in PDFium.
  - CVE-2016-5184: Use after free in PDFium.
  - CVE-2016-5185: Use after free in Blink.
  - CVE-2016-5187: URL spoofing.
  - CVE-2016-5188: UI spoofing.
  - CVE-2016-5192: Cross-origin bypass in Blink.
  - CVE-2016-5189: URL spoofing.
  - CVE-2016-5186: Out of bounds read in DevTools.
  - CVE-2016-5191: Universal XSS in Bookmarks.
  - CVE-2016-5190: Use after free in Internals.
  - CVE-2016-5193: Scheme bypass.
  - CVE-2016-5194: Various fixes from internal audits, fuzzing and other
    initiatives

Show diffs side-by-side

added added

removed removed

Lines of Context:
4
4
 
5
5
--- a/build/common.gypi
6
6
+++ b/build/common.gypi
7
 
@@ -3831,8 +3831,6 @@
 
7
@@ -3824,8 +3824,6 @@
8
8
                 # http://crbug.com/313032 for an example where this has "bit"
9
9
                 # us in the past.
10
10
                 'cflags': [
15
15
                 ],
16
16
--- a/cc/cc.gyp
17
17
+++ b/cc/cc.gyp
18
 
@@ -601,7 +601,7 @@
 
18
@@ -615,7 +615,7 @@
19
19
         '../build/android/increase_size_for_speed.gypi',
20
20
       ],
21
21
       'conditions': [
211
211
 }  // namespace media
212
212
--- a/media/media.gyp
213
213
+++ b/media/media.gyp
214
 
@@ -1016,7 +1016,7 @@
 
214
@@ -1023,7 +1023,7 @@
215
215
             'filters/ffmpeg_h265_to_annex_b_bitstream_converter.h',
216
216
           ],
217
217
         }],
511
511
             'skia_opts_sse41',
512
512
--- a/third_party/qcms/qcms.gyp
513
513
+++ b/third_party/qcms/qcms.gyp
514
 
@@ -50,7 +50,7 @@
 
514
@@ -43,7 +43,7 @@
515
515
             'src/transform_util.h',
516
516
           ],
517
517
           'conditions': [
520
520
               'defines': [
521
521
                 'SSE2_ENABLE',
522
522
               ],
523
 
@@ -110,4 +110,4 @@
 
523
@@ -103,4 +103,4 @@
524
524
 # tab-width:2
525
525
 # indent-tabs-mode:nil
526
526
 # End: