~chromium-team/chromium-browser/artful-beta

« back to all changes in this revision

Viewing changes to debian/patches/do-not-use-bundled-clang

  • Committer: Chad MILLER
  • Date: 2016-10-13 13:47:45 UTC
  • Revision ID: chad.miller@canonical.com-20161013134745-mvj8bxk2uhh3m0mv
* Move to using GN to build chromium.
  - debian/known_gn_gen_args
  - debian/rules
  patches
* debian/rules, lintians, installs, script: Move component libs out of
  libs/, to /usr/lib/chromium-browser/ only.
* debian/patches/do-not-use-bundled-clang: Use clang from path.
* debian/control: Express that binary packages could be on "any"
  architecture.
* Upstrem release of 54.0.2840.59:
  - CVE-2016-5181: Universal XSS in Blink.
  - CVE-2016-5182: Heap overflow in Blink.
  - CVE-2016-5183: Use after free in PDFium.
  - CVE-2016-5184: Use after free in PDFium.
  - CVE-2016-5185: Use after free in Blink.
  - CVE-2016-5187: URL spoofing.
  - CVE-2016-5188: UI spoofing.
  - CVE-2016-5192: Cross-origin bypass in Blink.
  - CVE-2016-5189: URL spoofing.
  - CVE-2016-5186: Out of bounds read in DevTools.
  - CVE-2016-5191: Universal XSS in Bookmarks.
  - CVE-2016-5190: Use after free in Internals.
  - CVE-2016-5193: Scheme bypass.
  - CVE-2016-5194: Various fixes from internal audits, fuzzing and other
    initiatives

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
--- a/build/config/linux/gconf/BUILD.gn
 
2
+++ b/build/config/linux/gconf/BUILD.gn
 
3
@@ -11,7 +11,7 @@ assert(!is_chromeos && use_gconf)
 
4
 # These packages should _only_ be expected when building for a target.
 
5
 # If these extra checks are not run, gconf is required when building host
 
6
 # tools for a CrOS build.
 
7
-assert(current_toolchain == default_toolchain)
 
8
+#assert(current_toolchain == default_toolchain)
 
9
 
 
10
 pkg_config("gconf") {
 
11
   packages = [ "gconf-2.0" ]
 
12
--- a/build/toolchain/gcc_toolchain.gni
 
13
+++ b/build/toolchain/gcc_toolchain.gni
 
14
@@ -453,9 +453,8 @@ template("clang_toolchain") {
 
15
   }
 
16
 
 
17
   gcc_toolchain(target_name) {
 
18
-    prefix = rebase_path("$clang_base_path/bin", root_build_dir)
 
19
-    cc = "$prefix/clang"
 
20
-    cxx = "$prefix/clang++"
 
21
+    cc = "clang"
 
22
+    cxx = "clang++"
 
23
     ld = cxx
 
24
 
 
25
     readelf = "${toolprefix}readelf"