~chromium-team/chromium-browser/artful-beta

« back to all changes in this revision

Viewing changes to debian/patches/fix_building_widevinecdm_with_chromium.patch

  • Committer: Chad MILLER
  • Date: 2016-10-13 13:47:45 UTC
  • Revision ID: chad.miller@canonical.com-20161013134745-mvj8bxk2uhh3m0mv
* Move to using GN to build chromium.
  - debian/known_gn_gen_args
  - debian/rules
  patches
* debian/rules, lintians, installs, script: Move component libs out of
  libs/, to /usr/lib/chromium-browser/ only.
* debian/patches/do-not-use-bundled-clang: Use clang from path.
* debian/control: Express that binary packages could be on "any"
  architecture.
* Upstrem release of 54.0.2840.59:
  - CVE-2016-5181: Universal XSS in Blink.
  - CVE-2016-5182: Heap overflow in Blink.
  - CVE-2016-5183: Use after free in PDFium.
  - CVE-2016-5184: Use after free in PDFium.
  - CVE-2016-5185: Use after free in Blink.
  - CVE-2016-5187: URL spoofing.
  - CVE-2016-5188: UI spoofing.
  - CVE-2016-5192: Cross-origin bypass in Blink.
  - CVE-2016-5189: URL spoofing.
  - CVE-2016-5186: Out of bounds read in DevTools.
  - CVE-2016-5191: Universal XSS in Bookmarks.
  - CVE-2016-5190: Use after free in Internals.
  - CVE-2016-5193: Scheme bypass.
  - CVE-2016-5194: Various fixes from internal audits, fuzzing and other
    initiatives

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
1
--- a/chrome/common/chrome_content_client.cc
2
2
+++ b/chrome/common/chrome_content_client.cc
3
 
@@ -207,9 +207,8 @@ void ComputeBuiltInPlugins(std::vector<c
 
3
@@ -208,9 +208,8 @@ void ComputeBuiltInPlugins(std::vector<c
4
4
     widevine_cdm.path = adapter_path;
5
5
     widevine_cdm.name = kWidevineCdmDisplayName;
6
6
     widevine_cdm.description =