~chromium-team/chromium-browser/artful-beta

« back to all changes in this revision

Viewing changes to debian/patches/gsettings-display-scaling

  • Committer: Chad MILLER
  • Date: 2016-10-13 13:47:45 UTC
  • Revision ID: chad.miller@canonical.com-20161013134745-mvj8bxk2uhh3m0mv
* Move to using GN to build chromium.
  - debian/known_gn_gen_args
  - debian/rules
  patches
* debian/rules, lintians, installs, script: Move component libs out of
  libs/, to /usr/lib/chromium-browser/ only.
* debian/patches/do-not-use-bundled-clang: Use clang from path.
* debian/control: Express that binary packages could be on "any"
  architecture.
* Upstrem release of 54.0.2840.59:
  - CVE-2016-5181: Universal XSS in Blink.
  - CVE-2016-5182: Heap overflow in Blink.
  - CVE-2016-5183: Use after free in PDFium.
  - CVE-2016-5184: Use after free in PDFium.
  - CVE-2016-5185: Use after free in Blink.
  - CVE-2016-5187: URL spoofing.
  - CVE-2016-5188: UI spoofing.
  - CVE-2016-5192: Cross-origin bypass in Blink.
  - CVE-2016-5189: URL spoofing.
  - CVE-2016-5186: Out of bounds read in DevTools.
  - CVE-2016-5191: Universal XSS in Bookmarks.
  - CVE-2016-5190: Use after free in Internals.
  - CVE-2016-5193: Scheme bypass.
  - CVE-2016-5194: Various fixes from internal audits, fuzzing and other
    initiatives

Show diffs side-by-side

added added

removed removed

Lines of Context:
2
2
Author: Chad MILLER <chad.miller@canonical.com>
3
3
Forwarded: yes
4
4
 
 
5
--- a/build/config/linux/BUILD.gn
 
6
+++ b/build/config/linux/BUILD.gn
 
7
@@ -84,6 +84,10 @@ config("libresolv") {
 
8
   libs = [ "resolv" ]
 
9
 }
 
10
 
 
11
+if (use_gio) {
 
12
+  libs = [ "gio" ]
 
13
+}
 
14
+
 
15
 if (use_glib) {
 
16
   pkg_config("glib") {
 
17
     packages = [
5
18
--- a/build/linux/system.gyp
6
19
+++ b/build/linux/system.gyp
7
20
@@ -36,7 +36,12 @@