~chromium-team/chromium-browser/artful-beta

« back to all changes in this revision

Viewing changes to debian/patches/last-commit-position

  • Committer: Chad MILLER
  • Date: 2016-10-13 13:47:45 UTC
  • Revision ID: chad.miller@canonical.com-20161013134745-mvj8bxk2uhh3m0mv
* Move to using GN to build chromium.
  - debian/known_gn_gen_args
  - debian/rules
  patches
* debian/rules, lintians, installs, script: Move component libs out of
  libs/, to /usr/lib/chromium-browser/ only.
* debian/patches/do-not-use-bundled-clang: Use clang from path.
* debian/control: Express that binary packages could be on "any"
  architecture.
* Upstrem release of 54.0.2840.59:
  - CVE-2016-5181: Universal XSS in Blink.
  - CVE-2016-5182: Heap overflow in Blink.
  - CVE-2016-5183: Use after free in PDFium.
  - CVE-2016-5184: Use after free in PDFium.
  - CVE-2016-5185: Use after free in Blink.
  - CVE-2016-5187: URL spoofing.
  - CVE-2016-5188: UI spoofing.
  - CVE-2016-5192: Cross-origin bypass in Blink.
  - CVE-2016-5189: URL spoofing.
  - CVE-2016-5186: Out of bounds read in DevTools.
  - CVE-2016-5191: Universal XSS in Bookmarks.
  - CVE-2016-5190: Use after free in Internals.
  - CVE-2016-5193: Scheme bypass.
  - CVE-2016-5194: Various fixes from internal audits, fuzzing and other
    initiatives

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
--- a/tools/gn/BUILD.gn
 
2
+++ b/tools/gn/BUILD.gn
 
3
@@ -264,7 +264,6 @@ executable("gn") {
 
4
 
 
5
   deps = [
 
6
     ":gn_lib",
 
7
-    ":last_commit_position",
 
8
     "//base",
 
9
     "//build/config/sanitizers:deps",
 
10
     "//build/win:default_exe_manifest",
 
11
--- a/tools/gn/gn_main.cc
 
12
+++ b/tools/gn/gn_main.cc
 
13
@@ -12,13 +12,7 @@
 
14
 #include "tools/gn/standard_out.h"
 
15
 #include "tools/gn/switches.h"
 
16
 
 
17
-// Only the GN-generated build makes this header for now.
 
18
-// TODO(brettw) consider adding this if we need it in GYP.
 
19
-#if defined(GN_BUILD)
 
20
-#include "tools/gn/last_commit_position.h"
 
21
-#else
 
22
 #define LAST_COMMIT_POSITION "UNKNOWN"
 
23
-#endif
 
24
 
 
25
 namespace {
 
26