~chromium-team/chromium-browser/artful-beta

« back to all changes in this revision

Viewing changes to debian/patches/linker-asneeded-bug.patch

  • Committer: Chad MILLER
  • Date: 2016-10-13 13:47:45 UTC
  • Revision ID: chad.miller@canonical.com-20161013134745-mvj8bxk2uhh3m0mv
* Move to using GN to build chromium.
  - debian/known_gn_gen_args
  - debian/rules
  patches
* debian/rules, lintians, installs, script: Move component libs out of
  libs/, to /usr/lib/chromium-browser/ only.
* debian/patches/do-not-use-bundled-clang: Use clang from path.
* debian/control: Express that binary packages could be on "any"
  architecture.
* Upstrem release of 54.0.2840.59:
  - CVE-2016-5181: Universal XSS in Blink.
  - CVE-2016-5182: Heap overflow in Blink.
  - CVE-2016-5183: Use after free in PDFium.
  - CVE-2016-5184: Use after free in PDFium.
  - CVE-2016-5185: Use after free in Blink.
  - CVE-2016-5187: URL spoofing.
  - CVE-2016-5188: UI spoofing.
  - CVE-2016-5192: Cross-origin bypass in Blink.
  - CVE-2016-5189: URL spoofing.
  - CVE-2016-5186: Out of bounds read in DevTools.
  - CVE-2016-5191: Universal XSS in Bookmarks.
  - CVE-2016-5190: Use after free in Internals.
  - CVE-2016-5193: Scheme bypass.
  - CVE-2016-5194: Various fixes from internal audits, fuzzing and other
    initiatives

Show diffs side-by-side

added added

removed removed

Lines of Context:
4
4
 
5
5
--- a/build/common.gypi
6
6
+++ b/build/common.gypi
7
 
@@ -3681,7 +3681,7 @@
 
7
@@ -3674,7 +3674,7 @@
8
8
                   '-fomit-frame-pointer',
9
9
                 ],
10
10
               }],
13
13
                 'ldflags': [
14
14
                   '-Wl,--no-as-needed',
15
15
                 ],
16
 
@@ -3783,6 +3783,11 @@
 
16
@@ -3776,6 +3776,11 @@
17
17
                 'cflags': ['-fno-unwind-tables', '-fno-asynchronous-unwind-tables'],
18
18
                 'defines': ['NO_UNWIND_TABLES'],
19
19
               }],