~chromium-team/chromium-browser/artful-beta

« back to all changes in this revision

Viewing changes to debian/patches/touch-v35

  • Committer: Chad MILLER
  • Date: 2016-10-13 13:47:45 UTC
  • Revision ID: chad.miller@canonical.com-20161013134745-mvj8bxk2uhh3m0mv
* Move to using GN to build chromium.
  - debian/known_gn_gen_args
  - debian/rules
  patches
* debian/rules, lintians, installs, script: Move component libs out of
  libs/, to /usr/lib/chromium-browser/ only.
* debian/patches/do-not-use-bundled-clang: Use clang from path.
* debian/control: Express that binary packages could be on "any"
  architecture.
* Upstrem release of 54.0.2840.59:
  - CVE-2016-5181: Universal XSS in Blink.
  - CVE-2016-5182: Heap overflow in Blink.
  - CVE-2016-5183: Use after free in PDFium.
  - CVE-2016-5184: Use after free in PDFium.
  - CVE-2016-5185: Use after free in Blink.
  - CVE-2016-5187: URL spoofing.
  - CVE-2016-5188: UI spoofing.
  - CVE-2016-5192: Cross-origin bypass in Blink.
  - CVE-2016-5189: URL spoofing.
  - CVE-2016-5186: Out of bounds read in DevTools.
  - CVE-2016-5191: Universal XSS in Bookmarks.
  - CVE-2016-5190: Use after free in Internals.
  - CVE-2016-5193: Scheme bypass.
  - CVE-2016-5194: Various fixes from internal audits, fuzzing and other
    initiatives

Show diffs side-by-side

added added

removed removed

Lines of Context:
4
4
 
5
5
--- a/ui/events/devices/x11/touch_factory_x11.cc
6
6
+++ b/ui/events/devices/x11/touch_factory_x11.cc
7
 
@@ -123,7 +123,10 @@ void TouchFactory::UpdateDeviceList(Disp
 
7
@@ -122,7 +122,10 @@ void TouchFactory::UpdateDeviceList(XDis
8
8
           if (tci->mode == XIDirectTouch) {
9
9
             touch_device_lookup_[devinfo.deviceid] = true;
10
10
             touch_device_list_[devinfo.deviceid] = true;
16
16
         }
17
17
       }
18
18
       pointer_device_lookup_[devinfo.deviceid] = true;
19
 
@@ -343,8 +346,12 @@ void TouchFactory::CacheTouchscreenIds(i
 
19
@@ -342,8 +345,12 @@ void TouchFactory::CacheTouchscreenIds(i
20
20
                      return touchscreen.id == device_id;
21
21
                    });
22
22
   // Internal displays will have a vid and pid of 0. Ignore them.