~chromium-team/chromium-browser/artful-beta

« back to all changes in this revision

Viewing changes to debian/patches/revert-clang-nostdlib++.patch

  • Committer: Olivier Tilloy
  • Date: 2017-12-15 09:10:55 UTC
  • mfrom: (1358.1.57 artful-dev)
  • Revision ID: olivier.tilloy@canonical.com-20171215091055-294mdt7uh3wpkzjb
* Upstream beta channel update: 64.0.3282.24
* debian/control: update Vcs-Bzr field
* debian/rules: remove enable_hotwording build flag
* debian/patches/add-missing-cstddef-include.patch: added
* debian/patches/configuration-directory.patch: refreshed
* debian/patches/disable-sse2: refreshed
* debian/patches/enable-chromecast-by-default.patch: refreshed
* debian/patches/fix-ffmpeg-ia32-build.patch: added
* debian/patches/last-commit-position: refreshed
* debian/patches/no-xlocale-header.patch: removed, no longer needed
* debian/patches/revert-clang-nostdlib++.patch: updated
* debian/patches/revert-Xclang-instcombine-lower-dbg-declare.patch: refreshed
* debian/patches/search-credit.patch: refreshed
* debian/patches/set-rpath-on-chromium-executables.patch: refreshed
* debian/patches/suppress-newer-clang-warning-flags.patch: updated
* debian/patches/title-bar-default-system.patch-v35: refreshed
* debian/patches/touch-v35: refreshed
* debian/patches/widevine-other-locations: refreshed
* debian/known_gn_gen_args-*: remove enable_hotwording build flag

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
Description: Partially revert ff69d30 because -nostdlib++ requires clang 5.0
 
1
Description: Partially revert ff69d30 because -nostdlib++ requires clang 6.0 (unreleased)
2
2
Origin: https://chromium.googlesource.com/chromium/src/+/ff69d3018c42eb994533de337f81d417a0209913
3
3
Author: Olivier Tilloy <olivier.tilloy@canonical.com>
4
4
 
5
5
--- a/build/config/posix/BUILD.gn
6
6
+++ b/build/config/posix/BUILD.gn
7
 
@@ -58,7 +58,17 @@ config("runtime_library") {
 
7
@@ -58,7 +58,7 @@ config("runtime_library") {
8
8
     }
9
9
 
10
10
     # Make sure we don't link against libc++ or libstdc++.
11
 
-    ldflags += [ "-nostdlib++" ]
12
 
+    ldflags += [ "-nodefaultlibs" ]
13
 
+    # Unfortunately, there's no way to disable linking against just
14
 
+    # libc++ (besides using clang instead of clang++); -nodefaultlibs
15
 
+    # removes all of the default libraries, so add back the ones that we
16
 
+    # need.
17
 
+    libs += [
18
 
+      "c",
19
 
+      "m",
20
 
+      "gcc_s",
21
 
+      "rt",
22
 
+    ]
23
 
   }
24
 
 
25
 
   if (!is_mac && !is_ios && sysroot != "") {
 
11
-    if (is_clang) {
 
12
+    if (false) {
 
13
       ldflags += [ "-nostdlib++" ]
 
14
     } else {
 
15
       ldflags += [ "-nodefaultlibs" ]