~chromium-team/chromium-browser/artful-beta

« back to all changes in this revision

Viewing changes to debian/patches/6-passwordless-install-support.patch

  • Committer: Olivier Tilloy
  • Date: 2018-02-12 09:35:31 UTC
  • mfrom: (1358.1.71 artful-dev)
  • Revision ID: olivier.tilloy@canonical.com-20180212093531-8e8kr2s6xo3dligh
* Upstream beta channel update: 65.0.3325.51
* debian/rules: remove use_gconf build flag
* debian/patches/3-chrome-xid.patch: removed, unused
* debian/patches/5-desktop-integration-settings.patch: removed, unused
* debian/patches/6-passwordless-install-support.patch: removed, unused
* debian/patches/7-npapi-permission-not-defaults-to-unauthorized.patch: removed, unused
* debian/patches/additional-search-engines.patch: refreshed
* debian/patches/breakpad: removed, unused
* debian/patches/cups-include-deprecated-ppd: removed, unused
* debian/patches/define__libc_malloc.patch: refreshed
* debian/patches/disable-sse2: updated
* debian/patches/display-scaling-default-value: removed, unused
* debian/patches/do-not-use-bundled-clang: removed, unused
* debian/patches/enable-chromecast-by-default.patch: refreshed
* debian/patches/enable_vaapi_on_linux.diff: removed, unused
* debian/patches/flash-redirection: removed, unused
* debian/patches/format-flag.patch: removed, unused
* debian/patches/gpu_default_disabled: removed, unused
* debian/patches/gsettings-display-scaling: removed, unused
* debian/patches/ld-memory-32bit.patch: removed, unused
* debian/patches/linker-asneeded-bug.patch: removed, unused
* debian/patches/lp-translations-paths: removed, unused
* debian/patches/mir-ozone-module: removed, unused
* debian/patches/mir-support: removed, unused
* debian/patches/revert-Xclang-instcombine-lower-dbg-declare.patch: refreshed
* debian/patches/search-credit.patch: refreshed
* debian/patches/set-rpath-on-chromium-executables.patch: refreshed
* debian/patches/suppress-newer-clang-warning-flags.patch: refreshed
* debian/patches/title-bar-default-system.patch-v35: refreshed
* debian/patches/use-clang-versioned.patch: refreshed
* debian/patches/wayland-ozone: removed, unused
* debian/patches/xdg-settings-multiexec-desktopfiles.patch: removed, unused
* debian/known_gn_gen_args-*: remove use_gconf build flag

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
--- a/content/common/set_process_title.cc
2
 
+++ b/content/common/set_process_title.cc
3
 
@@ -69,6 +69,9 @@ void SetProcessTitleFromCommandLine(cons
4
 
     // when the full command line is not being displayed in most process
5
 
     // listings.
6
 
     prctl(PR_SET_NAME, base::FilePath(title).BaseName().value().c_str());
7
 
+
8
 
+    // Limits the exe path part in the title
9
 
+    title = base::FilePath(title).BaseName().value().c_str();
10
 
   }
11
 
 #endif  // defined(OS_LINUX)
12
 
 
13
 
--- a/content/common/set_process_title_linux.cc
14
 
+++ b/content/common/set_process_title_linux.cc
15
 
@@ -45,6 +45,7 @@
16
 
 #include <stdio.h>
17
 
 #include <string.h>
18
 
 #include <unistd.h>
19
 
+#include <stddef.h>
20
 
 
21
 
 extern char** environ;
22
 
 
23
 
@@ -88,7 +89,11 @@ void setproctitle(const char* fmt, ...)
24
 
   // Put the title in argv[0]. We have to zero out the space first since the
25
 
   // kernel doesn't actually look for a null terminator unless we make the
26
 
   // argument list longer than it started.
27
 
-  avail_size = page_end - (uintptr_t) g_main_argv[0];
28
 
+  avail_size = 0;
29
 
+  for (i = 0; g_main_argv[i]; ++i) {
30
 
+    avail_size += strlen(g_main_argv[i]) + 1;
31
 
+  }
32
 
+
33
 
   memset(g_main_argv[0], 0, avail_size);
34
 
   va_start(ap, fmt);
35
 
   if (fmt[0] == '-') {