~chromium-team/chromium-browser/artful-beta

« back to all changes in this revision

Viewing changes to debian/patches/4-chromeless-window-launch-option.patch

  • Committer: Chad Miller
  • Date: 2014-02-21 00:14:13 UTC
  • Revision ID: chad.miller@canonical.com-20140221001413-xeloyqxq52xndv72
* Upstream release 33.0.1750.115.
* debian/rules, debian/control: Switch to using ninja instead of make to
  build. Switch from CDBS to dh. Remove many old hacks.
* debian/patches/disable_gn.patch: disable broken GN before build. Temporary
  hack.

Show diffs side-by-side

added added

removed removed

Lines of Context:
99
99
   TABS_DETECTLANGUAGE,
100
100
--- a/src/chrome/browser/sessions/session_service.cc
101
101
+++ b/src/chrome/browser/sessions/session_service.cc
102
 
@@ -1556,7 +1556,8 @@
 
102
@@ -1552,7 +1552,8 @@
103
103
 bool SessionService::ShouldTrackBrowser(Browser* browser) const {
104
104
   AppType app_type = browser->is_app() ? TYPE_APP : TYPE_NORMAL;
105
105
   return browser->profile() == profile() &&
111
111
 bool SessionService::should_track_changes_for_browser_type(Browser::Type type,
112
112
--- a/src/chrome/browser/ui/browser.cc
113
113
+++ b/src/chrome/browser/ui/browser.cc
114
 
@@ -247,6 +247,7 @@
 
114
@@ -251,6 +251,7 @@
115
115
       profile(profile),
116
116
       host_desktop_type(host_desktop_type),
117
117
       app_type(APP_TYPE_HOST),
119
119
       initial_show_state(ui::SHOW_STATE_DEFAULT),
120
120
       is_session_restore(false),
121
121
       window(NULL) {
122
 
@@ -259,12 +260,23 @@
 
122
@@ -263,12 +264,23 @@
123
123
       profile(profile),
124
124
       host_desktop_type(host_desktop_type),
125
125
       app_type(APP_TYPE_HOST),
143
143
 Browser::CreateParams Browser::CreateParams::CreateForApp(
144
144
     Type type,
145
145
     const std::string& app_name,
146
 
@@ -328,6 +340,7 @@
 
146
@@ -332,6 +344,7 @@
147
147
       tab_strip_model_(new TabStripModel(tab_strip_model_delegate_.get(),
148
148
                                          params.profile)),
149
149
       app_name_(params.app_name),
151
151
       app_type_(params.app_type),
152
152
       cancel_download_confirmation_state_(NOT_PROMPTED),
153
153
       override_bounds_(params.initial_bounds),
154
 
@@ -517,6 +530,10 @@
 
154
@@ -531,6 +544,10 @@
155
155
   return find_bar_controller_.get() != NULL;
156
156
 }
157
157
 
162
162
 bool Browser::is_app() const {
163
163
   return !app_name_.empty();
164
164
 }
165
 
@@ -562,7 +579,7 @@
 
165
@@ -576,7 +593,7 @@
166
166
     return title;
167
167
 #endif
168
168
   // Don't append the app name to window titles on app frames and app popups
171
171
       title :
172
172
       l10n_util::GetStringFUTF16(IDS_BROWSER_WINDOW_TITLE_FORMAT, title);
173
173
 }
174
 
@@ -649,7 +666,8 @@
 
174
@@ -662,7 +679,8 @@
175
175
     tab_restore_service->BrowserClosing(tab_restore_service_delegate());
176
176
 #endif
177
177
 
181
181
     tab_restore_service->BrowserClosing(tab_restore_service_delegate());
182
182
 
183
183
   // TODO(sky): convert session/tab restore to use notification.
184
 
@@ -2135,20 +2153,24 @@
 
184
@@ -2150,20 +2168,24 @@
185
185
   unsigned int features = FEATURE_INFOBAR | FEATURE_DOWNLOADSHELF;
186
186
 
187
187
   if (is_type_tabbed())
208
208
   return !!(features & feature);
209
209
--- a/src/chrome/browser/ui/browser.h
210
210
+++ b/src/chrome/browser/ui/browser.h
211
 
@@ -165,6 +165,10 @@
 
211
@@ -166,6 +166,10 @@
212
212
         Profile* profile,
213
213
         chrome::HostDesktopType host_desktop_type);
214
214
 
219
219
     // The browser type.
220
220
     Type type;
221
221
 
222
 
@@ -183,6 +187,9 @@
 
222
@@ -184,6 +188,9 @@
223
223
     // Type of app (host or child). See description of AppType.
224
224
     AppType app_type;
225
225
 
229
229
     // The bounds of the window to open.
230
230
     gfx::Rect initial_bounds;
231
231
 
232
 
@@ -467,6 +474,7 @@
 
232
@@ -455,6 +462,7 @@
233
233
   bool is_type_tabbed() const { return type_ == TYPE_TABBED; }
234
234
   bool is_type_popup() const { return type_ == TYPE_POPUP; }
235
235
 
237
237
   bool is_app() const;
238
238
   bool is_devtools() const;
239
239
 
240
 
@@ -830,6 +838,8 @@
 
240
@@ -820,6 +828,8 @@
241
241
   // 2) we launch an undocked devtool window.
242
242
   std::string app_name_;
243
243
 
248
248
 
249
249
--- a/src/chrome/browser/ui/browser_command_controller.cc
250
250
+++ b/src/chrome/browser/ui/browser_command_controller.cc
251
 
@@ -4,6 +4,9 @@
252
 
 
253
 
 #include "chrome/browser/ui/browser_command_controller.h"
254
 
 
255
 
+#include <stdio.h>
256
 
+
257
 
+#include "base/command_line.h"
258
 
 #include "base/prefs/pref_service.h"
259
 
 #include "chrome/app/chrome_command_ids.h"
260
 
 #include "chrome/browser/browser_process.h"
261
 
@@ -30,6 +33,7 @@
262
 
 #include "chrome/browser/ui/tabs/tab_strip_model_utils.h"
 
251
@@ -32,6 +32,7 @@
263
252
 #include "chrome/browser/ui/webui/inspect_ui.h"
 
253
 #include "chrome/common/chrome_switches.h"
264
254
 #include "chrome/common/content_restriction.h"
265
255
+#include "chrome/common/chrome_switches.h"
266
256
 #include "chrome/common/pref_names.h"
267
257
 #include "chrome/common/profiling.h"
268
258
 #include "content/public/browser/native_web_keyboard_event.h"
269
 
@@ -846,7 +850,8 @@
 
259
@@ -860,7 +861,8 @@
270
260
 
271
261
 bool BrowserCommandController::IsShowingMainUI() {
272
262
   bool should_hide_ui = window() && window()->ShouldHideUIForFullscreen();
276
266
 }
277
267
 
278
268
 void BrowserCommandController::InitCommandState() {
279
 
@@ -861,9 +866,10 @@
 
269
@@ -875,9 +877,10 @@
280
270
 
281
271
   // Window management commands
282
272
   command_updater_.UpdateCommandEnabled(IDC_CLOSE_WINDOW, true);
289
279
   command_updater_.UpdateCommandEnabled(IDC_RESTORE_TAB, false);
290
280
 #if defined(OS_WIN) && defined(USE_ASH)
291
281
   if (browser_->host_desktop_type() != chrome::HOST_DESKTOP_TYPE_ASH)
292
 
@@ -933,20 +939,23 @@
 
282
@@ -947,20 +950,23 @@
293
283
   command_updater_.UpdateCommandEnabled(IDC_ZOOM_MINUS, true);
294
284
 
295
285
   // Show various bits of UI
317
307
 
318
308
   UpdateShowSyncState(true);
319
309
 
320
 
@@ -954,7 +963,9 @@
 
310
@@ -968,7 +974,9 @@
321
311
   bool normal_window = browser_->is_type_tabbed();
322
312
 
323
313
   // Navigation commands
328
318
 
329
319
   // Window management commands
330
320
   command_updater_.UpdateCommandEnabled(IDC_SELECT_NEXT_TAB, normal_window);
331
 
@@ -988,7 +999,9 @@
 
321
@@ -1002,7 +1010,9 @@
332
322
   command_updater_.UpdateCommandEnabled(IDC_TABPOSE, normal_window);
333
323
 
334
324
   // Show various bits of UI
339
329
 
340
330
   // The upgrade entry and the view incompatibility entry should always be
341
331
   // enabled. Whether they are visible is a separate matter determined on menu
342
 
@@ -1012,15 +1025,18 @@
 
332
@@ -1026,15 +1036,18 @@
343
333
 // static
344
334
 void BrowserCommandController::UpdateSharedCommandsForIncognitoAvailability(
345
335
     CommandUpdater* command_updater,
361
351
 
362
352
   // Bookmark manager and settings page/subpages are forced to open in normal
363
353
   // mode. For this reason we disable these commands when incognito is forced.
364
 
@@ -1028,7 +1044,8 @@
 
354
@@ -1042,7 +1055,8 @@
365
355
       incognito_availability != IncognitoModePrefs::FORCED;
366
356
   command_updater->UpdateCommandEnabled(
367
357
       IDC_SHOW_BOOKMARK_MANAGER,
371
361
   ExtensionService* extension_service = profile->GetExtensionService();
372
362
   bool enable_extensions =
373
363
       extension_service && extension_service->extensions_enabled();
374
 
@@ -1041,7 +1058,10 @@
 
364
@@ -1055,7 +1069,10 @@
375
365
 }
376
366
 
377
367
 void BrowserCommandController::UpdateCommandsForIncognitoAvailability() {
383
373
 
384
374
   if (!IsShowingMainUI()) {
385
375
     command_updater_.UpdateCommandEnabled(IDC_IMPORT_SETTINGS, false);
386
 
@@ -1066,17 +1086,20 @@
 
376
@@ -1080,17 +1097,20 @@
387
377
 
388
378
   // Window management commands
389
379
   command_updater_.UpdateCommandEnabled(IDC_DUPLICATE_TAB,
408
398
     command_updater_.UpdateCommandEnabled(IDC_OPEN_FILE, false);
409
399
 
410
400
   // Changing the encoding is not possible on Chrome-internal webpages.
411
 
@@ -1092,7 +1115,8 @@
 
401
@@ -1106,6 +1126,7 @@
412
402
 #if !defined(OS_MACOSX)
413
403
   command_updater_.UpdateCommandEnabled(
414
404
       IDC_CREATE_SHORTCUTS,
415
 
-      CanCreateApplicationShortcuts(browser_));
416
 
+      CanCreateApplicationShortcuts(browser_)
417
 
+          && !browser_->is_chromeless_mode());
418
 
 #endif
419
 
 
 
405
+         !browser_->is_chromeless_mode() &&
 
406
       CanCreateApplicationShortcuts(browser_));
420
407
   command_updater_.UpdateCommandEnabled(
421
 
@@ -1133,24 +1157,38 @@
 
408
       IDC_CREATE_HOSTED_APP,
 
409
@@ -1150,24 +1171,38 @@
422
410
 }
423
411
 
424
412
 void BrowserCommandController::UpdateCommandsForBookmarkEditing() {
462
450
 }
463
451
 
464
452
 void BrowserCommandController::UpdateCommandsForFullscreenMode() {
465
 
@@ -1277,13 +1315,14 @@
 
453
@@ -1296,13 +1331,14 @@
466
454
 
467
455
 // static
468
456
 void BrowserCommandController::UpdateOpenFileState(
501
489
   class InterstitialObserver;
502
490
--- a/src/chrome/browser/ui/browser_commands.cc
503
491
+++ b/src/chrome/browser/ui/browser_commands.cc
504
 
@@ -474,6 +474,9 @@
 
492
@@ -476,6 +476,9 @@
505
493
 }
506
494
 
507
495
 void NewTab(Browser* browser) {
559
547
 
560
548
   // For popups, we initialize widgets then set the window geometry, because
561
549
   // popups need the widgets inited before they can set the window size
562
 
@@ -975,7 +982,7 @@
 
550
@@ -979,7 +986,7 @@
563
551
 }
564
552
 
565
553
 void BrowserWindowGtk::SetFocusToLocationBar(bool select_all) {
568
556
     GetLocationBar()->FocusLocation(select_all);
569
557
 }
570
558
 
571
 
@@ -1277,6 +1284,20 @@
 
559
@@ -1283,6 +1290,20 @@
572
560
   gtk_util::SetWindowIcon(window_, browser_->profile());
573
561
 }
574
562
 
589
577
 void BrowserWindowGtk::TabDetachedAt(WebContents* contents, int index) {
590
578
   // We use index here rather than comparing |contents| because by this time
591
579
   // the model has already removed |contents| from its list, so
592
 
@@ -1287,6 +1308,23 @@
 
580
@@ -1293,6 +1314,23 @@
593
581
     UpdateDevToolsForContents(NULL);
594
582
   }
595
583
   contents_container_->DetachTab(contents);
613
601
 }
614
602
 
615
603
 void BrowserWindowGtk::ActiveWindowChanged(GdkWindow* active_window) {
616
 
@@ -2191,8 +2229,12 @@
 
604
@@ -2197,8 +2235,12 @@
617
605
 }
618
606
 
619
607
 void BrowserWindowGtk::ShowSupportedWindowFeatures() {
628
616
 
629
617
   if (IsToolbarSupported()) {
630
618
     toolbar_->Show();
631
 
@@ -2205,8 +2247,12 @@
 
619
@@ -2211,8 +2253,12 @@
632
620
 }
633
621
 
634
622
 void BrowserWindowGtk::HideUnsupportedWindowFeatures() {
643
631
 
644
632
   if (!IsToolbarSupported())
645
633
     toolbar_->Hide();
646
 
@@ -2246,7 +2292,8 @@
 
634
@@ -2252,7 +2298,8 @@
647
635
 
648
636
 bool BrowserWindowGtk::UseCustomFrame() const {
649
637
   // We don't use the custom frame for app mode windows or app window popups.
655
643
 void BrowserWindowGtk::PlaceBookmarkBar(bool is_floating) {
656
644
--- a/src/chrome/browser/ui/gtk/browser_window_gtk.h
657
645
+++ b/src/chrome/browser/ui/gtk/browser_window_gtk.h
658
 
@@ -191,6 +191,13 @@
 
646
@@ -193,6 +193,13 @@
659
647
   virtual void TabDetachedAt(content::WebContents* contents,
660
648
                              int index) OVERRIDE;
661
649
 
669
657
   // Overridden from ActiveWindowWatcherXObserver.
670
658
   virtual void ActiveWindowChanged(GdkWindow* active_window) OVERRIDE;
671
659
 
672
 
@@ -334,6 +341,9 @@
 
660
@@ -336,6 +343,9 @@
673
661
   // ctrl-l, etc.).
674
662
   void ConnectAccelerators();
675
663
 
936
924
   SkBitmap background = theme_service_->GetImageNamed(
937
925
--- a/src/chrome/browser/ui/startup/startup_browser_creator_impl.cc
938
926
+++ b/src/chrome/browser/ui/startup/startup_browser_creator_impl.cc
939
 
@@ -393,6 +393,12 @@
 
927
@@ -397,6 +397,12 @@
940
928
   } else {
941
929
     RecordLaunchModeHistogram(urls_to_open.empty() ?
942
930
                               LM_TO_BE_DECIDED : LM_WITH_URLS);
949
937
 
950
938
     ProcessLaunchURLs(process_startup, urls_to_open, desktop_type);
951
939
 
952
 
@@ -447,6 +453,16 @@
 
940
@@ -443,6 +449,16 @@
953
941
   }
954
942
 }
955
943
 
966
954
 bool StartupBrowserCreatorImpl::IsAppLaunch(std::string* app_url,
967
955
                                             std::string* app_id) {
968
956
   if (command_line_.HasSwitch(switches::kApp)) {
969
 
@@ -737,7 +753,8 @@
 
957
@@ -734,7 +750,8 @@
970
958
   // mode. Also, no pages should be opened automatically if the session
971
959
   // crashed. Otherwise it might trigger another crash, locking the user out of
972
960
   // chrome. The crash infobar is shown in this case.
976
964
                                                  profile_->GetPrefs()) &&
977
965
       !HasPendingUncleanExit(profile_)) {
978
966
     tabs = PinnedTabCodec::ReadPinnedTabs(profile_);
979
 
@@ -816,6 +833,12 @@
 
967
@@ -813,6 +830,12 @@
980
968
   if (!profile_ && browser)
981
969
     profile_ = browser->profile();
982
970
 
989
977
   if (!browser || !browser->is_type_tabbed()) {
990
978
     browser = new Browser(Browser::CreateParams(profile_, desktop_type));
991
979
   } else {
992
 
@@ -891,6 +914,11 @@
 
980
@@ -888,6 +911,11 @@
993
981
   if (!browser || !profile_ || browser->tab_strip_model()->count() == 0)
994
982
     return;
995
983
 
1017
1005
 
1018
1006
--- a/src/chrome/common/chrome_switches.cc
1019
1007
+++ b/src/chrome/common/chrome_switches.cc
1020
 
@@ -162,6 +162,9 @@
 
1008
@@ -170,6 +170,9 @@
1021
1009
 // as a dependent process of the Chrome Frame plugin.
1022
1010
 const char kChromeFrame[]                   = "chrome-frame";
1023
1011