~cszikszoy/do-plugins/fix-confluence

« back to all changes in this revision

Viewing changes to autogen.sh

  • Committer: Christopher James Halse Rogers
  • Date: 2008-07-25 06:31:03 UTC
  • Revision ID: raof@cowboylaputopu.cooperteam.net-20080725063103-r77k514l0z7kfw03
Start making autotools work again; all the plugins that currently have autofoo should be working

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
#! /bin/sh
2
 
 
3
 
PROJECT=DoPlugins
 
1
#! /bin/bash
 
2
 
 
3
function check_autotool_version () {
 
4
        which $1 &>/dev/null || {
 
5
                error "$1 is not installed, and is required to configure $PACKAGE"
 
6
        }
 
7
 
 
8
        version=$($1 --version | head -n 1 | cut -f4 -d' ')
 
9
        major=$(echo $version | cut -f1 -d.)
 
10
        minor=$(echo $version | cut -f2 -d.)
 
11
        major_check=$(echo $2 | cut -f1 -d.)
 
12
        minor_check=$(echo $2 | cut -f2 -d.)
 
13
 
 
14
        if [ $major -lt $major_check ]; then
 
15
                do_bail=yes
 
16
        elif [[ $minor -lt $minor_check && $major = $major_check ]]; then
 
17
                do_bail=yes
 
18
        fi
 
19
 
 
20
        if [ x"$do_bail" = x"yes" ]; then
 
21
                error "$1 version $2 or better is required to configure $PROJECT"
 
22
        fi
 
23
}
 
24
 
 
25
function run () {
 
26
        echo "Running $@ ..."
 
27
        $@ 2>.autogen.log || {
 
28
                cat .autogen.log 1>&2
 
29
                rm .autogen.log
 
30
                error "Could not run $1, which is required to configure $PROJECT"
 
31
        }
 
32
        rm .autogen.log
 
33
}
 
34
 
 
35
 
 
36
PROJECT=gnome-do-plugins
4
37
FILE=
5
38
CONFIGURE=configure.ac
6
39
 
17
50
ORIGDIR=`pwd`
18
51
cd $srcdir
19
52
TEST_TYPE=-f
20
 
aclocalinclude="-I . $ACLOCAL_FLAGS"
 
53
aclocalinclude="-I . -I m4/shamrock $ACLOCAL_FLAGS"
21
54
 
22
55
DIE=0
23
56
 
 
57
 
24
58
($AUTOCONF --version) < /dev/null > /dev/null 2>&1 || {
25
59
        echo
26
60
        echo "You must have autoconf installed to compile $PROJECT."
79
113
echo "Running $AUTOCONF ..."
80
114
$AUTOCONF
81
115
 
 
116
check_autotool_version intltoolize 0.35
 
117
run intltoolize --force --copy --automake
 
118
 
82
119
echo Running $srcdir/configure $conf_flags "$@" ...
83
120
$srcdir/configure --enable-maintainer-mode $conf_flags "$@" \