~drbob/+junk/diary-main

« back to all changes in this revision

Viewing changes to configure.ac

  • Committer: Philip Withnall
  • Date: 2008-05-20 21:24:47 UTC
  • Revision ID: philip@tecnocode.co.uk-20080520212447-mqaw7h0dy3ht3qyu
2008-05-20  Philip Withnall  <philip@tecnocode.co.uk>

        * src/interface.c:
        * src/interface.h:
        * src/main-window.c:
        * src/Makefile.am:
        * src/printing.c:
        * src/printing.h:
        * src/storage-manager.h:
        * data/diary.ui: Add printing support.
        * configure.ac: Remove redundant dependency on libcryptui.
        * intltool-extract.in:
        * intltool-merge.in:
        * intltool-update.in: Upgrade intltool scripts.

Show diffs side-by-side

added added

removed removed

Lines of Context:
34
34
 
35
35
AM_PROG_LIBTOOL
36
36
 
37
 
PKG_CHECK_MODULES(STANDARD, glib-2.0 gtk+-2.0 >= 2.12 gmodule-2.0 gio-2.0 sqlite3 gtkspell-2.0 gconf-2.0)
 
37
PKG_CHECK_MODULES(STANDARD, glib-2.0 gtk+-2.0 >= 2.12 gmodule-2.0 gio-2.0 sqlite3 gtkspell-2.0 gconf-2.0 cairo)
38
38
AC_SUBST(STANDARD_CFLAGS)
39
39
AC_SUBST(STANDARD_LIBS)
40
40
 
41
 
PKG_CHECK_MODULES(ENCRYPTION, cryptui-0.0)
42
 
 
43
41
dnl Check for GPGME, which doesn't provide a pkgconfig file
44
42
dnl This code courtesy of seahorse
45
43
min_gpgme_version=1.0.0
70
68
fi
71
69
 
72
70
if test $ok = "yes"; then
73
 
  GPGME_CFLAGS=`$GPGME_CONFIG --cflags`
74
 
  GPGME_LIBS=`$GPGME_CONFIG --libs`
 
71
  ENCRYPTION_CFLAGS=`$GPGME_CONFIG --cflags`
 
72
  ENCRYPTION_LIBS=`$GPGME_CONFIG --libs`
75
73
  AC_MSG_RESULT(yes)
76
74
else
77
75
  AC_MSG_ERROR(GPGME $min_gpgme_version or later needed)
78
76
fi
79
77
 
80
 
ENCRYPTION_CFLAGS="$ENCRYPTION_CFLAGS $GPGME_CFLAGS"
81
 
ENCRYPTION_LIBS="$ENCRYPTION_LIBS $GPGME_LIBS"
82
 
 
83
78
AC_SUBST(ENCRYPTION_CFLAGS)
84
79
AC_SUBST(ENCRYPTION_LIBS)
85
80