~gnome3-team/gnome-screensaver/ubuntu

« back to all changes in this revision

Viewing changes to debian/patches/12_use_dbus_service.patch

  • Committer: Robert Ancell
  • Date: 2010-12-08 04:40:34 UTC
  • Revision ID: robert.ancell@canonical.com-20101208044034-oxr91iinkcn9xfn6
* New upstream release
* debian/control:
  - Bump build-depends on libgtk3.0-dev, libgnome-desktop-3-dev,
    libgnotify4-dev
  - Use standards-version 3.9.1
  - Update Vcs-Bzr link
* debian/patches/00git_gnome_bg.patch:
* debian/patches/00git_gnome_rr.patch:
* debian/patches/00git_size_request.patch:
  - Git patches to build against latest GTK+ and libgnome-desktop

Show diffs side-by-side

added added

removed removed

Lines of Context:
4
4
Bug: https://bugzilla.gnome.org/show_bug.cgi?id=609029
5
5
Forwarded: https://bugzilla.gnome.org/show_bug.cgi?id=609029
6
6
 
7
 
diff -Nur -x '*.orig' -x '*~' gnome-screensaver-2.28.0/src/gnome-screensaver-command.c gnome-screensaver-2.28.0.new/src/gnome-screensaver-command.c
8
 
--- gnome-screensaver-2.28.0/src/gnome-screensaver-command.c    2009-08-26 09:06:12.000000000 -0700
9
 
+++ gnome-screensaver-2.28.0.new/src/gnome-screensaver-command.c        2010-02-03 12:01:26.000000000 -0800
10
 
@@ -88,19 +88,19 @@
11
 
 static GMainLoop *loop = NULL;
 
7
Index: gnome-screensaver-2.91.0/src/gnome-screensaver-command.c
 
8
===================================================================
 
9
--- gnome-screensaver-2.91.0.orig/src/gnome-screensaver-command.c       2010-10-20 04:54:37.000000000 +1100
 
10
+++ gnome-screensaver-2.91.0/src/gnome-screensaver-command.c    2010-12-08 14:44:08.701450090 +1100
 
11
@@ -270,19 +270,19 @@
 
12
 }
12
13
 
13
14
 static gboolean
14
15
-screensaver_is_running (DBusConnection *connection)
30
31
+        return success;
31
32
 }
32
33
 
33
 
 static DBusMessage *
34
 
@@ -468,7 +468,7 @@
35
 
 
36
 
         dbus_connection_setup_with_g_main (connection, NULL);
37
 
 
38
 
-        if (! screensaver_is_running (connection)) {
39
 
+        if (! screensaver_start_service (connection)) {
40
 
                 g_message ("Screensaver is not running!");
41
 
                 exit (1);
42
 
         }
 
34
 static gboolean
 
35
@@ -300,7 +300,7 @@
 
36
                 DBusMessageIter array;
 
37
                 dbus_bool_t     v;
 
38
 
 
39
-                if (!screensaver_is_running (connection)) {
 
40
+                if (!screensaver_start_service (connection)) {
 
41
                         g_message ("Screensaver is not running!");
 
42
                         goto done;
 
43
                 }