~jbicha/firefox/update-dependencies

« back to all changes in this revision

Viewing changes to debian/patches/unity-menubar.patch

  • Committer: Rico Tzschichholz
  • Date: 2017-09-26 13:22:04 UTC
  • Revision ID: ricotz@ubuntu.com-20170926132204-j4oynh4hho7yan3j
* New upstream release from the beta channel (FIREFOX_57_0b3_BUILD1)
* Update make-langpack-xpis target
  - debian/build/rules.mk
* Bump build-dep on rustc >= 1.19.0 and cargo >= 0.20
* Build-dep on clang-4.0, llvm-4.0-dev on all archs for stylo
  - update debian/control{,.in}
* Refresh patches
  - update debian/patches/ppc-no-static-sizes.patch

Show diffs side-by-side

added added

removed removed

Lines of Context:
16
16
diff --git a/browser/base/content/browser.js b/browser/base/content/browser.js
17
17
--- a/browser/base/content/browser.js
18
18
+++ b/browser/base/content/browser.js
19
 
@@ -5389,6 +5389,8 @@ function getTogglableToolbars() {
 
19
@@ -5401,6 +5401,8 @@ function getTogglableToolbars() {
20
20
   let toolbarNodes = Array.slice(gNavToolbox.childNodes);
21
21
   toolbarNodes = toolbarNodes.concat(gNavToolbox.externalToolbars);
22
22
   toolbarNodes = toolbarNodes.filter(node => node.getAttribute("toolbarname"));
54
54
diff --git a/layout/build/nsLayoutStatics.cpp b/layout/build/nsLayoutStatics.cpp
55
55
--- a/layout/build/nsLayoutStatics.cpp
56
56
+++ b/layout/build/nsLayoutStatics.cpp
57
 
@@ -125,6 +125,10 @@
 
57
@@ -126,6 +126,10 @@
58
58
 #include "mozilla/dom/ipc/IPCBlobInputStreamStorage.h"
59
59
 #include "mozilla/dom/U2FTokenManager.h"
60
60
 
65
65
 using namespace mozilla;
66
66
 using namespace mozilla::net;
67
67
 using namespace mozilla::dom;
68
 
@@ -157,6 +161,9 @@ nsLayoutStatics::Initialize()
 
68
@@ -158,6 +162,9 @@ nsLayoutStatics::Initialize()
69
69
   nsTextServicesDocument::RegisterAtoms();
70
70
   nsHTMLTags::RegisterAtoms();
71
71
   nsRDFAtoms::RegisterAtoms();
78
78
diff --git a/modules/libpref/init/all.js b/modules/libpref/init/all.js
79
79
--- a/modules/libpref/init/all.js
80
80
+++ b/modules/libpref/init/all.js
81
 
@@ -230,6 +230,9 @@ pref("dom.script_loader.bytecode_cache.s
 
81
@@ -242,6 +242,9 @@ pref("dom.script_loader.bytecode_cache.s
82
82
 pref("browser.sessionhistory.max_total_viewers", -1);
83
83
 
84
84
 pref("ui.use_native_colors", true);
347
347
new file mode 100644
348
348
--- /dev/null
349
349
+++ b/widget/gtk/nsMenu.cpp
350
 
@@ -0,0 +1,856 @@
 
350
@@ -0,0 +1,858 @@
351
351
+/* -*- Mode: C++; tab-width: 4; indent-tabs-mode: nil; c-basic-offset: 4 -*- */
352
352
+/* vim:expandtab:shiftwidth=4:tabstop=4:
353
353
+ */
383
383
+#include "nsITimer.h"
384
384
+#include "nsString.h"
385
385
+#include "nsStyleContext.h"
 
386
+#include "nsStyleContextInlines.h"
386
387
+#include "nsStyleSet.h"
387
388
+#include "nsStyleStruct.h"
388
389
+#include "nsThreadUtils.h"
482
483
+
483
484
+    RefPtr<nsStyleContext> sc;
484
485
+    if (shell->StyleSet()->IsGecko()) {
485
 
+        shell->StyleSet()->AsGecko()->ResolveStyleFor(aContent->AsElement(), nullptr);
 
486
+        sc = shell->StyleSet()->AsGecko()->ResolveStyleFor(aContent->AsElement(),
 
487
+                                                           nullptr);
486
488
+    } else {
487
 
+        shell->StyleSet()->AsServo()->ResolveStyleFor(aContent->AsElement(),
488
 
+                                                      nullptr,
489
 
+                                                      LazyComputeBehavior::Allow);
 
489
+        sc = shell->StyleSet()->AsServo()->ResolveStyleFor(aContent->AsElement(),
 
490
+                                                           nullptr,
 
491
+                                                           LazyComputeBehavior::Allow);
490
492
+    }
491
493
+
492
494
+    if (!sc) {
5305
5307
diff --git a/widget/gtk/nsWidgetFactory.cpp b/widget/gtk/nsWidgetFactory.cpp
5306
5308
--- a/widget/gtk/nsWidgetFactory.cpp
5307
5309
+++ b/widget/gtk/nsWidgetFactory.cpp
5308
 
@@ -49,6 +49,8 @@
 
5310
@@ -48,6 +48,8 @@
5309
5311
 #include "GfxInfoX11.h"
5310
5312
 #endif
5311
5313
 
5324
5326
 #ifdef NS_PRINTING
5325
5327
 NS_GENERIC_FACTORY_CONSTRUCTOR(nsDeviceContextSpecGTK)
5326
5328
 NS_GENERIC_FACTORY_CONSTRUCTOR_INIT(nsPrintOptionsGTK, Init)
5327
 
@@ -247,6 +252,7 @@ NS_DEFINE_NAMED_CID(NS_IMAGE_TO_PIXBUF_C
 
5329
@@ -225,6 +230,7 @@ NS_DEFINE_NAMED_CID(NS_IMAGE_TO_PIXBUF_C
5328
5330
 NS_DEFINE_NAMED_CID(NS_IDLE_SERVICE_CID);
5329
5331
 NS_DEFINE_NAMED_CID(NS_GFXINFO_CID);
5330
5332
 #endif
5332
5334
 
5333
5335
 
5334
5336
 static const mozilla::Module::CIDEntry kWidgetCIDs[] = {
5335
 
@@ -282,6 +288,7 @@ static const mozilla::Module::CIDEntry k
 
5337
@@ -260,6 +266,7 @@ static const mozilla::Module::CIDEntry k
5336
5338
     { &kNS_IDLE_SERVICE_CID, false, nullptr, nsIdleServiceGTKConstructor },
5337
5339
     { &kNS_GFXINFO_CID, false, nullptr, mozilla::widget::GfxInfoConstructor },
5338
5340
 #endif
5340
5342
     { nullptr }
5341
5343
 };
5342
5344
 
5343
 
@@ -319,6 +326,7 @@ static const mozilla::Module::ContractID
 
5345
@@ -297,6 +304,7 @@ static const mozilla::Module::ContractID
5344
5346
     { "@mozilla.org/widget/idleservice;1", &kNS_IDLE_SERVICE_CID },
5345
5347
     { "@mozilla.org/gfx/info;1", &kNS_GFXINFO_CID },
5346
5348
 #endif
5359
5361
 #include "mozilla/Preferences.h"
5360
5362
 #include "nsIPrefService.h"
5361
5363
 #include "nsIGConfService.h"
5362
 
@@ -5091,6 +5092,11 @@ nsWindow::HideWindowChrome(bool aShouldH
 
5364
@@ -5092,6 +5093,11 @@ nsWindow::HideWindowChrome(bool aShouldH
5363
5365
 #endif /* MOZ_X11 */
5364
5366
 }
5365
5367
 
5374
5376
diff --git a/widget/gtk/nsWindow.h b/widget/gtk/nsWindow.h
5375
5377
--- a/widget/gtk/nsWindow.h
5376
5378
+++ b/widget/gtk/nsWindow.h
5377
 
@@ -36,6 +36,8 @@
 
5379
@@ -35,6 +35,8 @@
5378
5380
 
5379
5381
 #include "IMContextWrapper.h"
5380
5382
 
5383
5385
 #undef LOG
5384
5386
 #ifdef MOZ_LOGGING
5385
5387
 
5386
 
@@ -159,6 +161,8 @@ public:
 
5388
@@ -157,6 +159,8 @@ public:
5387
5389
                                       nsIScreen* aTargetScreen = nullptr) override;
5388
5390
     virtual void       HideWindowChrome(bool aShouldHide) override;
5389
5391
 
5392
5394
     /**
5393
5395
      * GetLastUserInputTime returns a timestamp for the most recent user input
5394
5396
      * event.  This is intended for pointer grab requests (including drags).
5395
 
@@ -567,6 +571,8 @@ private:
 
5397
@@ -561,6 +565,8 @@ private:
5396
5398
     RefPtr<mozilla::widget::IMContextWrapper> mIMContext;
5397
5399
 
5398
5400
     mozilla::UniquePtr<mozilla::CurrentX11TimeGetter> mCurrentTimeGetter;
5420
5422
diff --git a/xpfe/appshell/nsWebShellWindow.cpp b/xpfe/appshell/nsWebShellWindow.cpp
5421
5423
--- a/xpfe/appshell/nsWebShellWindow.cpp
5422
5424
+++ b/xpfe/appshell/nsWebShellWindow.cpp
5423
 
@@ -75,7 +75,7 @@
 
5425
@@ -74,7 +74,7 @@
5424
5426
 
5425
5427
 #include "gfxPlatform.h"
5426
5428