~jbicha/firefox/update-dependencies

« back to all changes in this revision

Viewing changes to debian/patches/allow-lockPref-everywhere.patch

  • Committer: Rico Tzschichholz
  • Date: 2017-11-11 09:22:52 UTC
  • Revision ID: ricotz@ubuntu.com-20171111092252-wvf528q8spzj01px
* New upstream release from the beta channel (FIREFOX_58_0b2_BUILD1)
* Bump build-dep on rustc >= 1.21.0 and cargo >= 0.22
* Update patches
  - debian/patches/ppc-no-static-sizes.patch
  - debian/patches/unity-menubar.patch
  - debian/patches/allow-lockPref-everywhere.patch
  - debian/patches/revert-upstream-search-engine-changes.patch
  - debian/patches/warn-only-on-duplicates.patch
* Drop upstreamed/obsolete patches
  - debian/patches/build-ppc64-s390x-nss.patch
  - debian/patches/build-ppc64-s390x-rust.patch
* Update make-langpack-xpis target
  - debian/build/rules.mk
* Build language packs based on web extensions
  - debian/build/xpi-id.py
* Bump debhelper compat level to 9
* Drop 12.04/Precise specific changes
* Update copyright and license files
* Install watermark.svg from the onbording extension as symbolic icon
  - debian/build/rules.mk 
  - debian/firefox.dirs.in
* mozbuild/shellutil.py: Don't treat '~' character as special
  - debian/patches/dont-treat-tilde-as-special.patch
* Add Nepali language pack
  - update debian/config/locales.all
  - update debian/config/locales.shipped
  - update debian/control
* Don't pass -mfloat-abi=softfp when building webrtc on armhf
  - add debian/patches/webrtc-fix-compiler-flags-for-armhf.patch
  - update debian/patches/series
* Backport some skia fixes to fix a build failure on aarch64 against
  kernel headers that don't define HWCAP_CRC32
  - add debian/patches/skia-fix-aarch64-build-on-older-linux.patch
  - update debian/patches/series
* Refresh and re-enable unity-menubar.patch

Show diffs side-by-side

added added

removed removed

Lines of Context:
3
3
Bug: https://bugzilla.mozilla.org/show_bug.cgi?id=467738
4
4
Forwarded: https://bugzilla.mozilla.org/attachment.cgi?id=351145
5
5
 
6
 
---
7
 
 modules/libpref/src/prefapi.cpp  |    5 ++++-
8
 
 modules/libpref/src/prefapi.h    |    3 ++-
9
 
 modules/libpref/src/prefread.cpp |   11 ++++++++---
10
 
 modules/libpref/src/prefread.h   |    4 +++-
11
 
 4 files changed, 17 insertions(+), 6 deletions(-)
12
 
 
13
 
Index: firefox-trunk-50.0~a1~hg20160801r307508/modules/libpref/prefread.cpp
 
6
Index: firefox-trunk-58.0~a1~hg20171027r388661/modules/libpref/Preferences.cpp
14
7
===================================================================
15
 
--- firefox-trunk-50.0~a1~hg20160801r307508.orig/modules/libpref/prefread.cpp
16
 
+++ firefox-trunk-50.0~a1~hg20160801r307508/modules/libpref/prefread.cpp
17
 
@@ -43,6 +43,7 @@ enum {
18
 
 #define BITS_PER_HEX_DIGIT      4
 
8
--- firefox-trunk-58.0~a1~hg20171027r388661.orig/modules/libpref/Preferences.cpp
 
9
+++ firefox-trunk-58.0~a1~hg20171027r388661/modules/libpref/Preferences.cpp
 
10
@@ -1280,7 +1280,8 @@
 
11
                     PrefValue aValue,
 
12
                     PrefType aType,
 
13
                     bool aIsDefault,
 
14
-                    bool aIsStickyDefault)
 
15
+                    bool aIsStickyDefault,
 
16
+                    bool aIsLocked)
 
17
 {
 
18
   uint32_t flags = 0;
 
19
   if (aIsDefault) {
 
20
@@ -1292,6 +1293,8 @@
 
21
     flags |= kPrefForceSet;
 
22
   }
 
23
   pref_HashPref(aPref, aValue, aType, flags);
 
24
+  if (aIsLocked)
 
25
+    PREF_LockPref(aPref, true);
 
26
 }
 
27
 
 
28
 //===========================================================================
 
29
@@ -1313,7 +1316,8 @@
 
30
                            PrefValue aValue,
 
31
                            PrefType aType,
 
32
                            bool aIsDefault,
 
33
-                           bool aIsStickyDefault);
 
34
+                           bool aIsStickyDefault,
 
35
+                           bool aIsLocked);
 
36
 
 
37
 // Report any errors or warnings we encounter during parsing.
 
38
 typedef void (*PrefParseErrorReporter)(const char* aMessage,
 
39
@@ -1341,6 +1345,7 @@
 
40
   PrefType mVtype;       // PREF_{STRING,INT,BOOL}
 
41
   bool mIsDefault;       // true if (default) pref
 
42
   bool mIsStickyDefault; // true if (sticky) pref
 
43
+  bool mIsLock;          // true if (locked) pref
 
44
 };
 
45
 
 
46
 // Pref parser states.
 
47
@@ -1370,6 +1375,7 @@
 
48
 #define BITS_PER_HEX_DIGIT 4
19
49
 
20
50
 static const char kUserPref[] = "user_pref";
21
51
+static const char kLockPref[] = "lockPref";
22
52
 static const char kPref[] = "pref";
23
53
 static const char kPrefSticky[] = "sticky_pref";
24
54
 static const char kTrue[] = "true";
25
 
@@ -146,7 +147,7 @@ pref_DoCallback(PrefParseState *ps)
26
 
         break;
27
 
     }
28
 
     (*ps->reader)(ps->closure, ps->lb, value, ps->vtype, ps->fdefault,
29
 
-                  ps->fstickydefault);
30
 
+                  ps->fstickydefault, ps->flock);
31
 
     return true;
32
 
 }
33
 
 
34
 
@@ -215,6 +216,7 @@ PREF_ParseBuf(PrefParseState *ps, const
35
 
                 ps->vtype = PrefType::Invalid;
36
 
                 ps->fdefault = false;
37
 
                 ps->fstickydefault = false;
38
 
+                ps->flock = false;
 
55
@@ -1517,6 +1523,7 @@
 
56
           aPS->mVtype = PrefType::Invalid;
 
57
           aPS->mIsDefault = false;
 
58
           aPS->mIsStickyDefault = false;
 
59
+          aPS->mIsLock = false;
 
60
         }
 
61
         switch (c) {
 
62
           case '/': // begin comment block or line?
 
63
@@ -1527,11 +1534,14 @@
 
64
             break;
 
65
           case 'u': // indicating user_pref
 
66
           case 's': // indicating sticky_pref
 
67
+          case 'l': // indicating lockPref
 
68
           case 'p': // indicating pref
 
69
             if (c == 'u') {
 
70
               aPS->mStrMatch = kUserPref;
 
71
             } else if (c == 's') {
 
72
               aPS->mStrMatch = kPrefSticky;
 
73
+            } else if (c == 'l') {
 
74
+              aPS->mStrMatch = kLockPref;
 
75
             } else {
 
76
               aPS->mStrMatch = kPref;
39
77
             }
40
 
             switch (c) {
41
 
             case '/':       /* begin comment block or line? */
42
 
@@ -225,11 +227,14 @@ PREF_ParseBuf(PrefParseState *ps, const
43
 
                 break;
44
 
             case 'u':       /* indicating user_pref */
45
 
             case 's':       /* indicating sticky_pref */
46
 
+            case 'l':       /* indicating lockPref */
47
 
             case 'p':       /* indicating pref */
48
 
                 if (c == 'u') {
49
 
                   ps->smatch = kUserPref;
50
 
                 } else if (c == 's') {
51
 
                   ps->smatch = kPrefSticky;
52
 
+                } else if (c == 'l') {
53
 
+                  ps->smatch = kLockPref;
54
 
                 } else {
55
 
                   ps->smatch = kPref;
56
 
                 }
57
 
@@ -277,8 +282,10 @@ PREF_ParseBuf(PrefParseState *ps, const
58
 
         /* name parsing */
59
 
         case PREF_PARSE_UNTIL_NAME:
60
 
             if (c == '\"' || c == '\'') {
61
 
-                ps->fdefault = (ps->smatch == kPref || ps->smatch == kPrefSticky);
62
 
+                ps->fdefault = (ps->smatch == kPref || ps->smatch == kPrefSticky ||
63
 
+                                ps->smatch == kLockPref);
64
 
                 ps->fstickydefault = (ps->smatch == kPrefSticky);
65
 
+                ps->flock = (ps->smatch == kLockPref);
66
 
                 ps->quotechar = c;
67
 
                 ps->nextstate = PREF_PARSE_UNTIL_COMMA; /* return here when done */
68
 
                 state = PREF_PARSE_QUOTED_STRING;
69
 
Index: firefox-trunk-50.0~a1~hg20160801r307508/modules/libpref/prefread.h
70
 
===================================================================
71
 
--- firefox-trunk-50.0~a1~hg20160801r307508.orig/modules/libpref/prefread.h
72
 
+++ firefox-trunk-50.0~a1~hg20160801r307508/modules/libpref/prefread.h
73
 
@@ -34,7 +34,8 @@ typedef void (*PrefReader)(void       *c
74
 
                            PrefValue   val,
75
 
                            PrefType    type,
76
 
                            bool        defPref,
77
 
-                           bool        stickyPref);
78
 
+                           bool        stickyPref,
79
 
+                           bool        lockPref);
80
 
 
81
 
 /**
82
 
  * Report any errors or warnings we encounter during parsing.
83
 
@@ -62,6 +63,7 @@ typedef struct PrefParseState {
84
 
     PrefType    vtype;      /* PREF_STRING,INT,BOOL          */
85
 
     bool        fdefault;   /* true if (default) pref        */
86
 
     bool        fstickydefault; /* true if (sticky) pref     */
87
 
+    bool        flock;      /* true if (locked) pref         */
88
 
 } PrefParseState;
89
 
 
90
 
 /**
91
 
Index: firefox-trunk-50.0~a1~hg20160801r307508/modules/libpref/prefapi.cpp
92
 
===================================================================
93
 
--- firefox-trunk-50.0~a1~hg20160801r307508.orig/modules/libpref/prefapi.cpp
94
 
+++ firefox-trunk-50.0~a1~hg20160801r307508/modules/libpref/prefapi.cpp
95
 
@@ -997,7 +997,8 @@ void PREF_ReaderCallback(void       *clo
96
 
                          PrefValue   value,
97
 
                          PrefType    type,
98
 
                          bool        isDefault,
99
 
-                         bool        isStickyDefault)
100
 
+                         bool        isStickyDefault,
101
 
+                         bool        isLocked)
102
 
 
103
 
 {
104
 
     uint32_t flags = 0;
105
 
@@ -1010,4 +1011,6 @@ void PREF_ReaderCallback(void       *clo
106
 
         flags |= kPrefForceSet;
107
 
     }
108
 
     pref_HashPref(pref, value, type, flags);
109
 
+    if (isLocked)
110
 
+       PREF_LockPref(pref, true);
111
 
 }
112
 
Index: firefox-trunk-50.0~a1~hg20160801r307508/modules/libpref/prefapi.h
113
 
===================================================================
114
 
--- firefox-trunk-50.0~a1~hg20160801r307508.orig/modules/libpref/prefapi.h
115
 
+++ firefox-trunk-50.0~a1~hg20160801r307508/modules/libpref/prefapi.h
116
 
@@ -243,7 +243,8 @@ void PREF_ReaderCallback( void *closure,
117
 
                           PrefValue   value,
118
 
                           PrefType    type,
119
 
                           bool        isDefault,
120
 
-                          bool        isStickyDefault);
121
 
+                          bool        isStickyDefault,
122
 
+                          bool        isLocked);
123
 
 
124
 
 
125
 
 /*
 
78
@@ -1580,8 +1590,9 @@
 
79
       case PREF_PARSE_UNTIL_NAME:
 
80
         if (c == '\"' || c == '\'') {
 
81
           aPS->mIsDefault =
 
82
-            (aPS->mStrMatch == kPref || aPS->mStrMatch == kPrefSticky);
 
83
+            (aPS->mStrMatch == kPref || aPS->mStrMatch == kPrefSticky || aPS->mStrMatch == kLockPref);
 
84
           aPS->mIsStickyDefault = (aPS->mStrMatch == kPrefSticky);
 
85
+          aPS->mIsLock = (aPS->mStrMatch == kLockPref);
 
86
           aPS->mQuoteChar = c;
 
87
           aPS->mNextState = PREF_PARSE_UNTIL_COMMA; // return here when done
 
88
           state = PREF_PARSE_QUOTED_STRING;
 
89
@@ -1910,7 +1921,8 @@
 
90
                        value,
 
91
                        aPS->mVtype,
 
92
                        aPS->mIsDefault,
 
93
-                       aPS->mIsStickyDefault);
 
94
+                       aPS->mIsStickyDefault,
 
95
+                       aPS->mIsLock);
 
96
 
 
97
           state = PREF_PARSE_INIT;
 
98
         } else if (c == '/') {