~ken-vandine/ubuntu/natty/nfs-utils/1.2.2-4ubuntu1

« back to all changes in this revision

Viewing changes to debian/patches/01-bzero.patch

  • Committer: Bazaar Package Importer
  • Author(s): Steinar H. Gunderson
  • Date: 2007-01-05 13:38:07 UTC
  • mfrom: (1.2.6 upstream)
  • mto: This revision was merged to the branch mainline in revision 13.
  • Revision ID: james.westby@ubuntu.com-20070105133807-0nvljb85umz1gfwu
Tags: 1:1.0.11~git-20060105-2
08-dont-build-getkversion.patch: We missed tools/Makefile.in on last
refresh, so it ended up in the .diff.gz. Fix.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Index: nfs-utils-1.0.10/support/nfs/svc_socket.c
 
2
===================================================================
 
3
--- nfs-utils-1.0.10.orig/support/nfs/svc_socket.c
 
4
+++ nfs-utils-1.0.10/support/nfs/svc_socket.c
 
5
@@ -64,7 +64,7 @@ svc_socket (u_long number, int type, int
 
6
        }
 
7
     }
 
8
 
 
9
-  __bzero ((char *) &addr, sizeof (addr));
 
10
+  memset (&addr, 0, sizeof (addr));
 
11
   addr.sin_family = AF_INET;
 
12
 
 
13
   ret = getrpcbynumber_r (number, &rpcbuf, rpcdata, sizeof rpcdata,