~mozillateam/firefox/firefox-beta.xenial

« back to all changes in this revision

Viewing changes to debian/patches/libpixman-disable-vmx.patch

  • Committer: Rico Tzschichholz
  • Date: 2022-12-04 18:04:07 UTC
  • Revision ID: ricotz@ubuntu.com-20221204180407-8vpdcat5o7d224a4
* Update generated uniffi-js on armhf and i386
  - debian/build/rules.mk
  - debian/patches/uniffi-js.patch

Show diffs side-by-side

added added

removed removed

Lines of Context:
3
3
 
4
4
--- a/gfx/cairo/libpixman/src/moz.build
5
5
+++ b/gfx/cairo/libpixman/src/moz.build
6
 
@@ -99,11 +99,6 @@
7
 
             'pixman-arm-simd-asm.S',
8
 
             'pixman-arm-simd.c',
9
 
         ]
 
6
@@ -94,9 +94,6 @@ if CONFIG['INTEL_ARCHITECTURE']:
 
7
             use_mmx = True
 
8
     if CONFIG['CC_TYPE'] in ('clang', 'gcc'):
 
9
         use_mmx = True
10
10
-elif CONFIG['CPU_ARCH'] in ('ppc', 'ppc64'):
11
11
-    if CONFIG['CC_TYPE'] in ('clang', 'gcc'):
12
 
-        DEFINES['USE_VMX'] = True
13
 
-        SOURCES += ['pixman-vmx.c']
14
 
-        SOURCES['pixman-vmx.c'].flags += ['-maltivec']
15
 
 
16
 
 if CONFIG['CC_TYPE'] == 'clang':
17
 
     ASFLAGS += [
 
12
-        use_vmx = True
 
13
 # Apple's arm assembler doesn't support the same syntax as
 
14
 # the standard GNU assembler, so use the C fallback paths for now.
 
15
 # This may be fixable if clang's ARM/iOS assembler improves into a