~mozillateam/firefox/firefox-beta.xenial

« back to all changes in this revision

Viewing changes to debian/patches/unity-menubar.patch

  • Committer: Rico Tzschichholz
  • Date: 2022-12-04 18:04:07 UTC
  • Revision ID: ricotz@ubuntu.com-20221204180407-8vpdcat5o7d224a4
* Update generated uniffi-js on armhf and i386
  - debian/build/rules.mk
  - debian/patches/uniffi-js.patch

Show diffs side-by-side

added added

removed removed

Lines of Context:
3254
3254
+                          nullptr, 0, loadGroup, this, nullptr, nullptr,
3255
3255
+                          nsIRequest::LOAD_NORMAL, nullptr,
3256
3256
+                          nsIContentPolicy::TYPE_IMAGE, EmptyString(),
3257
 
+                          false, false, 0, getter_AddRefs(mImageRequest));
 
3257
+                          false, false, getter_AddRefs(mImageRequest));
3258
3258
+    }
3259
3259
+}
3260
3260
+
5045
5045
--- a/widget/gtk/nsWindow.cpp
5046
5046
+++ b/widget/gtk/nsWindow.cpp
5047
5047
@@ -7060,6 +7060,10 @@ void nsWindow::HideWindowChrome(bool aSh
5048
 
   SetWindowDecoration(aShouldHide ? BorderStyle::None : mBorderStyle);
 
5048
   SetWindowDecoration(aShouldHide ? eBorderStyle_none : mBorderStyle);
5049
5049
 }
5050
5050
 
5051
5051
+void nsWindow::SetMenuBar(UniquePtr<nsMenuBar> aMenuBar) {
5099
5099
--- a/xpcom/ds/StaticAtoms.py
5100
5100
+++ b/xpcom/ds/StaticAtoms.py
5101
5101
@@ -7,6 +7,7 @@
5102
 
     PseudoElementAtom,
5103
 
 )
 
5102
 from Atom import Atom, InheritingAnonBoxAtom, NonInheritingAnonBoxAtom
 
5103
 from Atom import PseudoElementAtom
5104
5104
 from HTMLAtoms import HTML_PARSER_ATOMS
5105
5105
+from NativeMenuAtoms import NATIVE_MENU_ATOMS
 
5106
 import sys
5106
5107
 
5107
5108
 # Static atom definitions, used to generate nsGkAtomList.h.
5108
 
 #
5109
5109
@@ -2529,7 +2530,7 @@ STATIC_ATOMS = [
5110
5110
     InheritingAnonBoxAtom("AnonBox_mozSVGForeignContent", ":-moz-svg-foreign-content"),
5111
5111
     InheritingAnonBoxAtom("AnonBox_mozSVGText", ":-moz-svg-text"),