~mozillateam/firefox/firefox-beta.xenial

« back to all changes in this revision

Viewing changes to debian/patches/dom-i386-sse2-ftbfs.patch

  • Committer: Rico Tzschichholz
  • Date: 2023-03-27 06:40:47 UTC
  • Revision ID: ricotz@ubuntu.com-20230327064047-wby4xxvgc4z27jh4
* New upstream release from the beta channel (FIREFOX_112_0b7_BUILD1)
* Drop upstreamed or obsolete patches
  - debian/patches/D172126.diff
  - debian/patches/webaudio-armhf-neon-ftbfs.patch
* Bump build-dep to python >= 3.7
  - debian/config/mozconfig.in
  - debian/control{,.in}
* Fix i386 build failure
  - debian/patches/dom-i386-sse2-ftbfs.patch
* Update patches
  - debian/patches/unity-menubar.patch

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Description: Disable SSE/SSE2 code paths when building on i386,
 
2
 because it's not available at build time. This is Debian/Ubuntu specific.
 
3
Author: Rico Tzschichholz <ricotz@ubuntu.com>
 
4
Forwarded: not-needed
 
5
 
 
6
diff -r a3447f709bef dom/base/moz.build
 
7
--- a/dom/base/moz.build
 
8
+++ b/dom/base/moz.build
 
9
@@ -525,7 +525,7 @@
 
10
 
 
11
 # Are we targeting x86-32 or x86-64?  If so, we want to include SSE2 code for
 
12
 # nsTextFragment.cpp
 
13
-if CONFIG["INTEL_ARCHITECTURE"]:
 
14
+if CONFIG["CPU_ARCH"] == "x86_64":
 
15
     SOURCES += ["nsTextFragmentSSE2.cpp"]
 
16
     SOURCES["nsTextFragmentSSE2.cpp"].flags += CONFIG["SSE2_FLAGS"]
 
17
 
 
18
diff -r a3447f709bef dom/base/nsTextFragment.cpp
 
19
--- a/dom/base/nsTextFragment.cpp
 
20
+++ b/dom/base/nsTextFragment.cpp
 
21
@@ -22,6 +22,10 @@
 
22
 #include "nsTextFragmentImpl.h"
 
23
 #include <algorithm>
 
24
 
 
25
+#if defined(__i386__)
 
26
+#undef MOZILLA_MAY_SUPPORT_SSE2
 
27
+#endif
 
28
+
 
29
 #define TEXTFRAG_WHITE_AFTER_NEWLINE 50
 
30
 #define TEXTFRAG_MAX_NEWLINES 7
 
31