~mozillateam/firefox/firefox.disco

« back to all changes in this revision

Viewing changes to debian/patches/test-integration/automation-output-junit-xml.patch

  • Committer: Chris Coulson
  • Date: 2013-06-26 16:48:05 UTC
  • Revision ID: chris.coulson@canonical.com-20130626164805-780fbdp452qapeja
* New upstream release from the beta channel (FIREFOX_23_0b1_BUILD1)
* Build conflict on python-progressbar, as having this installed causes the
  jit test harness to fail
  - update debian/control.in
* Disable unsupported W3C webgl tests
  - update debian/testing/extra/mochitest/mochitest.json
* Refresh paths for a11y tests after landing of bmo: #854868
  - update debian/testing/extra/mochitest/mochitest-chrome.json
* Make firefox-globalmenu a real transitional package
  - update debian/control.in
  - update debian/build/mozbuild.mk
* Just test the selected locale on all channels in test_langpack_chrome.js,
  rather than testing we get a correctly translated string. This is just
  way too fragile
  - update debian/testing/extra/xpcshell/package-tests/test_langpack_chrome.js
  - update d/p/test-integration/automation-output-junit-xml.patch
  - update debian/patches/unity-menubar.patch
  - update debian/patches/dont-override-general-useragent-locale.patch
  - update debian/patches/no_neon_on_arm.patch
* Drop crashtest-no-network-access.patch as the test seems to have been
  removed from the tree
* Always build the crash reporter and Breakpad symbols on supported
  architectures, even if it is disabled at run time. Will hopefully avoid
  surprises by the time we reach beta (where the crash reporter is enabled)
  - update debian/rules
  - update debian/build/mozvars.mk
  - update debian/build/mozbuild.mk
* Rename mozbuild.mk => rules.mk and mozvars.mk => config.mk
* Shut up lintian
  - update debian/copyright
* Make the transitional globalmenu package priority extra, section oldlibs
  - update debian/control.in
* Make the testsuite priority extra, section misc
  - update debian/control.in
* The testsuite shouldn't depend on essential package libc-bin
  - update debian/control.in
* Override symlink-is-self-recursive warning in the testsuite, as this is
  intentional
  - add debian/firefox-testsuite.lintian-overrides.in
* Remove the executable bit from the testsuite zip file
  - update debian/build/rules.mk
* Remove the executable bit from searchplugins
  - update debian/build/rules.mk
* Silence an embedded-library warning and some image-file-in-usr-lib warnings
  - update debian/firefox.lintian-overrides.in
* Drop firefox-gnome-support. It was only depending on libraries that are
  already guaranteed to exist when firefox is installed (mostly, glib).
  Firefox has no need to depend on libnotify for the time being either, but
  if it does again, that dependency should just be on the main package
  - update debian/control.in
  - update debian/build/rules.mk
  - remove debian/firefox-gnome-support.install.in
* Only blacklist Firefox in Apport on official builds
  - update debian/apport/blacklist.in
  - update debian/build/rules.mk
* Merge in latest desktop file translations
  - update debian/firefox.desktop.in
* Refresh patches
  - update debian/patches/dont-override-general-useragent-locale.patch
  - update debian/patches/no_neon_on_arm.patch
  - update d/p/test-integration/automation-output-junit-xml.patch
  - update d/p/test-overrides/disable-failing-python-tests.patch
  - update debian/patches/unity-menubar.patch
  - update debian/patches/fix-broken-langpack-install-manifests.patch
* Disable intl.locale.matchOS in test_bug848297.js
  - add d/p/test-fixes/xpcshell-chrome-fix-test_bug848297-with-locale-matchOS.patch
  - update debian/patches/series
* Write xpcshell test duration to the JUnit results when the test fails
  - add d/p/test-integration/xpcshell-write-time-for-failed-test.patch
  - update debian/patches/series
* Update test-fixes/mochitest-browser-plugincrash-with-no-crashreporter.patch
  to just not include the test on !MOZ_CRASHREPORTER builds
* Fix build-time xpcshell tests after landing of bmo: 597064, by
  using the python virtualenv provided by the upstream build system
  - update debian/build/testsuite.mk
  - update debian/build/rules.mk
* Fix broken Bulgarian language pack
  - update debian/patches/fix-broken-langpack-install-manifests.patch
* new upstream release from the beta channel (firefox_22_0b6_build1)

Show diffs side-by-side

added added

removed removed

Lines of Context:
3
3
Author: Chris Coulson <chris.coulson@canonical.com>
4
4
Forwarded: no
5
5
 
6
 
Index: firefox-trunk-22.0~a1~hg20130325r126070/build/automation.py.in
 
6
Index: firefox-trunk-23.0~a1~hg20130413r128668/build/automation.py.in
7
7
===================================================================
8
 
--- firefox-trunk-22.0~a1~hg20130325r126070.orig/build/automation.py.in 2013-03-25 21:20:32.999781604 +0000
9
 
+++ firefox-trunk-22.0~a1~hg20130325r126070/build/automation.py.in      2013-03-26 00:57:04.155550767 +0000
 
8
--- firefox-trunk-23.0~a1~hg20130413r128668.orig/build/automation.py.in 2013-04-14 01:23:57.043550343 +0100
 
9
+++ firefox-trunk-23.0~a1~hg20130413r128668/build/automation.py.in      2013-04-14 01:23:57.039550343 +0100
10
10
@@ -19,6 +19,8 @@
11
11
 import tempfile
12
12
 import sqlite3
16
16
 
17
17
 SCRIPT_DIR = os.path.abspath(os.path.realpath(os.path.dirname(sys.argv[0])))
18
18
 sys.path.insert(0, SCRIPT_DIR)
19
 
@@ -118,6 +120,182 @@
 
19
@@ -119,6 +121,182 @@
20
20
     self.port = port
21
21
     self.options = options
22
22
 
199
199
 class Automation(object):
200
200
   """
201
201
   Runs the browser from a script, and provides useful utilities
202
 
@@ -748,7 +926,17 @@
 
202
@@ -753,7 +931,17 @@
203
203
                       action = "append", type = "string",
204
204
                       default = [],
205
205
                       dest = "extraPrefs", metavar = "PREF=VALUE",
218
218
 
219
219
   def fillCertificateDB(self, profileDir, certPath, utilityPath, xrePath):
220
220
     pwfilePath = os.path.join(profileDir, ".crtdbpw")
221
 
@@ -1160,11 +1348,61 @@
222
 
   def checkForCrashes(self, profileDir, symbolsPath):
223
 
     return mozcrash.check_for_crashes(os.path.join(profileDir, "minidumps"), symbolsPath, test_name=self.lastTestSeen)
 
221
@@ -1165,11 +1353,61 @@
 
222
   def checkForCrashes(self, minidumpDir, symbolsPath):
 
223
     return mozcrash.check_for_crashes(minidumpDir, symbolsPath, test_name=self.lastTestSeen)
224
224
 
225
225
+  def writeXunitResults(self, xunitFile, xunitName, xunitResults):
226
226
+    doc = xml.dom.minidom.Document()
281
281
     """
282
282
     Run the app, log the duration it took to execute, return the status code.
283
283
     Kills the app if it runs for longer than |maxTime| seconds, or outputs nothing for |timeout| seconds.
284
 
@@ -1179,6 +1417,11 @@
 
284
@@ -1184,6 +1422,11 @@
285
285
     if timeout == -1:
286
286
       timeout = self.DEFAULT_TIMEOUT
287
287
 
293
293
     # copy env so we don't munge the caller's environment
294
294
     env = dict(env);
295
295
     env["NO_EM_RESTART"] = "1"
296
 
@@ -1226,9 +1469,17 @@
 
296
@@ -1231,9 +1474,17 @@
297
297
       # app is launched.
298
298
       onLaunch()
299
299
 
309
309
+      self.writeXunitResults(xunitFile, xunitName, xunitHandler.results)
310
310
+
311
311
     # Do a final check for zombie child processes.
312
 
     zombieProcesses = self.checkForZombies(processLog)
 
312
     zombieProcesses = self.checkForZombies(processLog, utilityPath, debuggerInfo)
313
313
 
314
 
Index: firefox-trunk-22.0~a1~hg20130325r126070/layout/tools/reftest/reftest.js
 
314
Index: firefox-trunk-23.0~a1~hg20130413r128668/layout/tools/reftest/reftest.js
315
315
===================================================================
316
 
--- firefox-trunk-22.0~a1~hg20130325r126070.orig/layout/tools/reftest/reftest.js        2013-03-25 21:20:32.999781604 +0000
317
 
+++ firefox-trunk-22.0~a1~hg20130325r126070/layout/tools/reftest/reftest.js     2013-03-25 21:20:32.991781605 +0000
318
 
@@ -1129,17 +1129,17 @@
 
316
--- firefox-trunk-23.0~a1~hg20130413r128668.orig/layout/tools/reftest/reftest.js        2013-04-14 01:23:57.043550343 +0100
 
317
+++ firefox-trunk-23.0~a1~hg20130413r128668/layout/tools/reftest/reftest.js     2013-04-14 01:23:57.039550343 +0100
 
318
@@ -1131,17 +1131,17 @@
319
319
         var test = gURLs[0];
320
320
         if (test.expected == EXPECTED_DEATH) {
321
321
             ++gTestResults.Skip;
336
336
             gURLs.shift();
337
337
         } else {
338
338
             break;
339
 
@@ -1217,11 +1217,11 @@
 
339
@@ -1219,11 +1219,11 @@
340
340
             if (e == "bad pref") {
341
341
                 var test = gURLs[0];
342
342
                 if (test.expected == EXPECTED_FAIL) {
350
350
                              " | " + badPref + " not known or wrong type\n");
351
351
                     ++gTestResults.UnexpectedFail;
352
352
                 }
353
 
Index: firefox-trunk-22.0~a1~hg20130325r126070/layout/tools/reftest/runreftest.py
 
353
Index: firefox-trunk-23.0~a1~hg20130413r128668/layout/tools/reftest/runreftest.py
354
354
===================================================================
355
 
--- firefox-trunk-22.0~a1~hg20130325r126070.orig/layout/tools/reftest/runreftest.py     2013-03-25 21:20:32.999781604 +0000
356
 
+++ firefox-trunk-22.0~a1~hg20130325r126070/layout/tools/reftest/runreftest.py  2013-03-25 21:20:32.991781605 +0000
 
355
--- firefox-trunk-23.0~a1~hg20130413r128668.orig/layout/tools/reftest/runreftest.py     2013-04-14 01:23:57.043550343 +0100
 
356
+++ firefox-trunk-23.0~a1~hg20130413r128668/layout/tools/reftest/runreftest.py  2013-04-14 01:23:57.039550343 +0100
357
357
@@ -120,6 +120,15 @@
358
358
       reftestlist = self.getManifestPath(testPath)
359
359
       if cmdlineArgs == None:
394
394
     self.set_defaults(**defaults)
395
395
 
396
396
   def verifyCommonOptions(self, options, reftest):
397
 
Index: firefox-trunk-22.0~a1~hg20130325r126070/testing/mochitest/runtests.py
 
397
Index: firefox-trunk-23.0~a1~hg20130413r128668/testing/mochitest/runtests.py
398
398
===================================================================
399
 
--- firefox-trunk-22.0~a1~hg20130325r126070.orig/testing/mochitest/runtests.py  2013-03-25 21:20:32.999781604 +0000
400
 
+++ firefox-trunk-22.0~a1~hg20130325r126070/testing/mochitest/runtests.py       2013-03-25 21:20:32.995781605 +0000
 
399
--- firefox-trunk-23.0~a1~hg20130413r128668.orig/testing/mochitest/runtests.py  2013-04-14 01:23:57.043550343 +0100
 
400
+++ firefox-trunk-23.0~a1~hg20130413r128668/testing/mochitest/runtests.py       2013-04-14 01:23:57.039550343 +0100
401
401
@@ -707,6 +707,28 @@
402
402
                                     "VMware recording: (%s)" % str(e))
403
403
       self.vmwareHelper = None
427
427
   def runTests(self, options, onLaunch=None):
428
428
     """ Prepare, configure, run tests and cleanup """
429
429
     debuggerInfo = getDebuggerInfo(self.oldcwd, options.debugger, options.debuggerArgs,
430
 
@@ -753,6 +775,8 @@
 
430
@@ -754,6 +776,8 @@
431
431
     if options.vmwareRecording:
432
432
       self.startVMwareRecording(options);
433
433
 
436
436
     self.automation.log.info("INFO | runtests.py | Running tests: start.\n")
437
437
     try:
438
438
       status = self.automation.runApp(testURL, browserEnv, options.app,
439
 
@@ -764,7 +788,10 @@
 
439
@@ -765,7 +789,10 @@
440
440
                                   debuggerInfo=debuggerInfo,
441
441
                                   symbolsPath=options.symbolsPath,
442
442
                                   timeout=timeout,