1
Index: firefox-22.0~b2+build1/browser/base/content/browser-menubar.inc
1
Index: firefox-23.0~a2~hg20130521r138523/browser/base/content/browser-menubar.inc
2
2
===================================================================
3
--- firefox-22.0~b2+build1.orig/browser/base/content/browser-menubar.inc 2013-05-22 10:22:45.000000000 +0100
4
+++ firefox-22.0~b2+build1/browser/base/content/browser-menubar.inc 2013-05-22 14:48:35.000000000 +0100
3
--- firefox-23.0~a2~hg20130521r138523.orig/browser/base/content/browser-menubar.inc 2013-05-22 12:59:58.948485674 +0100
4
+++ firefox-23.0~a2~hg20130521r138523/browser/base/content/browser-menubar.inc 2013-05-22 12:59:58.932485674 +0100
7
7
<menubar id="main-menubar"
14
14
this.setAttribute('openedwithkey',
15
15
event.target.parentNode.openedWithKey);"
16
16
style="border:0px;padding:0px;margin:0px;-moz-appearance:none">
17
Index: firefox-22.0~b2+build1/browser/base/content/browser.css
17
Index: firefox-23.0~a2~hg20130521r138523/browser/base/content/browser.css
18
18
===================================================================
19
--- firefox-22.0~b2+build1.orig/browser/base/content/browser.css 2013-05-22 10:22:45.000000000 +0100
20
+++ firefox-22.0~b2+build1/browser/base/content/browser.css 2013-05-22 14:48:35.000000000 +0100
19
--- firefox-23.0~a2~hg20130521r138523.orig/browser/base/content/browser.css 2013-05-22 12:59:58.948485674 +0100
20
+++ firefox-23.0~a2~hg20130521r138523/browser/base/content/browser.css 2013-05-22 12:59:58.932485674 +0100
22
22
#appmenu-toolbar-button > .toolbarbutton-text {
31
31
#appmenu_offlineModeRecovery:not([checked=true]) {
33
#toolbar-menubar:not([autohide="true"]) > #personal-bookmarks > #bookmarks-menu-button {
37
+%ifdef MOZ_WIDGET_GTK
38
+window[shellshowingmenubar="true"] #nav-bar > #bookmarks-menu-button-container,
39
+window[shellshowingmenubar="true"] #personal-bookmarks > #bookmarks-menu-button {
45
#editBMPanel_tagsSelector {
46
Index: firefox-22.0~b2+build1/browser/base/content/browser.js
32
Index: firefox-23.0~a2~hg20130521r138523/browser/base/content/browser.js
47
33
===================================================================
48
--- firefox-22.0~b2+build1.orig/browser/base/content/browser.js 2013-05-22 10:22:45.000000000 +0100
49
+++ firefox-22.0~b2+build1/browser/base/content/browser.js 2013-05-22 14:48:35.000000000 +0100
50
@@ -4846,6 +4846,10 @@
34
--- firefox-23.0~a2~hg20130521r138523.orig/browser/base/content/browser.js 2013-05-22 12:59:58.948485674 +0100
35
+++ firefox-23.0~a2~hg20130521r138523/browser/base/content/browser.js 2013-05-22 12:59:58.932485674 +0100
36
@@ -4471,6 +4471,10 @@
51
37
toolbarNodes.push(document.getElementById("addon-bar"));
53
39
for (let toolbar of toolbarNodes) {
58
44
let toolbarName = toolbar.getAttribute("toolbarname");
60
46
let menuItem = document.createElement("menuitem");
61
Index: firefox-22.0~b2+build1/browser/components/places/content/places.xul
47
Index: firefox-23.0~a2~hg20130521r138523/browser/components/places/content/places.xul
62
48
===================================================================
63
--- firefox-22.0~b2+build1.orig/browser/components/places/content/places.xul 2013-05-22 10:22:46.000000000 +0100
64
+++ firefox-22.0~b2+build1/browser/components/places/content/places.xul 2013-05-22 14:48:35.000000000 +0100
49
--- firefox-23.0~a2~hg20130521r138523.orig/browser/components/places/content/places.xul 2013-05-22 12:59:58.948485674 +0100
50
+++ firefox-23.0~a2~hg20130521r138523/browser/components/places/content/places.xul 2013-05-22 12:59:58.936485674 +0100
65
51
@@ -157,7 +157,7 @@
66
52
<toolbarbutton type="menu" class="tabbable"
67
53
onpopupshowing="document.getElementById('placeContent').focus()"
71
57
<menu accesskey="&organize.accesskey;" class="menu-iconic"
73
59
id="organizeButton" label="&organize.label;"
74
Index: firefox-22.0~b2+build1/modules/libpref/src/init/all.js
75
===================================================================
76
--- firefox-22.0~b2+build1.orig/modules/libpref/src/init/all.js 2013-05-22 10:22:59.000000000 +0100
77
+++ firefox-22.0~b2+build1/modules/libpref/src/init/all.js 2013-05-22 14:48:35.000000000 +0100
79
pref("browser.sessionhistory.max_total_viewers", -1);
81
pref("ui.use_native_colors", true);
82
+#ifdef MOZ_WIDGET_GTK
83
+pref("ui.use_unity_menubar", true);
85
pref("ui.click_hold_context_menus", false);
86
pref("browser.display.use_document_fonts", 1); // 0 = never, 1 = quick, 2 = always
87
pref("browser.display.use_document_colors", true);
88
Index: firefox-22.0~b2+build1/toolkit/content/widgets/popup.xml
89
===================================================================
90
--- firefox-22.0~b2+build1.orig/toolkit/content/widgets/popup.xml 2013-05-22 10:23:02.000000000 +0100
91
+++ firefox-22.0~b2+build1/toolkit/content/widgets/popup.xml 2013-05-22 14:48:35.000000000 +0100
60
Index: firefox-23.0~a2~hg20130521r138523/toolkit/content/widgets/popup.xml
61
===================================================================
62
--- firefox-23.0~a2~hg20130521r138523.orig/toolkit/content/widgets/popup.xml 2013-05-22 12:59:58.948485674 +0100
63
+++ firefox-23.0~a2~hg20130521r138523/toolkit/content/widgets/popup.xml 2013-05-22 12:59:58.936485674 +0100
107
79
<property name="triggerNode" readonly="true"
108
80
onget="return this.popupBoxObject.triggerNode"/>
109
Index: firefox-22.0~b2+build1/toolkit/content/xul.css
81
Index: firefox-23.0~a2~hg20130521r138523/toolkit/content/xul.css
110
82
===================================================================
111
--- firefox-22.0~b2+build1.orig/toolkit/content/xul.css 2013-05-22 10:23:02.000000000 +0100
112
+++ firefox-22.0~b2+build1/toolkit/content/xul.css 2013-05-22 14:48:35.000000000 +0100
83
--- firefox-23.0~a2~hg20130521r138523.orig/toolkit/content/xul.css 2013-05-22 12:59:58.948485674 +0100
84
+++ firefox-23.0~a2~hg20130521r138523/toolkit/content/xul.css 2013-05-22 12:59:58.936485674 +0100
113
85
@@ -289,6 +289,18 @@
129
101
toolbarseparator {
130
102
-moz-binding: url("chrome://global/content/bindings/toolbar.xml#toolbardecoration");
132
Index: firefox-22.0~b2+build1/widget/gtk2/Makefile.in
104
Index: firefox-23.0~a2~hg20130521r138523/widget/gtk2/Makefile.in
133
105
===================================================================
134
--- firefox-22.0~b2+build1.orig/widget/gtk2/Makefile.in 2013-05-22 10:23:03.000000000 +0100
135
+++ firefox-22.0~b2+build1/widget/gtk2/Makefile.in 2013-05-22 14:48:35.000000000 +0100
106
--- firefox-23.0~a2~hg20130521r138523.orig/widget/gtk2/Makefile.in 2013-05-22 12:59:58.948485674 +0100
107
+++ firefox-23.0~a2~hg20130521r138523/widget/gtk2/Makefile.in 2013-05-22 12:59:58.936485674 +0100
136
108
@@ -44,6 +44,15 @@
137
109
nsImageToPixbuf.cpp \
138
110
nsGtkIMModule.cpp \
157
129
-I$(topsrcdir)/layout/xul/base/src \
158
130
-I$(topsrcdir)/other-licenses/atk-1.0 \
160
Index: firefox-22.0~b2+build1/widget/gtk2/nsDbusmenu.cpp
132
Index: firefox-23.0~a2~hg20130521r138523/widget/gtk2/nsDbusmenu.cpp
161
133
===================================================================
162
134
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
163
+++ firefox-22.0~b2+build1/widget/gtk2/nsDbusmenu.cpp 2013-05-22 14:48:35.000000000 +0100
135
+++ firefox-23.0~a2~hg20130521r138523/widget/gtk2/nsDbusmenu.cpp 2013-05-22 12:59:58.936485674 +0100
165
137
+/* -*- Mode: C++; tab-width: 4; indent-tabs-mode: nil; c-basic-offset: 4 -*- */
166
138
+/* vim:expandtab:shiftwidth=4:tabstop=4:
224
Index: firefox-22.0~b2+build1/widget/gtk2/nsDbusmenu.h
196
Index: firefox-23.0~a2~hg20130521r138523/widget/gtk2/nsDbusmenu.h
225
197
===================================================================
226
198
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
227
+++ firefox-22.0~b2+build1/widget/gtk2/nsDbusmenu.h 2013-05-22 14:48:35.000000000 +0100
199
+++ firefox-23.0~a2~hg20130521r138523/widget/gtk2/nsDbusmenu.h 2013-05-22 12:59:58.936485674 +0100
229
201
+/* -*- Mode: C++; tab-width: 4; indent-tabs-mode: nil; c-basic-offset: 4 -*- */
230
202
+/* vim:expandtab:shiftwidth=4:tabstop=4:
325
297
+#define dbusmenu_menuitem_property_set_shortcut nsDbusmenuFunctions::s_dbusmenu_menuitem_property_set_shortcut
327
299
+#endif /* __nsDbusmenu_h__ */
328
Index: firefox-22.0~b2+build1/widget/gtk2/nsMenu.cpp
300
Index: firefox-23.0~a2~hg20130521r138523/widget/gtk2/nsMenu.cpp
329
301
===================================================================
330
302
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
331
+++ firefox-22.0~b2+build1/widget/gtk2/nsMenu.cpp 2013-05-22 14:53:31.424502557 +0100
303
+++ firefox-23.0~a2~hg20130521r138523/widget/gtk2/nsMenu.cpp 2013-05-22 14:27:20.956498665 +0100
332
304
@@ -0,0 +1,791 @@
333
305
+/* -*- Mode: C++; tab-width: 4; indent-tabs-mode: nil; c-basic-offset: 4 -*- */
334
306
+/* vim:expandtab:shiftwidth=4:tabstop=4:
1122
1094
+ MaybeAddPlaceholderItem();
1124
Index: firefox-22.0~b2+build1/widget/gtk2/nsMenu.h
1096
Index: firefox-23.0~a2~hg20130521r138523/widget/gtk2/nsMenu.h
1125
1097
===================================================================
1126
1098
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
1127
+++ firefox-22.0~b2+build1/widget/gtk2/nsMenu.h 2013-05-22 14:53:04.592502490 +0100
1099
+++ firefox-23.0~a2~hg20130521r138523/widget/gtk2/nsMenu.h 2013-05-22 14:26:54.516498599 +0100
1128
1100
@@ -0,0 +1,155 @@
1129
1101
+/* -*- Mode: C++; tab-width: 4; indent-tabs-mode: nil; c-basic-offset: 4 -*- */
1130
1102
+/* vim:expandtab:shiftwidth=4:tabstop=4:
1283
1255
+#endif /* __nsMenu_h__ */
1284
Index: firefox-22.0~b2+build1/widget/gtk2/nsMenuBar.cpp
1256
Index: firefox-23.0~a2~hg20130521r138523/widget/gtk2/nsMenuBar.cpp
1285
1257
===================================================================
1286
1258
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
1287
+++ firefox-22.0~b2+build1/widget/gtk2/nsMenuBar.cpp 2013-05-22 14:48:35.000000000 +0100
1259
+++ firefox-23.0~a2~hg20130521r138523/widget/gtk2/nsMenuBar.cpp 2013-05-22 12:59:58.936485674 +0100
1288
1260
@@ -0,0 +1,560 @@
1289
1261
+/* -*- Mode: C++; tab-width: 4; indent-tabs-mode: nil; c-basic-offset: 4 -*- */
1290
1262
+/* vim:expandtab:shiftwidth=4:tabstop=4:
1846
1818
+ DebugOnly<nsresult> rv = RemoveMenuObject(aChild);
1847
1819
+ NS_ASSERTION(NS_SUCCEEDED(rv), "Failed to remove item from menubar");
1849
Index: firefox-22.0~b2+build1/widget/gtk2/nsMenuBar.h
1821
Index: firefox-23.0~a2~hg20130521r138523/widget/gtk2/nsMenuBar.h
1850
1822
===================================================================
1851
1823
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
1852
+++ firefox-22.0~b2+build1/widget/gtk2/nsMenuBar.h 2013-05-22 14:48:35.000000000 +0100
1824
+++ firefox-23.0~a2~hg20130521r138523/widget/gtk2/nsMenuBar.h 2013-05-22 12:59:58.940485674 +0100
1853
1825
@@ -0,0 +1,147 @@
1854
1826
+/* -*- Mode: C++; tab-width: 4; indent-tabs-mode: nil; c-basic-offset: 4 -*- */
1855
1827
+/* vim:expandtab:shiftwidth=4:tabstop=4:
2000
1972
+#endif /* __nsMenuBar_h__ */
2001
Index: firefox-22.0~b2+build1/widget/gtk2/nsMenuItem.cpp
1973
Index: firefox-23.0~a2~hg20130521r138523/widget/gtk2/nsMenuItem.cpp
2002
1974
===================================================================
2003
1975
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
2004
+++ firefox-22.0~b2+build1/widget/gtk2/nsMenuItem.cpp 2013-05-22 14:48:35.000000000 +0100
1976
+++ firefox-23.0~a2~hg20130521r138523/widget/gtk2/nsMenuItem.cpp 2013-05-22 12:59:58.940485674 +0100
2005
1977
@@ -0,0 +1,464 @@
2006
1978
+/* -*- Mode: C++; tab-width: 4; indent-tabs-mode: nil; c-basic-offset: 4 -*- */
2007
1979
+/* vim:expandtab:shiftwidth=4:tabstop=4:
2467
2439
+ SyncAccelFromContent();
2470
Index: firefox-22.0~b2+build1/widget/gtk2/nsMenuItem.h
2442
Index: firefox-23.0~a2~hg20130521r138523/widget/gtk2/nsMenuItem.h
2471
2443
===================================================================
2472
2444
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
2473
+++ firefox-22.0~b2+build1/widget/gtk2/nsMenuItem.h 2013-05-22 14:48:35.000000000 +0100
2445
+++ firefox-23.0~a2~hg20130521r138523/widget/gtk2/nsMenuItem.h 2013-05-22 12:59:58.940485674 +0100
2474
2446
@@ -0,0 +1,114 @@
2475
2447
+/* -*- Mode: C++; tab-width: 4; indent-tabs-mode: nil; c-basic-offset: 4 -*- */
2476
2448
+/* vim:expandtab:shiftwidth=4:tabstop=4:
2588
2560
+#endif /* __nsMenuItem_h__ */
2589
Index: firefox-22.0~b2+build1/widget/gtk2/nsMenuObject.cpp
2561
Index: firefox-23.0~a2~hg20130521r138523/widget/gtk2/nsMenuObject.cpp
2590
2562
===================================================================
2591
2563
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
2592
+++ firefox-22.0~b2+build1/widget/gtk2/nsMenuObject.cpp 2013-05-22 14:48:35.000000000 +0100
2564
+++ firefox-23.0~a2~hg20130521r138523/widget/gtk2/nsMenuObject.cpp 2013-05-22 12:59:58.940485674 +0100
2594
2566
+/* -*- Mode: C++; tab-width: 4; indent-tabs-mode: nil; c-basic-offset: 4 -*- */
2595
2567
+/* vim:expandtab:shiftwidth=4:tabstop=4:
2706
2680
+ if (!mImageRect.IsEmpty()) {
2707
+ img->ExtractFrame(0, mImageRect, 0, getter_AddRefs(img));
2710
+ mOwner->ClearIcon();
2681
+ img = ImageOps::Clip(img, mImageRect);
2714
2684
+ int32_t width, height;
2715
2685
+ img->GetWidth(&width);
2716
2686
+ img->GetHeight(&height);
2688
+ if (width <= 0 || height <= 0) {
2689
+ mOwner->ClearIcon();
2718
2693
+ if (width > 100 || height > 100) {
2719
2694
+ // The icon data needs to go across DBus. Make sure the icon
2720
2695
+ // data isn't too large, else our connection gets terminated and
3279
3254
+ return aContent;
3281
Index: firefox-22.0~b2+build1/widget/gtk2/nsMenuObject.h
3256
Index: firefox-23.0~a2~hg20130521r138523/widget/gtk2/nsMenuObject.h
3282
3257
===================================================================
3283
3258
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
3284
+++ firefox-22.0~b2+build1/widget/gtk2/nsMenuObject.h 2013-05-22 14:48:35.000000000 +0100
3259
+++ firefox-23.0~a2~hg20130521r138523/widget/gtk2/nsMenuObject.h 2013-05-22 12:59:58.940485674 +0100
3285
3260
@@ -0,0 +1,180 @@
3286
3261
+/* -*- Mode: C++; tab-width: 4; indent-tabs-mode: nil; c-basic-offset: 4 -*- */
3287
3262
+/* vim:expandtab:shiftwidth=4:tabstop=4:
3465
3440
+#endif /* __nsMenuObject_h__ */
3466
Index: firefox-22.0~b2+build1/widget/gtk2/nsMenuSeparator.cpp
3441
Index: firefox-23.0~a2~hg20130521r138523/widget/gtk2/nsMenuSeparator.cpp
3467
3442
===================================================================
3468
3443
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
3469
+++ firefox-22.0~b2+build1/widget/gtk2/nsMenuSeparator.cpp 2013-05-22 14:48:35.000000000 +0100
3444
+++ firefox-23.0~a2~hg20130521r138523/widget/gtk2/nsMenuSeparator.cpp 2013-05-22 12:59:58.940485674 +0100
3470
3445
@@ -0,0 +1,65 @@
3471
3446
+/* -*- Mode: C++; tab-width: 4; indent-tabs-mode: nil; c-basic-offset: 4 -*- */
3472
3447
+/* vim:expandtab:shiftwidth=4:tabstop=4:
3534
3509
+ SyncVisibilityFromContent();
3536
Index: firefox-22.0~b2+build1/widget/gtk2/nsMenuSeparator.h
3511
Index: firefox-23.0~a2~hg20130521r138523/widget/gtk2/nsMenuSeparator.h
3537
3512
===================================================================
3538
3513
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
3539
+++ firefox-22.0~b2+build1/widget/gtk2/nsMenuSeparator.h 2013-05-22 14:48:35.000000000 +0100
3514
+++ firefox-23.0~a2~hg20130521r138523/widget/gtk2/nsMenuSeparator.h 2013-05-22 12:59:58.940485674 +0100
3540
3515
@@ -0,0 +1,48 @@
3541
3516
+/* -*- Mode: C++; tab-width: 4; indent-tabs-mode: nil; c-basic-offset: 4 -*- */
3542
3517
+/* vim:expandtab:shiftwidth=4:tabstop=4:
3588
3563
+#endif /* __nsMenuSeparator_h__ */
3589
Index: firefox-22.0~b2+build1/widget/gtk2/nsNativeMenuAtomList.h
3564
Index: firefox-23.0~a2~hg20130521r138523/widget/gtk2/nsNativeMenuAtomList.h
3590
3565
===================================================================
3591
3566
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
3592
+++ firefox-22.0~b2+build1/widget/gtk2/nsNativeMenuAtomList.h 2013-05-22 14:48:35.000000000 +0100
3567
+++ firefox-23.0~a2~hg20130521r138523/widget/gtk2/nsNativeMenuAtomList.h 2013-05-22 12:59:58.940485674 +0100
3593
3568
@@ -0,0 +1,11 @@
3594
3569
+/* -*- Mode: C++; tab-width: 4; indent-tabs-mode: nil; c-basic-offset: 4 -*- */
3595
3570
+/* vim:expandtab:shiftwidth=4:tabstop=4:
3602
3577
+WIDGET_ATOM2(_moz_menupopupstate, "_moz-menupopupstate")
3603
3578
+WIDGET_ATOM(openedwithkey)
3604
3579
+WIDGET_ATOM(shellshowingmenubar)
3605
Index: firefox-22.0~b2+build1/widget/gtk2/nsNativeMenuAtoms.cpp
3580
Index: firefox-23.0~a2~hg20130521r138523/widget/gtk2/nsNativeMenuAtoms.cpp
3606
3581
===================================================================
3607
3582
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
3608
+++ firefox-22.0~b2+build1/widget/gtk2/nsNativeMenuAtoms.cpp 2013-05-22 14:48:35.000000000 +0100
3583
+++ firefox-23.0~a2~hg20130521r138523/widget/gtk2/nsNativeMenuAtoms.cpp 2013-05-22 12:59:58.940485674 +0100
3609
3584
@@ -0,0 +1,39 @@
3610
3585
+/* -*- Mode: C++; tab-width: 4; indent-tabs-mode: nil; c-basic-offset: 4 -*- */
3611
3586
+/* vim:expandtab:shiftwidth=4:tabstop=4:
3647
3622
+ NS_RegisterStaticAtoms(gAtoms);
3649
Index: firefox-22.0~b2+build1/widget/gtk2/nsNativeMenuAtoms.h
3624
Index: firefox-23.0~a2~hg20130521r138523/widget/gtk2/nsNativeMenuAtoms.h
3650
3625
===================================================================
3651
3626
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
3652
+++ firefox-22.0~b2+build1/widget/gtk2/nsNativeMenuAtoms.h 2013-05-22 14:48:35.000000000 +0100
3627
+++ firefox-23.0~a2~hg20130521r138523/widget/gtk2/nsNativeMenuAtoms.h 2013-05-22 12:59:58.940485674 +0100
3653
3628
@@ -0,0 +1,25 @@
3654
3629
+/* -*- Mode: C++; tab-width: 4; indent-tabs-mode: nil; c-basic-offset: 4 -*- */
3655
3630
+/* vim:expandtab:shiftwidth=4:tabstop=4:
3678
3653
+#endif /* __nsNativeMenuAtoms_h__ */
3679
Index: firefox-22.0~b2+build1/widget/gtk2/nsNativeMenuDocListener.cpp
3654
Index: firefox-23.0~a2~hg20130521r138523/widget/gtk2/nsNativeMenuDocListener.cpp
3680
3655
===================================================================
3681
3656
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
3682
+++ firefox-22.0~b2+build1/widget/gtk2/nsNativeMenuDocListener.cpp 2013-05-22 14:48:35.000000000 +0100
3657
+++ firefox-23.0~a2~hg20130521r138523/widget/gtk2/nsNativeMenuDocListener.cpp 2013-05-22 12:59:58.940485674 +0100
3683
3658
@@ -0,0 +1,371 @@
3684
3659
+/* -*- Mode: C++; tab-width: 4; indent-tabs-mode: nil; c-basic-offset: 4 -*- */
3685
3660
+/* vim:expandtab:shiftwidth=4:tabstop=4:
3707
3682
+ * Small helper which caches a single listener, so that consecutive
3708
3683
+ * events which go to the same node avoid multiple hash table lookups
3710
+class DispatchHelper {
3685
+class MOZ_STACK_CLASS DispatchHelper {
3712
3687
+ DispatchHelper(nsNativeMenuDocListener *aListener,
3713
3688
+ nsIContent *aContent
4052
4027
+ UnscheduleFlush(this);
4053
4028
+ mPendingMutations.Clear();
4055
Index: firefox-22.0~b2+build1/widget/gtk2/nsNativeMenuDocListener.h
4030
Index: firefox-23.0~a2~hg20130521r138523/widget/gtk2/nsNativeMenuDocListener.h
4056
4031
===================================================================
4057
4032
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
4058
+++ firefox-22.0~b2+build1/widget/gtk2/nsNativeMenuDocListener.h 2013-05-22 14:48:35.000000000 +0100
4033
+++ firefox-23.0~a2~hg20130521r138523/widget/gtk2/nsNativeMenuDocListener.h 2013-05-22 12:59:58.940485674 +0100
4059
4034
@@ -0,0 +1,146 @@
4060
4035
+/* -*- Mode: C++; tab-width: 4; indent-tabs-mode: nil; c-basic-offset: 4 -*- */
4061
4036
+/* vim:expandtab:shiftwidth=4:tabstop=4:
4186
4161
+ * menu. This allows us to do menu updates without altering the structure
4187
4162
+ * seen by the OS.
4189
+class nsNativeMenuAutoUpdateBatch
4164
+class MOZ_STACK_CLASS nsNativeMenuAutoUpdateBatch
4192
4167
+ nsNativeMenuAutoUpdateBatch(MOZ_GUARD_OBJECT_NOTIFIER_ONLY_PARAM) {
4205
4180
+#endif /* __nsNativeMenuDocListener_h__ */
4206
Index: firefox-22.0~b2+build1/widget/gtk2/nsNativeMenuService.cpp
4181
Index: firefox-23.0~a2~hg20130521r138523/widget/gtk2/nsNativeMenuService.cpp
4207
4182
===================================================================
4208
4183
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
4209
+++ firefox-22.0~b2+build1/widget/gtk2/nsNativeMenuService.cpp 2013-05-22 14:48:35.000000000 +0100
4184
+++ firefox-23.0~a2~hg20130521r138523/widget/gtk2/nsNativeMenuService.cpp 2013-05-22 12:59:58.944485674 +0100
4210
4185
@@ -0,0 +1,503 @@
4211
4186
+/* -*- Mode: C++; tab-width: 4; indent-tabs-mode: nil; c-basic-offset: 4 -*- */
4212
4187
+/* vim:expandtab:shiftwidth=4:tabstop=4:
4712
4687
+ return NS_OK;
4714
Index: firefox-22.0~b2+build1/widget/gtk2/nsNativeMenuService.h
4689
Index: firefox-23.0~a2~hg20130521r138523/widget/gtk2/nsNativeMenuService.h
4715
4690
===================================================================
4716
4691
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
4717
+++ firefox-22.0~b2+build1/widget/gtk2/nsNativeMenuService.h 2013-05-22 14:48:35.000000000 +0100
4692
+++ firefox-23.0~a2~hg20130521r138523/widget/gtk2/nsNativeMenuService.h 2013-05-22 12:59:58.944485674 +0100
4718
4693
@@ -0,0 +1,90 @@
4719
4694
+/* -*- Mode: C++; tab-width: 4; indent-tabs-mode: nil; c-basic-offset: 4 -*- */
4720
4695
+/* vim:expandtab:shiftwidth=4:tabstop=4:
4808
4783
+#endif /* __nsNativeMenuService_h__ */
4809
Index: firefox-22.0~b2+build1/widget/gtk2/nsNativeMenuUtils.h
4784
Index: firefox-23.0~a2~hg20130521r138523/widget/gtk2/nsNativeMenuUtils.h
4810
4785
===================================================================
4811
4786
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
4812
+++ firefox-22.0~b2+build1/widget/gtk2/nsNativeMenuUtils.h 2013-05-22 14:48:35.000000000 +0100
4787
+++ firefox-23.0~a2~hg20130521r138523/widget/gtk2/nsNativeMenuUtils.h 2013-05-22 12:59:58.944485674 +0100
4813
4788
@@ -0,0 +1,70 @@
4814
4789
+/* -*- Mode: C++; tab-width: 4; indent-tabs-mode: nil; c-basic-offset: 4 -*- */
4815
4790
+/* vim:expandtab:shiftwidth=4:tabstop=4:
4883
4858
+#endif /* __nsNativeMenuUtils_h__ */
4884
Index: firefox-22.0~b2+build1/widget/gtk2/nsWidgetFactory.cpp
4859
Index: firefox-23.0~a2~hg20130521r138523/widget/gtk2/nsWidgetFactory.cpp
4885
4860
===================================================================
4886
--- firefox-22.0~b2+build1.orig/widget/gtk2/nsWidgetFactory.cpp 2013-05-22 10:23:03.000000000 +0100
4887
+++ firefox-22.0~b2+build1/widget/gtk2/nsWidgetFactory.cpp 2013-05-22 14:48:35.000000000 +0100
4861
--- firefox-23.0~a2~hg20130521r138523.orig/widget/gtk2/nsWidgetFactory.cpp 2013-05-22 12:59:58.948485674 +0100
4862
+++ firefox-23.0~a2~hg20130521r138523/widget/gtk2/nsWidgetFactory.cpp 2013-05-22 12:59:58.944485674 +0100
4888
4863
@@ -42,6 +42,9 @@
4889
4864
#include "GfxInfoX11.h"
4953
4928
nsWidgetGtk2ModuleDtor
4956
Index: firefox-22.0~b2+build1/widget/gtk2/nsWindow.cpp
4931
Index: firefox-23.0~a2~hg20130521r138523/widget/gtk2/nsWindow.cpp
4957
4932
===================================================================
4958
--- firefox-22.0~b2+build1.orig/widget/gtk2/nsWindow.cpp 2013-05-22 10:23:03.000000000 +0100
4959
+++ firefox-22.0~b2+build1/widget/gtk2/nsWindow.cpp 2013-05-22 14:48:35.000000000 +0100
4960
@@ -4730,6 +4730,11 @@
4933
--- firefox-23.0~a2~hg20130521r138523.orig/widget/gtk2/nsWindow.cpp 2013-05-22 12:59:58.948485674 +0100
4934
+++ firefox-23.0~a2~hg20130521r138523/widget/gtk2/nsWindow.cpp 2013-05-22 12:59:58.944485674 +0100
4935
@@ -4731,6 +4731,11 @@
4970
4945
nsWindow::CheckForRollup(gdouble aMouseX, gdouble aMouseY,
4971
4946
bool aIsWheel, bool aAlwaysRollup)
4972
Index: firefox-22.0~b2+build1/widget/gtk2/nsWindow.h
4947
Index: firefox-23.0~a2~hg20130521r138523/widget/gtk2/nsWindow.h
4973
4948
===================================================================
4974
--- firefox-22.0~b2+build1.orig/widget/gtk2/nsWindow.h 2013-05-22 10:23:03.000000000 +0100
4975
+++ firefox-22.0~b2+build1/widget/gtk2/nsWindow.h 2013-05-22 14:48:35.000000000 +0100
4949
--- firefox-23.0~a2~hg20130521r138523.orig/widget/gtk2/nsWindow.h 2013-05-22 12:59:58.948485674 +0100
4950
+++ firefox-23.0~a2~hg20130521r138523/widget/gtk2/nsWindow.h 2013-05-22 12:59:58.944485674 +0100
4976
4951
@@ -36,6 +36,8 @@
4978
4953
#include "nsGtkIMModule.h"
5002
4977
class nsChildWindow : public nsWindow {
5003
Index: firefox-22.0~b2+build1/widget/Makefile.in
4978
Index: firefox-23.0~a2~hg20130521r138523/widget/moz.build
5004
4979
===================================================================
5005
--- firefox-22.0~b2+build1.orig/widget/Makefile.in 2013-05-22 10:23:03.000000000 +0100
5006
+++ firefox-22.0~b2+build1/widget/Makefile.in 2013-05-22 14:48:35.000000000 +0100
5008
nsIWidgetListener.h \
4980
--- firefox-23.0~a2~hg20130521r138523.orig/widget/moz.build 2013-05-22 12:59:58.948485674 +0100
4981
+++ firefox-23.0~a2~hg20130521r138523/widget/moz.build 2013-05-22 12:59:58.944485674 +0100
4983
'nsITaskbarProgress.idl',
4986
- 'nsINativeMenuService.h',
4987
- 'nsIPrintDialogService.h',
4988
+ 'nsIPrintDialogService.h'
4990
elif toolkit == 'os2':
4994
EXPORTS += ['nsIDragSessionOS2.h']
5011
+ifneq (,$(filter cocoa gtk2 gtk3,$(MOZ_WIDGET_TOOLKIT)))
5012
+EXPORTS += nsINativeMenuService.h
4996
+if toolkit in ('cocoa', 'gtk2', 'gtk3'):
4997
+ EXPORTS += ['nsINativeMenuService.h']
5015
ifeq ($(MOZ_WIDGET_TOOLKIT),cocoa)
5017
- nsINativeMenuService.h \
5018
- nsIPrintDialogService.h \
5020
+EXPORTS += nsIPrintDialogService.h
4999
TEST_TOOL_DIRS += ['tests']
5023
ifeq ($(MOZ_WIDGET_TOOLKIT),os2)
5024
Index: firefox-22.0~b2+build1/xpfe/appshell/src/nsWebShellWindow.cpp
5001
# Don't build the DSO under the 'build' directory as windows does.
5002
Index: firefox-23.0~a2~hg20130521r138523/xpfe/appshell/src/nsWebShellWindow.cpp
5025
5003
===================================================================
5026
--- firefox-22.0~b2+build1.orig/xpfe/appshell/src/nsWebShellWindow.cpp 2013-05-22 10:23:03.000000000 +0100
5027
+++ firefox-22.0~b2+build1/xpfe/appshell/src/nsWebShellWindow.cpp 2013-05-22 14:48:35.000000000 +0100
5004
--- firefox-23.0~a2~hg20130521r138523.orig/xpfe/appshell/src/nsWebShellWindow.cpp 2013-05-22 12:59:58.948485674 +0100
5005
+++ firefox-23.0~a2~hg20130521r138523/xpfe/appshell/src/nsWebShellWindow.cpp 2013-05-22 12:59:58.944485674 +0100
5029
5007
#include "nsIScreen.h"
5031
5009
#include "nsIContent.h" // for menus
5057
5035
if (nms && menubarContent)
5058
5036
nms->CreateNativeMenuBar(aParentWindow, menubarContent);
5038
Index: firefox-23.0~a2~hg20130521r138523/modules/libpref/src/init/all.js
5039
===================================================================
5040
--- firefox-23.0~a2~hg20130521r138523.orig/modules/libpref/src/init/all.js 2013-05-22 12:59:58.948485674 +0100
5041
+++ firefox-23.0~a2~hg20130521r138523/modules/libpref/src/init/all.js 2013-05-22 12:59:58.944485674 +0100
5043
pref("browser.sessionhistory.max_total_viewers", -1);
5045
pref("ui.use_native_colors", true);
5046
+#ifdef MOZ_WIDGET_GTK
5047
+pref("ui.use_unity_menubar", true);
5049
pref("ui.click_hold_context_menus", false);
5050
pref("browser.display.use_document_fonts", 1); // 0 = never, 1 = quick, 2 = always
5051
pref("browser.display.use_document_colors", true);