~pmdj/ubuntu/trusty/qemu/2.9+applesmc+fadtv3

« back to all changes in this revision

Viewing changes to debian/control

  • Committer: Phil Dennis-Jordan
  • Date: 2017-08-16 15:17:21 UTC
  • Revision ID: phil@philjordan.eu-20170816151721-jtu0pp4zzfjp3m5m
Refreshes debian/control file (autogenerated from control-in)

Show diffs side-by-side

added added

removed removed

Lines of Context:
2
2
Source: qemu
3
3
Section: otherosfs
4
4
Priority: optional
5
 
Maintainer: Debian QEMU Team <pkg-qemu-devel@lists.alioth.debian.org>
 
5
Maintainer: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
 
6
XSBC-Original-Maintainer: Debian QEMU Team <pkg-qemu-devel@lists.alioth.debian.org>
6
7
Uploaders: Aurelien Jarno <aurel32@debian.org>,
7
8
        Riku Voipio <riku.voipio@iki.fi>,
8
9
        Vagrant Cascadian <vagrant@debian.org>,
46
47
# libgtk2.0-dev, libvte-dev (>> 0.18.0~),
47
48
# vte is used together with gtk
48
49
# --disable-vte
49
 
# --enable-libiscsi
50
 
 libiscsi-dev (>> 1.9.0~),
 
50
# --disable-libiscsi
 
51
# libiscsi-dev (>> 1.9.0~),
51
52
# --enable-curses
52
53
 libncursesw5-dev,
53
 
# --enable-libnfs
54
 
 libnfs-dev (>> 1.9.3),
55
54
# --enable-numa i386|amd64|ia64|mips|mipsel|powerpc|powerpcspe|x32|ppc64|ppc64el|arm64|sparc|hppa
56
55
 libnuma-dev   [i386 amd64 ia64 mips mipsel powerpc powerpcspe x32 ppc64 ppc64el arm64 sparc hppa],
57
 
# --enable-smartcard
58
 
 libcacard-dev,
 
56
# --disable-smartcard
 
57
# libcacard-dev,
59
58
# --with-system-pixman
60
59
 libpixman-1-dev,
61
60
# audio-drv-list += pa
63
62
# --enable-rbd          linux-*
64
63
 librados-dev [linux-any], librbd-dev [linux-any],
65
64
# glusterfs is debian-only since ubuntu/glusterfs is in universe (MIR LP: #1274247)
66
 
# --enable-glusterfs
67
 
 glusterfs-common,
68
65
# --enable-vnc-sasl
69
66
 libsasl2-dev,
70
67
# note: libsdl2-dev is in universe on ubuntu
80
77
# --enable-usb-redir    linux-*
81
78
 libusbredirparser-dev (>= 0.6~) [linux-any],
82
79
# libssh2 is debian-only since ubuntu/libssh2 is in universe
83
 
# --enable-libssh2
84
 
 libssh2-1-dev,
85
80
# vde is debian-only since ubuntu/vde2 is in universe
86
 
# --enable-vde
87
 
 libvdeplug-dev,
88
81
# needed for sdl
89
82
 libx11-dev,
90
83
# --enable-xen  linux-amd64|linux-i386
112
105
Build-Conflicts: oss4-dev
113
106
Standards-Version: 3.9.8
114
107
Homepage: http://www.qemu.org/
115
 
Vcs-Browser: https://anonscm.debian.org/gitweb/?p=pkg-qemu/qemu.git
116
 
Vcs-Git: git://anonscm.debian.org/pkg-qemu/qemu.git
 
108
Vcs-Browser: https://anonscm.debian.org/gitweb/?p=pkg-qemu/qemu.git;a=shortlog;h=refs/heads/ubuntu-utopic
 
109
XS-Debian-Vcs-Browser: https://anonscm.debian.org/gitweb/?p=pkg-qemu/qemu.git
 
110
Vcs-Git: git://anonscm.debian.org/pkg-qemu/qemu.git -b ubuntu-utopic
 
111
XS-Debian-Vcs-Git: git://anonscm.debian.org/pkg-qemu/qemu.git
117
112
 
118
113
Package: qemu
119
114
Architecture: amd64 arm arm64 armel armhf hppa i386 ia64 kfreebsd-amd64 kfreebsd-i386 mips mipsel powerpc powerpcspe ppc64 ppc64el s390x sparc sparc64 x32
182
177
Provides: qemu-keymaps
183
178
Depends: ${misc:Depends}, ${shlibs:Depends},
184
179
# to fix wrong acl for newly created device node on ubuntu:
 
180
 acl
185
181
Breaks:
 
182
 qemu-common,
186
183
# qemu-system before qemu-system-split
187
184
  qemu-system (<< 1.3.0+dfsg-5),
188
185
# qemu-utils had virtfs-proxy-helper
192
189
# iproute before 20110315 were unable to deal with bridge (set master device)
193
190
  iproute (<< 20110315-1)
194
191
Replaces:
 
192
 qemu (<< 1.3.0+dfsg-5),
 
193
 qemu-common,
195
194
  qemu-system (<< 1.3.0+dfsg-5),
196
195
  qemu-utils (<< 1.3.0+dfsg-4),
197
196
  qemu-keymaps,
239
238
Recommends: qemu-utils,
240
239
# aarch64 arm uses bootroms
241
240
 ipxe-qemu (>= 1.0.0+git-20131111.c3d1e78-1~),
 
241
Suggests: samba, vde2, qemu-block-extra (= ${binary:Version}),
242
242
 qemu-efi
243
 
Suggests: samba, vde2, qemu-block-extra (= ${binary:Version}),
244
243
Provides: ${sysprovides:arm}
245
244
Breaks: qemu-system (<< 1.3.0+dfsg-5),
 
245
 qemu-common (<< 1.3.0+dfsg-5),
 
246
 qemu-kvm (<< 1.2.0.dfsg-1),
 
247
 kvm (<< 1.3.0+dfsg-5),
 
248
 qemu-system-aarch64 (<< 2.0.0~rc1+dfsg-0ubuntu1),
246
249
Replaces: qemu-system (<< 1.3.0+dfsg-5),
 
250
 qemu-common (<< 1.3.0+dfsg-5),
 
251
 qemu-kvm (<< 1.2.0.dfsg-1),
 
252
 kvm (<< 1.3.0+dfsg-5),
 
253
 qemu-system-aarch64 (<< 2.0.0~rc1+dfsg-0ubuntu1),
247
254
Description: QEMU full system emulation binaries (arm)
248
255
 QEMU is a fast processor emulator: currently the package supports
249
256
 ARM emulation. By using dynamic translation it achieves
287
294
Depends: ${shlibs:Depends}, ${misc:Depends}, qemu-system-common (>> 2.0.0+dfsg-7~),
288
295
 qemu-slof,
289
296
# ubuntu can't Depend on openbios-ppc and openhackware as they're in universe
 
297
Suggests: samba, vde2, qemu-block-extra (= ${binary:Version}),
290
298
 openbios-ppc (>= 1.1+svn1229), openhackware
291
 
Suggests: samba, vde2, qemu-block-extra (= ${binary:Version}),
292
299
Recommends: qemu-utils,
293
300
# ppc targets use vgabios-stdvga and bootroms
294
301
 seabios, ipxe-qemu (>= 1.0.0+git-20131111.c3d1e78-1~)
295
302
Provides: ${sysprovides:ppc}
296
303
Breaks: qemu-system (<< 1.3.0+dfsg-5),
 
304
 qemu-common (<< 1.3.0+dfsg-5),
 
305
 qemu-kvm (<< 1.2.0.dfsg-1),
 
306
 kvm (<< 1.3.0+dfsg-5),
297
307
Replaces: qemu-system (<< 1.3.0+dfsg-5),
 
308
 qemu-common (<< 1.3.0+dfsg-5),
 
309
 qemu-kvm (<< 1.2.0.dfsg-1),
 
310
 kvm (<< 1.3.0+dfsg-5),
298
311
Description: QEMU full system emulation binaries (ppc)
299
312
 QEMU is a fast processor emulator: currently the package supports
300
313
 PowerPC emulation. By using dynamic translation it achieves
313
326
Multi-Arch: foreign
314
327
Depends: ${shlibs:Depends}, ${misc:Depends}, qemu-system-common (>> 2.0.0+dfsg-7~),
315
328
# ubuntu/openbios-sparc is in universe
316
 
 openbios-sparc (>> 1.1+svn1395-1~)
317
329
Recommends: qemu-utils,
318
330
# sparc64 uses vgabios-stdvga and bootroms
319
331
 seabios, ipxe-qemu (>= 1.0.0+git-20131111.c3d1e78-1~)
321
333
Provides: ${sysprovides:sparc}
322
334
Breaks:
323
335
 qemu-system (<< 1.3.0+dfsg-5),
 
336
 qemu-common (<< 1.3.0+dfsg-5),
 
337
 qemu-kvm (<< 1.2.0.dfsg-1),
 
338
 kvm (<< 1.3.0+dfsg-5),
324
339
Replaces:
325
340
 qemu-system (<< 1.3.0+dfsg-5),
 
341
 qemu-common (<< 1.3.0+dfsg-5),
 
342
 qemu-kvm (<< 1.2.0.dfsg-1),
 
343
 kvm (<< 1.3.0+dfsg-5),
326
344
Description: QEMU full system emulation binaries (sparc)
327
345
 QEMU is a fast processor emulator: currently the package supports
328
346
 SPARC emulation. By using dynamic translation it achieves
342
360
Depends: ${shlibs:Depends}, ${misc:Depends}, qemu-system-common (>> 2.0.0+dfsg-7~),
343
361
 seabios (>= 1.10.2-1~), ipxe-qemu (>= 1.0.0+git-20131111.c3d1e78-1~)
344
362
Recommends: qemu-utils,
 
363
 cpu-checker
345
364
Suggests: samba, vde2, qemu-block-extra (= ${binary:Version}),
346
365
 kmod [linux-any], sgabios, ovmf
347
366
Provides: ${sysprovides:x86}
 
367
Conflicts: kvm (<< 1.3.0+dfsg-5)
348
368
Breaks:
349
369
 qemu-system (<< 1.3.0+dfsg-5),
350
370
# older libvirt (eg 1.0) is known broken with qemu >= 1.6
351
371
 libvirt0 (<< 1.2),
 
372
 qemu-common (<< 1.3.0+dfsg-5),
 
373
 qemu-kvm (<< 1.2.0.dfsg-1),
 
374
 kvm (<< 1.3.0+dfsg-5),
352
375
Replaces:
353
376
 qemu-system (<< 1.3.0+dfsg-5),
 
377
 qemu-common (<< 1.3.0+dfsg-5),
 
378
 qemu-kvm (<< 1.2.0.dfsg-1),
 
379
 kvm (<< 1.3.0+dfsg-5),
354
380
Description: QEMU full system emulation binaries (x86)
355
381
 QEMU is a fast processor emulator: currently the package supports
356
382
 i386 and x86-64 emulation. By using dynamic translation it achieves
373
399
Depends: ${shlibs:Depends}, ${misc:Depends}
374
400
Recommends: qemu-user-binfmt
375
401
Suggests: sudo
 
402
Breaks: qemu-kvm (<< 1.2.0.dfsg-1)
 
403
Replaces: qemu-kvm (<< 1.2.0.dfsg-1)
376
404
Description: QEMU user mode emulation binaries
377
405
 QEMU is a fast processor emulator: currently the package supports
378
406
 ARM, CRIS, i386, M68k (ColdFire), MicroBlaze, MIPS, PowerPC, SH4,
433
461
Multi-Arch: foreign
434
462
Depends: ${shlibs:Depends}, ${misc:Depends}
435
463
Suggests: debootstrap, qemu-block-extra (= ${binary:Version}),
 
464
Conflicts: qemu-user (<< 0.11.1-2), qemu-kvm (<< 1.2.0.dfsg-1)
 
465
Replaces: qemu-user (<< 0.11.1-2), qemu-kvm (<< 1.2.0.dfsg-1)
436
466
Description: QEMU utilities
437
467
 QEMU is a fast processor emulator: currently the package supports
438
468
 ARM, CRIS, i386, M68k (ColdFire), MicroBlaze, MIPS, PowerPC, SH4,
469
499
 qemu virtual machine.  It is not used on the host.
470
500
 
471
501
Package: qemu-kvm
472
 
Architecture: i386 amd64
 
502
Architecture: i386 amd64 armhf armel powerpc sparc
473
503
Multi-Arch: foreign
474
504
Pre-Depends: ${misc:Pre-Depends}
475
505
Depends: ${misc:Depends}, qemu-system-x86 (>= 1.7.0+dfsg-2~)
476
506
Provides: kvm,
 
507
 qemu-kvm-spice
477
508
Conflicts: kvm,
 
509
 qemu-kvm-spice
478
510
Breaks: qemu-system-x86 (<< 1.7.0+dfsg-2~)
479
511
Replaces: qemu-system-x86 (<< 1.7.0+dfsg-2~),
 
512
 qemu-kvm-spice
480
513
Description: QEMU Full virtualization on x86 hardware
481
514
 QEMU is a fast processor emulator.  This package provides just a wrapper
482
515
 script /usr/bin/kvm which run qemu-system-x86 in kvm mode for backwards
485
518
 Please note that old qemu-kvm configuration files (in /etc/kvm/) are
486
519
 no longer used.
487
520
 
 
521
Package: qemu-system-aarch64
 
522
Architecture: arm64
 
523
Multi-Arch: foreign
 
524
Depends: ${misc:Depends}, qemu-system-arm (>= 2.0~git-20140403.de03c31-0ubuntu2)
 
525
Description: QEMU full system emulation binaries (aarch64)
 
526
 QEMU is a fast processor emulator: currently the package supports
 
527
 ARM emulation. By using dynamic translation it achieves
 
528
 reasonable speed while being easy to port on new host CPUs.
 
529
 .
 
530
 This is a transition package as qemu-system-aarch64 has been moved into
 
531
 qemu-system-arm.