~svn/ubuntu/oneiric/subversion/ppa

« back to all changes in this revision

Viewing changes to debian/patches/rpath.patch

  • Committer: Bazaar Package Importer
  • Author(s): Michael Vogt
  • Date: 2005-06-29 13:09:32 UTC
  • mfrom: (1.1.1 upstream) (0.1.2 sarge)
  • Revision ID: james.westby@ubuntu.com-20050629130932-vzt4595e7q8wtfqy
Tags: 1.2.0-1ubuntu1
Resynchronise with Debian.

Show diffs side-by-side

added added

removed removed

Lines of Context:
17
17
* build/generator/gen_make.py (Generator) : Fix the swig and apache module
18
18
  link rule to explicitly link to the necessary subversion shared libraries.
19
19
 
20
 
Index: subversion-1.1.1/Makefile.in
 
20
Index: Makefile.in
21
21
===================================================================
22
 
--- subversion-1.1.1.orig/Makefile.in   2004-12-09 23:20:41.000000000 -0800
23
 
+++ subversion-1.1.1/Makefile.in        2004-12-10 19:29:18.404434595 -0800
 
22
--- Makefile.in 2005-01-16 22:54:22.724283258 -0800
 
23
+++ Makefile.in 2005-01-16 22:54:23.117277740 -0800
24
24
@@ -160,7 +160,8 @@
25
25
 # special compilation for files destined for SWIG/Java
26
26
 COMPILE_SWIG_JAVA_JAVAC = $(JAVAC) $(JAVAC_FLAGS)
31
31
 
32
32
 # special link rule for mod_dav_svn
33
33
 LINK_APACHE_MOD = $(LIBTOOL) $(LTFLAGS) --mode=link $(CC) $(LT_LDFLAGS) $(CFLAGS) $(LDFLAGS) -rpath $(APACHE_LIBEXECDIR) -avoid-version -module
34
 
@@ -574,6 +575,17 @@
 
34
@@ -579,6 +580,17 @@
35
35
 $(SWIG_PL_DIR)/native/Makefile: $(SWIG_PL_DIR)/native/Makefile.PL
36
36
        cd $(SWIG_PL_DIR)/native; $(PERL) Makefile.PL
37
37
 
49
49
 swig-pl_DEPS = libsvn_client libsvn_delta libsvn_diff libsvn_fs libsvn_ra libsvn_repos libsvn_subr libsvn_wc libsvn_swig_perl $(SWIG_PL_DIR)/native/Makefile
50
50
 swig-pl: $(swig-pl_DEPS)
51
51
        cd $(SWIG_PL_DIR)/native; $(MAKE)
52
 
Index: subversion-1.1.1/build/generator/gen_base.py
 
52
Index: build/generator/gen_base.py
53
53
===================================================================
54
 
--- subversion-1.1.1.orig/build/generator/gen_base.py   2004-07-12 14:51:03.000000000 -0700
55
 
+++ subversion-1.1.1/build/generator/gen_base.py        2004-12-09 23:20:41.000000000 -0800
 
54
--- build/generator/gen_base.py 2004-07-12 14:51:03.000000000 -0700
 
55
+++ build/generator/gen_base.py 2005-01-16 22:54:23.119277711 -0800
56
56
@@ -332,7 +332,7 @@
57
57
     self.install = options.get('install')
58
58
     self.compile_cmd = options.get('compile-cmd')
70
70
 
71
71
     self.manpages = options.get('manpages', '')
72
72
     self.testing = options.get('testing')
73
 
Index: subversion-1.1.1/build.conf
 
73
Index: build.conf
74
74
===================================================================
75
 
--- subversion-1.1.1.orig/build.conf    2004-08-10 09:35:02.000000000 -0700
76
 
+++ subversion-1.1.1/build.conf 2004-12-09 23:20:41.000000000 -0800
77
 
@@ -347,7 +347,7 @@
 
75
--- build.conf  2004-12-07 09:24:51.000000000 -0800
 
76
+++ build.conf  2005-01-16 22:54:23.121277683 -0800
 
77
@@ -340,7 +340,7 @@
78
78
 sources = swigutil_py.c
79
79
 libs = swig_runtime libsvn_subr libsvn_delta aprutil apriconv apr
80
80
 # need SWIG_LDFLAGS to be able to link swig_runtime
83
83
 install = swig-py-lib
84
84
 # need special build rule to include -DSWIGPYTHON
85
85
 compile-cmd = $(COMPILE_SWIG_PY)
86
 
Index: subversion-1.1.1/build/generator/gen_make.py
 
86
Index: build/generator/gen_make.py
87
87
===================================================================
88
 
--- subversion-1.1.1.orig/build/generator/gen_make.py   2004-08-09 15:30:31.000000000 -0700
89
 
+++ subversion-1.1.1/build/generator/gen_make.py        2004-12-09 23:20:41.000000000 -0800
 
88
--- build/generator/gen_make.py 2004-08-09 15:30:31.000000000 -0700
 
89
+++ build/generator/gen_make.py 2005-01-16 22:54:23.122277669 -0800
90
90
@@ -72,8 +72,18 @@
91
91
             # append the output of the target to our stated dependencies
92
92
             deps.append(source.filename)