~sylvain-pineau/checkbox/lsb_release_dep

« back to all changes in this revision

Viewing changes to debian/rules

  • Committer: Sylvain Pineau
  • Date: 2013-11-26 13:42:58 UTC
  • Revision ID: sylvain.pineau@canonical.com-20131126134258-x9yhr9210orktsvz
debian:rules: Fix detection of releases greater than 13.04

lsb_release was not found if used inside backquotes.

Show diffs side-by-side

added added

removed removed

Lines of Context:
5
5
# Prevent setuptools/distribute from accessing the internet.
6
6
export http_proxy=http://127.0.9.1:9
7
7
 
8
 
RELEASE_GTE_RARING      := $(shell expr `lsb_release -rs` \>= 13.04)
 
8
REL_NO  := $(shell lsb_release -rs)
 
9
RELEASE_GTE_RARING      := $(shell expr $(REL_NO) \>= 13.04)
9
10
 
10
11
%:
11
12
        dh "$@" --with python3,sphinxdoc,translations