~ubuntu-branches/debian/sid/ipmitool/sid

« back to all changes in this revision

Viewing changes to debian/patches/120-Dell-13G.patch

  • Committer: Package Import Robot
  • Author(s): Jörg Frings-Fürst
  • Date: 2014-08-07 15:09:16 UTC
  • Revision ID: package-import@ubuntu.com-20140807150916-s8nybl26opb01slr
Tags: 1.8.14-4
* New debian/patches/120-Dell-13G.patch:
  - Add support for Dell 13G server (Closes: #756555)
* debian/rules:
  - Remove oldstyle CFLAGS parameter.
  - change hardening to modern dh.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Description: Add support for Dell 13G server.
 
2
 Add support for upcoming Dell PowerEdge 13G server 
 
3
 and replace multiple if statments. 
 
4
 Based on patch from  SriniG <srinivas_g_gowda@dell.com>
 
5
Author: Jörg Frings-Fürst <debian@jff-webhosting.net>
 
6
Origin: based on patch from SriniG <srinivas_g_gowda@dell.com>
 
7
Bug: http://sourceforge.net/p/ipmitool/patches/102/
 
8
Bug-debian: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=756555
 
9
Forwarded: http://sourceforge.net/p/ipmitool/patches/102/
 
10
Reviewed-by: 2014-08-07 SriniG <srinivas_g_gowda@dell.com>
 
11
Last-Update: 2014-08-07
 
12
---
 
13
This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
 
14
Index: trunk/include/ipmitool/ipmi_delloem.h
 
15
===================================================================
 
16
--- trunk.orig/include/ipmitool/ipmi_delloem.h  2014-08-04 17:24:11.291429804 +0200
 
17
+++ trunk/include/ipmitool/ipmi_delloem.h       2014-08-04 17:24:11.279429542 +0200
 
18
@@ -72,6 +72,7 @@
 
19
 
 
20
 #define        IDRAC_11G                                       1
 
21
 #define        IDRAC_12G                                       2
 
22
+#define        IDRAC_13G                                       3
 
23
 // Return Error code for license
 
24
 #define        LICENSE_NOT_SUPPORTED           0x6F
 
25
 #define        VFL_NOT_LICENSED                        0x33
 
26
@@ -184,6 +185,9 @@
 
27
 #define IMC_IDRAC_12G_MONOLITHIC       (uint8_t) (0x10)
 
28
 #define IMC_IDRAC_12G_MODULAR          (uint8_t) (0x11)
 
29
 
 
30
+#define IMC_IDRAC_13G_MONOLITHIC       (uint8_t) (0x20)
 
31
+#define IMC_IDRAC_13G_MODULAR          (uint8_t) (0x21)
 
32
+#define IMC_IDRAC_13G_DCS                      (uint8_t) (0x22)
 
33
 
 
34
 
 
35
 typedef struct
 
36
Index: trunk/lib/ipmi_delloem.c
 
37
===================================================================
 
38
--- trunk.orig/lib/ipmi_delloem.c       2014-08-04 17:24:11.291429804 +0200
 
39
+++ trunk/lib/ipmi_delloem.c    2014-08-04 17:24:11.279429542 +0200
 
40
@@ -123,6 +123,16 @@
 
41
 
 
42
 static int current_arg =0;
 
43
 uint8_t iDRAC_FLAG=0;
 
44
+
 
45
+/*
 
46
+ * new flags for
 
47
+ * 11G || 12G || 13G  -> _ALL
 
48
+ * 12G || 13G -> _12_13
 
49
+ *
 
50
+ */
 
51
+uint8_t iDRAC_FLAG_ALL=0;
 
52
+uint8_t iDRAC_FLAG_12_13=0;
 
53
+
 
54
 LCD_MODE lcd_mode;
 
55
 static uint8_t LcdSupported=0;
 
56
 static uint8_t SetLEDSupported=0;
 
57
@@ -358,7 +368,7 @@
 
58
                lprintf(LOG_ERR, "lcd is not supported on this system.");
 
59
                return -1;
 
60
        } else if (strncmp(argv[current_arg], "info\0", 5) == 0) {
 
61
-               if ((iDRAC_FLAG==IDRAC_11G) || (iDRAC_FLAG==IDRAC_12G)) {
 
62
+               if (iDRAC_FLAG_ALL) {
 
63
                        rc = ipmi_lcd_get_info_wh(intf);
 
64
                } else {
 
65
                        rc = ipmi_lcd_get_info(intf);
 
66
@@ -392,7 +402,7 @@
 
67
                        }
 
68
                }
 
69
                if ((strncmp(argv[current_arg], "mode\0", 5) == 0)
 
70
-                               && ((iDRAC_FLAG==IDRAC_11G) || (iDRAC_FLAG==IDRAC_12G))) {
 
71
+                               && (iDRAC_FLAG_ALL)) {
 
72
                        current_arg++;
 
73
                        if (argc <= current_arg) {
 
74
                                ipmi_lcd_usage();
 
75
@@ -446,7 +456,7 @@
 
76
                                ipmi_lcd_usage();
 
77
                        }
 
78
                } else if ((strncmp(argv[current_arg], "lcdqualifier\0", 13) == 0)
 
79
-                               && ((iDRAC_FLAG==IDRAC_11G) || (iDRAC_FLAG==IDRAC_12G))) {
 
80
+                               && (iDRAC_FLAG_ALL)) {
 
81
                        current_arg++;
 
82
                        if (argc <= current_arg) {
 
83
                                ipmi_lcd_usage();
 
84
@@ -470,7 +480,7 @@
 
85
                                ipmi_lcd_usage();
 
86
                        }
 
87
                } else if ((strncmp(argv[current_arg], "errordisplay\0", 13) == 0)
 
88
-                               && ((iDRAC_FLAG==IDRAC_11G) || (iDRAC_FLAG==IDRAC_12G))) {
 
89
+                               && (iDRAC_FLAG_ALL)) {
 
90
                        current_arg++;
 
91
                        if (argc <= current_arg) {
 
92
                                ipmi_lcd_usage();
 
93
@@ -635,17 +645,33 @@
 
94
                val2str(rsp->ccode, completion_code_vals));  */
 
95
                return -1;
 
96
        }
 
97
+       /*
 
98
+        * Set the new flags to 0
 
99
+        */
 
100
+       iDRAC_FLAG_ALL = 0;
 
101
+       iDRAC_FLAG_12_13 = 0;
 
102
        /* Support the 11G Monolithic, modular, Maisy and Coaster */
 
103
        if ((IMC_IDRAC_11G_MONOLITHIC == data[10])
 
104
                        || (IMC_IDRAC_11G_MODULAR == data[10])
 
105
                        || (IMC_MASER_LITE_BMC == data[10])
 
106
                        || (IMC_MASER_LITE_NU == data[10])) {
 
107
                iDRAC_FLAG=IDRAC_11G;
 
108
+               iDRAC_FLAG_ALL = 1;
 
109
        } else if((IMC_IDRAC_12G_MONOLITHIC == data[10])
 
110
                        || (IMC_IDRAC_12G_MODULAR == data[10])) {
 
111
                iDRAC_FLAG = IDRAC_12G;
 
112
+               iDRAC_FLAG_ALL = 1;
 
113
+               iDRAC_FLAG_12_13 = 1;
 
114
+       } else if( (IMC_IDRAC_13G_MONOLITHIC == data[10])
 
115
+                       || (IMC_IDRAC_13G_MODULAR == data[10])
 
116
+                       || (IMC_IDRAC_13G_DCS == data[10]) ) {
 
117
+               iDRAC_FLAG=IDRAC_13G;
 
118
+               iDRAC_FLAG_ALL = 1;
 
119
+               iDRAC_FLAG_12_13 = 1;
 
120
        } else {
 
121
                iDRAC_FLAG = 0;
 
122
+               iDRAC_FLAG_ALL = 0;
 
123
+               iDRAC_FLAG_12_13 = 0;
 
124
        }
 
125
        IMC_Type = data[10];
 
126
        return 0;
 
127
@@ -1394,7 +1420,7 @@
 
128
        lprintf(LOG_NOTICE,
 
129
 "");
 
130
        lprintf(LOG_NOTICE,
 
131
-"iDRAC 11g or iDRAC 12g:");
 
132
+"iDRAC 11g or iDRAC 12g or  iDRAC 13g :");
 
133
        lprintf(LOG_NOTICE,
 
134
 "   lcd set {mode}|{lcdqualifier}|{errordisplay}");
 
135
        lprintf(LOG_NOTICE,
 
136
@@ -1561,7 +1587,9 @@
 
137
                return -1;
 
138
        }
 
139
        if ((IMC_IDRAC_12G_MODULAR == IMC_Type)
 
140
-                       || (IMC_IDRAC_12G_MONOLITHIC== IMC_Type)) {
 
141
+                       || (IMC_IDRAC_12G_MONOLITHIC== IMC_Type)
 
142
+                       || (IMC_IDRAC_13G_MODULAR == IMC_Type)
 
143
+                       || (IMC_IDRAC_13G_MONOLITHIC== IMC_Type)) {
 
144
                /* Get the Chasiss Assigned MAC Addresss for 12g Only */
 
145
                memcpy(VirtualMacAddress, ((rsp->data) + 1), MACADDRESSLENGH);
 
146
                for (i = 0; i < MACADDRESSLENGH; i++) {
 
147
@@ -1599,6 +1627,9 @@
 
148
        } else if ((IMC_IDRAC_12G_MODULAR == IMC_Type)
 
149
                        || (IMC_IDRAC_12G_MONOLITHIC== IMC_Type)) {
 
150
                printf("\niDRAC7 MAC Address ");
 
151
+       } else if ((IMC_IDRAC_13G_MODULAR == IMC_Type)
 
152
+                       || (IMC_IDRAC_13G_MONOLITHIC== IMC_Type))        {
 
153
+                       printf ("\niDRAC8 MAC Address ");
 
154
        } else if ((IMC_MASER_LITE_BMC== IMC_Type)
 
155
                        || (IMC_MASER_LITE_NU== IMC_Type)) {
 
156
                printf("\nBMC MAC Address ");
 
157
@@ -1668,6 +1699,9 @@
 
158
        } else if ((IMC_IDRAC_12G_MODULAR == IMC_Type)
 
159
                        || (IMC_IDRAC_12G_MONOLITHIC== IMC_Type)) {
 
160
                printf("\niDRAC7 MAC Address ");
 
161
+       } else if ((IMC_IDRAC_13G_MODULAR == IMC_Type)
 
162
+                       || (IMC_IDRAC_13G_MONOLITHIC== IMC_Type))        {
 
163
+                       printf ("\niDRAC8 MAC Address ");
 
164
        } else if ((IMC_MASER_LITE_BMC== IMC_Type)
 
165
                        || (IMC_MASER_LITE_NU== IMC_Type)) {
 
166
                printf("\n\rBMC MAC Address ");
 
167
@@ -1879,6 +1913,8 @@
 
168
                                || IMC_IDRAC_11G_MONOLITHIC == IMC_Type)
 
169
                        || (IMC_IDRAC_12G_MODULAR == IMC_Type
 
170
                                || IMC_IDRAC_12G_MONOLITHIC == IMC_Type)
 
171
+                       || (IMC_IDRAC_13G_MODULAR == IMC_Type
 
172
+                               || IMC_IDRAC_13G_MONOLITHIC == IMC_Type)
 
173
                        || (IMC_MASER_LITE_NU == IMC_Type || IMC_MASER_LITE_BMC== IMC_Type)) {
 
174
                return ipmi_macinfo_11g(intf,NicNum);
 
175
        } else {
 
176
@@ -1946,7 +1982,7 @@
 
177
                        ipmi_lan_usage();
 
178
                        return -1;
 
179
                }
 
180
-               if (iDRAC_FLAG == IDRAC_12G) {
 
181
+               if (iDRAC_FLAG_12_13)  {
 
182
                        nic_selection = get_nic_selection_mode_12g(intf, current_arg, argv,
 
183
                                        nic_set);
 
184
                        if (INVALID == nic_selection) {
 
185
@@ -2063,7 +2099,7 @@
 
186
        }
 
187
        if (argv[current_arg] != NULL
 
188
                        && strncmp(argv[current_arg], "lom1\0", 5) == 0) {
 
189
-               if (IMC_IDRAC_12G_MODULAR == IMC_Type) {
 
190
+               if ((IMC_IDRAC_12G_MODULAR == IMC_Type) ||  (IMC_IDRAC_13G_MODULAR == IMC_Type)) {
 
191
                        return INVAILD_SHARED_MODE;
 
192
                }
 
193
                if (failover) {
 
194
@@ -2082,7 +2118,7 @@
 
195
                return 0;
 
196
        } else if (argv[current_arg] != NULL
 
197
                        && strncmp(argv[current_arg], "lom2\0", 5) == 0) {
 
198
-               if (IMC_IDRAC_12G_MODULAR == IMC_Type) {
 
199
+               if ((IMC_IDRAC_12G_MODULAR == IMC_Type) ||  (IMC_IDRAC_13G_MODULAR == IMC_Type)) {
 
200
                        return INVAILD_SHARED_MODE;
 
201
                }
 
202
                if (failover) {
 
203
@@ -2101,7 +2137,7 @@
 
204
                return 0;
 
205
        } else if (argv[current_arg] != NULL
 
206
                        && strncmp(argv[current_arg], "lom3\0", 5) == 0) {
 
207
-               if (IMC_IDRAC_12G_MODULAR == IMC_Type) {
 
208
+               if ((IMC_IDRAC_12G_MODULAR == IMC_Type) ||  (IMC_IDRAC_13G_MODULAR == IMC_Type)) {
 
209
                        return INVAILD_SHARED_MODE;
 
210
                }
 
211
                if (failover) {
 
212
@@ -2120,7 +2156,7 @@
 
213
                return 0;
 
214
        } else if (argv[current_arg] != NULL
 
215
                        && strncmp(argv[current_arg], "lom4\0", 5) == 0) {
 
216
-               if (IMC_IDRAC_12G_MODULAR == IMC_Type) {
 
217
+               if ((IMC_IDRAC_12G_MODULAR == IMC_Type) ||  (IMC_IDRAC_13G_MODULAR == IMC_Type)) {
 
218
                        return INVAILD_SHARED_MODE;
 
219
                }
 
220
                if (failover) {
 
221
@@ -2139,7 +2175,7 @@
 
222
                return 0;
 
223
        } else if (failover && argv[current_arg] != NULL
 
224
                        && strncmp(argv[current_arg], "none\0", 5) == 0) {
 
225
-               if (IMC_IDRAC_12G_MODULAR == IMC_Type) {
 
226
+               if ((IMC_IDRAC_12G_MODULAR == IMC_Type) ||  (IMC_IDRAC_13G_MODULAR == IMC_Type) ) {
 
227
                        return INVAILD_SHARED_MODE;
 
228
                }
 
229
                if (failover) {
 
230
@@ -2159,7 +2195,7 @@
 
231
        current_arg++;
 
232
        if (failover && argv[current_arg] != NULL
 
233
                        && strncmp(argv[current_arg], "loms\0", 5) == 0) {
 
234
-               if (IMC_IDRAC_12G_MODULAR == IMC_Type) {
 
235
+               if ((IMC_IDRAC_12G_MODULAR == IMC_Type) ||  (IMC_IDRAC_13G_MODULAR == IMC_Type)) {
 
236
                        return INVAILD_SHARED_MODE;
 
237
                }
 
238
                if (nic_set[0] == 1) {
 
239
@@ -2242,7 +2278,8 @@
 
240
                lprintf(LOG_ERR, "Error in setting nic selection");
 
241
                return -1;
 
242
        } else if( (nic_selection[0] == 1)
 
243
-                       && ((iDRAC_FLAG == IDRAC_12G) && (rsp->ccode == LICENSE_NOT_SUPPORTED))) {
 
244
+                       && (( iDRAC_FLAG_12_13 )
 
245
+                       && (rsp->ccode == LICENSE_NOT_SUPPORTED))) {
 
246
                /* Check license only for setting the dedicated nic. */
 
247
                lprintf(LOG_ERR,
 
248
                                "FM001 : A required license is missing or expired");
 
249
@@ -2297,7 +2334,7 @@
 
250
        input_length = 0;
 
251
        req.msg.netfn = DELL_OEM_NETFN;
 
252
        req.msg.lun = 0;
 
253
-       if (iDRAC_FLAG == IDRAC_12G) {
 
254
+       if( iDRAC_FLAG_12_13 ) {
 
255
                req.msg.cmd = GET_NIC_SELECTION_12G_CMD;
 
256
        } else {
 
257
                req.msg.cmd = GET_NIC_SELECTION_CMD;
 
258
@@ -2314,7 +2351,7 @@
 
259
                return -1;
 
260
        }
 
261
        nic_selection = rsp->data[0];
 
262
-       if (iDRAC_FLAG == IDRAC_12G) {
 
263
+       if( iDRAC_FLAG_12_13 ) {
 
264
                nic_selection_failover = rsp->data[1];
 
265
                if ((nic_selection < 6) && (nic_selection > 0)
 
266
                                && (nic_selection_failover < 7)) {
 
267
@@ -2413,7 +2450,7 @@
 
268
        lprintf(LOG_NOTICE,
 
269
 "      sets the NIC Selection Mode :");
 
270
        lprintf(LOG_NOTICE,
 
271
-"          on iDRAC12g :");
 
272
+"          on iDRAC12g OR iDRAC13g  :");
 
273
        lprintf(LOG_NOTICE,
 
274
 "              dedicated, shared with lom1, shared with lom2,shared with lom3,shared");
 
275
        lprintf(LOG_NOTICE,
 
276
@@ -2433,7 +2470,7 @@
 
277
        lprintf(LOG_NOTICE,
 
278
 "   lan get ");
 
279
        lprintf(LOG_NOTICE,
 
280
-"          on iDRAC12g :");
 
281
+"          on iDRAC12g or iDRAC13g  :");
 
282
        lprintf(LOG_NOTICE,
 
283
 "              returns the current NIC Selection Mode (dedicated, shared with lom1, shared");
 
284
        lprintf(LOG_NOTICE,
 
285
@@ -2662,7 +2699,7 @@
 
286
        if (rsp == NULL) {
 
287
                lprintf(LOG_ERR, "Error getting powercap status");
 
288
                return -1;
 
289
-       } else if((iDRAC_FLAG == IDRAC_12G) && (rsp->ccode == LICENSE_NOT_SUPPORTED)) {
 
290
+       } else if(( iDRAC_FLAG_12_13 ) && (rsp->ccode == LICENSE_NOT_SUPPORTED)) {
 
291
                lprintf(LOG_ERR,
 
292
                                "FM001 : A required license is missing or expired");
 
293
                return -1; /* Return Error as unlicensed */
 
294
@@ -2713,7 +2750,7 @@
 
295
        if (rsp == NULL) {
 
296
                lprintf(LOG_ERR, "Error setting powercap status");
 
297
                return -1;
 
298
-       } else if ((iDRAC_FLAG == IDRAC_12G) && (rsp->ccode == LICENSE_NOT_SUPPORTED)) {
 
299
+       } else if ((iDRAC_FLAG_12_13) && (rsp->ccode == LICENSE_NOT_SUPPORTED)) {
 
300
                lprintf(LOG_ERR,
 
301
                                "FM001 : A required license is missing or expired");
 
302
                return -1; /* return unlicensed Error code */
 
303
@@ -2807,7 +2844,7 @@
 
304
                return -1;
 
305
        }
 
306
 
 
307
-       if((iDRAC_FLAG == IDRAC_12G) && (rsp->ccode == LICENSE_NOT_SUPPORTED)) {
 
308
+       if((iDRAC_FLAG_12_13) && (rsp->ccode == LICENSE_NOT_SUPPORTED)) {
 
309
                lprintf(LOG_ERR,
 
310
                                "FM001 : A required license is missing or expired");
 
311
                return -1;
 
312
@@ -2910,7 +2947,7 @@
 
313
        if (rsp == NULL) {
 
314
                lprintf(LOG_ERR, "Error clearing power values.");
 
315
                return -1;
 
316
-       } else if ((iDRAC_FLAG == IDRAC_12G)
 
317
+       } else if ((iDRAC_FLAG_12_13)
 
318
                        && (rsp->ccode == LICENSE_NOT_SUPPORTED)) {
 
319
                lprintf(LOG_ERR,
 
320
                                "FM001 : A required license is missing or expired");
 
321
@@ -2988,7 +3025,7 @@
 
322
        if (rsp == NULL) {
 
323
                lprintf(LOG_ERR, "Error getting power headroom status");
 
324
                return -1;
 
325
-       } else if ((iDRAC_FLAG == IDRAC_12G)
 
326
+       } else if ((iDRAC_FLAG_12_13)
 
327
                        && (rsp->ccode == LICENSE_NOT_SUPPORTED)) {
 
328
                lprintf(LOG_ERR,
 
329
                                "FM001 : A required license is missing or expired");
 
330
@@ -3122,7 +3159,7 @@
 
331
        if (rsp == NULL) {
 
332
                lprintf(LOG_ERR, "Error getting instantaneous power consumption data .");
 
333
                return -1;
 
334
-       } else if ((iDRAC_FLAG == IDRAC_12G)
 
335
+       } else if ((iDRAC_FLAG_12_13)
 
336
                        && (rsp->ccode == LICENSE_NOT_SUPPORTED)) {
 
337
                lprintf(LOG_ERR,
 
338
                                "FM001 : A required license is missing or expired");
 
339
@@ -3215,7 +3252,7 @@
 
340
                lprintf(LOG_ERR,
 
341
                                "Error getting average power consumption history data.");
 
342
                return -1;
 
343
-       } else if ((iDRAC_FLAG == IDRAC_12G) &&  (rc == LICENSE_NOT_SUPPORTED)) {
 
344
+       } else if ((iDRAC_FLAG_12_13) &&  (rc == LICENSE_NOT_SUPPORTED)) {
 
345
                lprintf(LOG_ERR,
 
346
                                "FM001 : A required license is missing or expired");
 
347
                return -1;
 
348
@@ -3264,7 +3301,7 @@
 
349
        if (rc < 0) {
 
350
                lprintf(LOG_ERR, "Error getting  peak power consumption history data.");
 
351
                return -1;
 
352
-       } else if ((iDRAC_FLAG == IDRAC_12G) && (rc == LICENSE_NOT_SUPPORTED)) {
 
353
+       } else if ((iDRAC_FLAG_12_13) && (rc == LICENSE_NOT_SUPPORTED)) {
 
354
                lprintf(LOG_ERR,
 
355
                                "FM001 : A required license is missing or expired");
 
356
                return -1;
 
357
@@ -3321,7 +3358,7 @@
 
358
        if (rc < 0) {
 
359
                lprintf(LOG_ERR, "Error getting  peak power consumption history data .");
 
360
                return -1;
 
361
-       } else if ((iDRAC_FLAG == IDRAC_12G) &&  (rc == LICENSE_NOT_SUPPORTED)) {
 
362
+       } else if ((iDRAC_FLAG_12_13) &&  (rc == LICENSE_NOT_SUPPORTED)) {
 
363
                lprintf(LOG_ERR,
 
364
                                "FM001 : A required license is missing or expired");
 
365
                return -1;
 
366
@@ -3518,7 +3555,7 @@
 
367
        if (rc < 0) {
 
368
                lprintf(LOG_ERR, "Error getting power cap.");
 
369
                return -1;
 
370
-       } else if ((iDRAC_FLAG == IDRAC_12G) && (rc == LICENSE_NOT_SUPPORTED)) {
 
371
+       } else if ((iDRAC_FLAG_12_13) && (rc == LICENSE_NOT_SUPPORTED)) {
 
372
                lprintf(LOG_ERR,
 
373
                                "FM001 : A required license is missing or expired");
 
374
                return -1;
 
375
@@ -3618,7 +3655,7 @@
 
376
        if (rc < 0) {
 
377
                lprintf(LOG_ERR, "Error getting power cap.");
 
378
                return -1;
 
379
-       } else if ((iDRAC_FLAG == IDRAC_12G) && (rc == LICENSE_NOT_SUPPORTED)) {
 
380
+       } else if ((iDRAC_FLAG_12_13) && (rc == LICENSE_NOT_SUPPORTED)) {
 
381
                lprintf(LOG_ERR,
 
382
                                "FM001 : A required license is missing or expired");
 
383
                return -1;
 
384
@@ -3698,7 +3735,7 @@
 
385
        if (rc < 0) {
 
386
                lprintf(LOG_ERR, "Error setting power cap");
 
387
                return -1;
 
388
-       } else if ((iDRAC_FLAG == IDRAC_12G) && (rc == LICENSE_NOT_SUPPORTED)) {
 
389
+       } else if ((iDRAC_FLAG_12_13) && (rc == LICENSE_NOT_SUPPORTED)) {
 
390
                lprintf(LOG_ERR,
 
391
                                "FM001 : A required license is missing or expired");
 
392
                return -1;
 
393
@@ -3860,7 +3897,7 @@
 
394
 
 
395
        sdcardinfoblock = (IPMI_DELL_SDCARD_INFO *) (void *) rsp->data;
 
396
 
 
397
-       if ((iDRAC_FLAG == IDRAC_12G)
 
398
+       if ((iDRAC_FLAG_12_13)
 
399
                        && (sdcardinfoblock->vflashcompcode == VFL_NOT_LICENSED)) {
 
400
                lprintf(LOG_ERR,
 
401
                                "FM001 : A required license is missing or expired");