~ubuntu-branches/debian/sid/pixman/sid

« back to all changes in this revision

Viewing changes to debian/patches/ppc64el.diff

  • Committer: Package Import Robot
  • Author(s): Julien Cristau, Andreas Boll, intrigeri
  • Date: 2015-09-12 13:08:02 UTC
  • mfrom: (1.1.29)
  • Revision ID: package-import@ubuntu.com-20150912130802-0egoj4agog1fsobn
Tags: 0.33.2-1
[ Andreas Boll ]
* New upstream release candidate.
* Enable vmx on ppc64el (closes: #786345).
* Update Vcs-* fields.
* Add upstream url.
* Drop XC- prefix from Package-Type field.
* Bump standards version to 3.9.6.

[ intrigeri ]
* Simplify hardening build flags handling (closes: #760100).
  Thanks to Simon Ruderich <simon@ruderich.org> for the patch.
* Enable all hardening build flags. Thanks to Simon Ruderich too.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
diff --git a/configure.ac b/configure.ac
2
 
index dce76b3..172de8b 100644
3
 
--- a/configure.ac
4
 
+++ b/configure.ac
5
 
@@ -540,6 +540,9 @@ AC_COMPILE_IFELSE([AC_LANG_SOURCE([[
6
 
 #if defined(__GNUC__) && (__GNUC__ < 3 || (__GNUC__ == 3 && __GNUC_MINOR__ < 4))
7
 
 #error "Need GCC >= 3.4 for sane altivec support"
8
 
 #endif
9
 
+#if defined(__PPC64__) && (__BYTE_ORDER__==__ORDER_LITTLE_ENDIAN__)
10
 
+#error VMX utilization is still not ready on ppc64el
11
 
+#endif
12
 
 #include <altivec.h>
13
 
 int main () {
14
 
     vector unsigned int v = vec_splat_u32 (1);