~ubuntu-branches/debian/stretch/clalsadrv/stretch

« back to all changes in this revision

Viewing changes to debian/patches/01-makefile.patch

  • Committer: Bazaar Package Importer
  • Author(s): Alessio Treglia
  • Date: 2010-04-17 12:25:13 UTC
  • mfrom: (1.1.4 upstream) (2.1.4 experimental)
  • Revision ID: james.westby@ubuntu.com-20100417122513-vsy32s4vwo8vgzvs
Tags: 2.0.0-2
Upload to unstable.

Show diffs side-by-side

added added

removed removed

Lines of Context:
2
2
Description: Set PREFIX properly, add DESTDIR var, create /usr/include
3
3
 before installing the headers.
4
4
---
5
 
 Makefile |    6 ++++--
6
 
 1 file changed, 4 insertions(+), 2 deletions(-)
 
5
 libs/Makefile |    6 +++---
 
6
 1 file changed, 3 insertions(+), 3 deletions(-)
7
7
 
8
 
--- clalsadrv.orig/Makefile
9
 
+++ clalsadrv/Makefile
10
 
@@ -14,11 +14,12 @@
11
 
 #  along with this program; if not, write to the Free Software
12
 
 #  Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
13
 
 
14
 
+DESTDIR =
 
8
--- clalsadrv.orig/libs/Makefile
 
9
+++ clalsadrv/libs/Makefile
 
10
@@ -17,8 +17,8 @@
15
11
 
16
12
 # Modify as required.
17
13
 #
18
 
-PREFIX = /usr
 
14
-PREFIX = /usr/local
19
15
-SUFFIX := $(shell uname -m | sed -e 's/^unknown/$//' -e 's/^i.86/$//' -e 's/^x86_64/$/64/')
20
 
+PREFIX = $(DESTDIR)/usr
 
16
+PREFIX = /usr
21
17
+#SUFFIX := $(shell uname -m | sed -e 's/^unknown/$//' -e 's/^i.86/$//' -e 's/^x86_64/$/64/')
22
18
 LIBDIR = lib$(SUFFIX)
23
19
 
24
20
 
25
 
@@ -47,6 +48,7 @@ $(CLALSADRV_MIN): $(CLALSADRV_O)
26
 
 
 
21
@@ -47,7 +47,7 @@ $(CLALSADRV_MIN): $(CLALSADRV_O)
27
22
 install:       $(CLALSADRV_MIN)
28
 
        /usr/bin/install -d $(PREFIX)/$(LIBDIR)
29
 
+       /usr/bin/install -d $(PREFIX)/include
30
 
        /usr/bin/install -m 644 $(CLALSADRV_H) $(PREFIX)/include
31
 
        /usr/bin/install -m 755 $(CLALSADRV_MIN) $(PREFIX)/$(LIBDIR)
32
 
        /sbin/ldconfig -n $(PREFIX)/$(LIBDIR)
 
23
        install -Dm 644 $(CLALSADRV_H)   $(DESTDIR)$(PREFIX)/include/$(CLALSADRV_H)
 
24
        install -Dm 755 $(CLALSADRV_MIN) $(DESTDIR)$(PREFIX)/$(LIBDIR)/$(CLALSADRV_MIN)
 
25
-       /sbin/ldconfig $(PREFIX)/$(LIBDIR)
 
26
+       ln -sf $(CLALSADRV_MIN) $(DESTDIR)$(PREFIX)/$(LIBDIR)/$(CLALSADRV_MAJ)
 
27
        ln -sf $(CLALSADRV_MIN) $(DESTDIR)$(PREFIX)/$(LIBDIR)/$(CLALSADRV_SO)
 
28
 
 
29
 clean: