~ubuntu-branches/ubuntu/feisty/apache2/feisty

« back to all changes in this revision

Viewing changes to debian/patches/to-review/023_largefiles_upstream_fixes

  • Committer: Bazaar Package Importer
  • Author(s): Andreas Barth
  • Date: 2006-12-09 21:05:45 UTC
  • mfrom: (0.6.1 upstream)
  • Revision ID: james.westby@ubuntu.com-20061209210545-h70s0xaqc2v8vqr2
Tags: 2.2.3-3.2
* Non-maintainer upload.
* 043_ajp_connection_reuse: Patch from upstream Bugzilla, fixing a critical
  issue with regard to connection reuse in mod_proxy_ajp.
  Closes: #396265

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
--- build-tree.orig/apache2/srclib/apr/configure.in     2004-08-14 00:27:43.000000000 -0600
2
 
+++ build-tree/apache2/srclib/apr/configure.in  2004-08-14 00:29:08.000000000 -0600
3
 
@@ -1176,20 +1176,20 @@
4
 
 
5
 
 APR_CHECK_SIZEOF_EXTENDED([#include <sys/types.h>], ssize_t, 8)
6
 
 
7
 
-if test "$ac_cv_sizeof_ssize_t" = "$ac_cv_sizeof_int"; then
8
 
-    ssize_t_fmt='#define APR_SSIZE_T_FMT "d"'
9
 
-elif test "$ac_cv_sizeof_ssize_t" = "$ac_cv_sizeof_long"; then
10
 
+if test "$ac_cv_sizeof_ssize_t" = "$ac_cv_sizeof_long"; then
11
 
     ssize_t_fmt='#define APR_SSIZE_T_FMT "ld"'
12
 
+elif test "$ac_cv_sizeof_ssize_t" = "$ac_cv_sizeof_int"; then
13
 
+    ssize_t_fmt='#define APR_SSIZE_T_FMT "d"'
14
 
 else
15
 
     ssize_t_fmt='#error Can not determine the proper size for ssize_t'
16
 
 fi
17
 
 
18
 
 APR_CHECK_SIZEOF_EXTENDED([#include <stddef.h>], size_t, 8)
19
 
 
20
 
-if test "$ac_cv_sizeof_size_t" = "$ac_cv_sizeof_int"; then
21
 
-    size_t_fmt='#define APR_SIZE_T_FMT "d"'
22
 
-elif test "$ac_cv_sizeof_size_t" = "$ac_cv_sizeof_long"; then
23
 
+if test "$ac_cv_sizeof_size_t" = "$ac_cv_sizeof_long"; then
24
 
     size_t_fmt='#define APR_SIZE_T_FMT "ld"'
25
 
+elif test "$ac_cv_sizeof_size_t" = "$ac_cv_sizeof_int"; then
26
 
+    size_t_fmt='#define APR_SIZE_T_FMT "d"'
27
 
 else
28
 
     size_t_fmt='#error Can not determine the proper size for size_t'
29
 
 fi
30
 
@@ -1228,10 +1228,10 @@
31
 
 
32
 
 if test "$ac_cv_sizeof_pid_t" = "$ac_cv_sizeof_short"; then
33
 
     pid_t_fmt='#define APR_PID_T_FMT "hd"'
34
 
-elif test "$ac_cv_sizeof_pid_t" = "$ac_cv_sizeof_int"; then
35
 
-    pid_t_fmt='#define APR_PID_T_FMT "d"'
36
 
 elif test "$ac_cv_sizeof_pid_t" = "$ac_cv_sizeof_long"; then
37
 
     pid_t_fmt='#define APR_PID_T_FMT "ld"'
38
 
+elif test "$ac_cv_sizeof_pid_t" = "$ac_cv_sizeof_int"; then
39
 
+    pid_t_fmt='#define APR_PID_T_FMT "d"'
40
 
 elif test "$ac_cv_sizeof_pid_t" = "$ac_cv_sizeof_long_long"; then
41
 
     pid_t_fmt='#define APR_PID_T_FMT APR_INT64_T_FMT'
42
 
 else
43
 
--- build-tree.orig/apache2/srclib/apr/network_io/unix/sendrecv.c       2004-02-13 02:33:51.000000000 -0700
44
 
+++ build-tree.orig/apache2/srclib/apr/network_io/unix/sendrecv.c       2004-08-14 02:28:51.000000000 -0600
45
 
@@ -244,7 +244,7 @@
46
 
                                  apr_hdtr_t *hdtr, apr_off_t *offset,
47
 
                                  apr_size_t *len, apr_int32_t flags)
48
 
 {
49
 
-    off_t off = *offset;
50
 
+    apr_off_t off = *offset;
51
 
     int rv, nbytes = 0, total_hdrbytes, i;
52
 
     apr_status_t arv;
53
 
 
54
 
@@ -427,7 +427,7 @@
55
 
                                  apr_hdtr_t * hdtr, apr_off_t * offset,
56
 
                                  apr_size_t * len, apr_int32_t flags)
57
 
 {
58
 
-    off_t nbytes = 0;
59
 
+    apr_off_t nbytes = 0;
60
 
     int rv, i;
61
 
     struct sf_hdtr headerstruct;
62
 
     apr_size_t bytes_to_send = *len;
63
 
@@ -869,7 +869,7 @@
64
 
     for (i = 0; i < hdtr->numheaders; i++, curvec++) {
65
 
         sfv[curvec].sfv_fd = SFV_FD_SELF;
66
 
         sfv[curvec].sfv_flag = 0;
67
 
-        sfv[curvec].sfv_off = (off_t)hdtr->headers[i].iov_base;
68
 
+        sfv[curvec].sfv_off = (apr_off_t)hdtr->headers[i].iov_base;
69
 
         sfv[curvec].sfv_len = hdtr->headers[i].iov_len;
70
 
         requested_len += sfv[curvec].sfv_len;
71
 
     }
72
 
@@ -893,7 +893,7 @@
73
 
     for (i = 0; i < hdtr->numtrailers; i++, curvec++) {
74
 
         sfv[curvec].sfv_fd = SFV_FD_SELF;
75
 
         sfv[curvec].sfv_flag = 0;
76
 
-        sfv[curvec].sfv_off = (off_t)hdtr->trailers[i].iov_base;
77
 
+        sfv[curvec].sfv_off = (apr_off_t)hdtr->trailers[i].iov_base;
78
 
         sfv[curvec].sfv_len = hdtr->trailers[i].iov_len;
79
 
         requested_len += sfv[curvec].sfv_len;
80
 
     }
81
 
 
82
 
--- build-tree/apache2/server/protocol.c.orig   2004-08-14 05:19:58.000000000 -0600
83
 
+++ build-tree/apache2/server/protocol.c        2004-08-14 05:14:37.000000000 -0600
84
 
@@ -1285,7 +1285,7 @@
85
 
 
86
 
 #if APR_HAS_MMAP
87
 
 /* send data from an in-memory buffer */
88
 
-AP_DECLARE(size_t) ap_send_mmap(apr_mmap_t *mm, request_rec *r, size_t offset,
89
 
+AP_DECLARE(size_t) ap_send_mmap(apr_mmap_t *mm, request_rec *r, apr_off_t offset,
90
 
                                 size_t length)
91
 
 {
92
 
     conn_rec *c = r->connection;
93
 
 
94
 
--- build-tree/apache2/include/http_protocol.h.orig     2004-08-14 05:10:27.000000000 -0600
95
 
+++ build-tree/apache2/include/http_protocol.h  2004-08-14 05:12:16.000000000 -0600
96
 
@@ -215,9 +215,9 @@
97
 
  * @param offset The offset into the MMAP to start sending
98
 
  * @param length The amount of data to send
99
 
  * @return The number of bytes sent
100
 
- * @deffunc size_t ap_send_mmap(apr_mmap_t *mm, request_rec *r, size_t offset, size_t length)
101
 
+ * @deffunc size_t ap_send_mmap(apr_mmap_t *mm, request_rec *r, apr_off_t offset, size_t length)
102
 
  */
103
 
-AP_DECLARE(size_t) ap_send_mmap(apr_mmap_t *mm, request_rec *r, size_t offset,
104
 
+AP_DECLARE(size_t) ap_send_mmap(apr_mmap_t *mm, request_rec *r, apr_off_t offset,
105
 
                              size_t length);
106
 
 #endif
107
 
 
108
 
 
109
 
--- build-tree/apache2/modules/experimental/mod_disk_cache.c.orig       2004-08-14 05:17:23.000000000 -0600
110
 
+++ build-tree/apache2/modules/experimental/mod_disk_cache.c    2004-08-14 05:17:42.000000000 -0600
111
 
@@ -57,7 +57,7 @@
112
 
 typedef struct {
113
 
     const char* cache_root;
114
 
     apr_size_t cache_root_len;
115
 
-    off_t space;                 /* Maximum cache size (in 1024 bytes) */
116
 
+    apr_off_t space;             /* Maximum cache size (in 1024 bytes) */
117
 
     apr_time_t maxexpire;        /* Maximum time to keep cached files in msecs */
118
 
     apr_time_t defaultexpire;    /* default time to keep cached file in msecs */
119
 
     double lmfactor;             /* factor for estimating expires date */