~ubuntu-branches/ubuntu/gutsy/alsa-lib/gutsy

« back to all changes in this revision

Viewing changes to debian/patches/01_alpha_versioned_symbols.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Jordi Mallach
  • Date: 2005-01-16 19:34:04 UTC
  • Revision ID: james.westby@ubuntu.com-20050116193404-iqr2qs5wnsth73sh
Tags: 1.0.8-1
* New upstream release
  (Closes: #290034 "libasound2 1.0.7 causing problems with XMMS")
* Thomas Hood:
  - Eliminate 10_pcm_wait_assertion.dpatch (applied upstream)
  - examples/asound.conf_dmix
    + Simplify
    + Mention /usr/share/doc/libasound2-doc/html/conf.html
  - debian/rules 
    + Eliminate debian/libasound2.shlibs; instead, use
         dh_makeshibs -V'libasound2 (>> 1.0.8)'
      (Version bumped up from 1.0.5)
    + Add -n option to dh_makeshlibs -plibasound2-plugins so that
      no ldconfig is done in libasound2-plugins's post(rm|inst).
      Eliminates lintian warning postinst-has-useless-call-to-ldconfig
* Jordi Mallach:
  - debian/rules: minor simplification.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
#! /bin/sh -e
 
2
## 01_alpha_symbols.dpatch by Jordi Mallach <jordi@debian.org>
 
3
##
 
4
## All lines beginning with `## DP:' are a description of the patch.
 
5
## DP: Fix use of embedded assembly so that we always use symbol versioning
 
6
## DP: instead of weak symbol aliases on alpha, since the assembly used for
 
7
## DP: weak symbols is apparently non-portable.
 
8
 
 
9
if [ $# -lt 1 ]; then
 
10
    echo "`basename $0`: script expects -patch|-unpatch as argument" >&2
 
11
    exit 1
 
12
fi
 
13
 
 
14
[ -f debian/patches/00patch-opts ] && . debian/patches/00patch-opts
 
15
patch_opts="${patch_opts:--f --no-backup-if-mismatch} ${2:+-d $2}"
 
16
 
 
17
case "$1" in
 
18
    -patch) patch -p1 ${patch_opts} < $0;;
 
19
    -unpatch) patch -R -p1 ${patch_opts} < $0;;
 
20
    *)
 
21
        echo "`basename $0`: script expects -patch|-unpatch as argument" >&2
 
22
        exit 1;;
 
23
esac
 
24
 
 
25
exit 0
 
26
 
 
27
@DPATCH@
 
28
diff -urNad /home/jordi/svn/pkg-alsa/trunk/build-area/alsa-lib-1.0.6/include/alsa-symbols.h alsa-lib-1.0.6/include/alsa-symbols.h
 
29
--- /home/jordi/svn/pkg-alsa/trunk/build-area/alsa-lib-1.0.6/include/alsa-symbols.h     2003-08-13 15:18:36.000000000 +0200
 
30
+++ alsa-lib-1.0.6/include/alsa-symbols.h       2004-09-26 18:42:57.000000000 +0200
 
31
@@ -43,7 +43,7 @@
 
32
        __asm__ (".symver " #real "," #name "@@" #version)
 
33
 #endif
 
34
 
 
35
-#ifdef USE_VERSIONED_SYMBOLS
 
36
+#if defined(USE_VERSIONED_SYMBOLS) || defined(__alpha__)
 
37
 #define use_symbol_version(real, name, version) \
 
38
                symbol_version(real, name, version)
 
39
 #define use_default_symbol_version(real, name, version) \