~ubuntu-branches/ubuntu/gutsy/slocate/gutsy

« back to all changes in this revision

Viewing changes to README

  • Committer: Bazaar Package Importer
  • Author(s): Kevin Lindsay
  • Date: 2006-01-06 09:36:28 UTC
  • mfrom: (1.1.2 upstream)
  • Revision ID: james.westby@ubuntu.com-20060106093628-cq82c695r3st8xkv
Tags: 3.0.beta.r3-1
* The environment variable LOCATE_PATH was not being used properly. It will
  now be used the same as in v2.7. Closes: #345646
* slocate was returning non zero for -h, --help, -V and --version. It now
  returns zero.
* PRUNEFS was being ignored in /etc/updatedb.conf
* Added documentation describing how /etc/updatedb.conf is used and what
  is supported to the README and the slocate.1 and updatedb.1 man pages.
* README.debian was removed in 3.0.beta.r1-1 to close bug 272131, but it was
  accidently readded in 3.0.beta.r2-1. I now have a use for it, so it is now
  here to stay.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
                           Secure Locate v3.0 beta
2
 
                           -----------------------
3
 
                          Released December 19, 2005
 
1
                            Secure Locate v3.0 beta
 
2
                            -----------------------
 
3
                            Released January 5, 2006
4
4
           Copyright (c) 1999, 2000, 2001, 2002, 2003, 2004, 2005, 2006
5
5
                                Kevin Lindsay
6
6
 
10
10
 Setting up Secure Locate Manually ................................... I
11
11
 Creating the Database ............................................... II
12
12
 Options ............................................................. III
13
 
 Ports ............................................................... IV
14
 
 Author and Bugs  .................................................... V
 
13
 Configuration File................................................... IV
 
14
 Ports ............................................................... V
 
15
 Author and Bugs  .................................................... VI
15
16
 
16
17
--------------------------------------------------------------------------
17
18
 
158
159
     -V
159
160
     --version          - Display version.
160
161
                           
161
 
 
162
 
IV.  PORTS
 
162
IV.  CONFIGURATION FILE
 
163
     ------------------
 
164
 
 
165
     Secure Locate will parse GNU Locate's '/etc/updatedb.conf' when the '-c'
 
166
     argument is provided with 'slocate' or automatically when 'updatedb' is
 
167
     run. But please be aware that Secure Locate currently does NOT support
 
168
     all options provided by GNU Locate's configuration file.
 
169
 
 
170
     Options currently supported by Secure Locate are PRUNEFS and PRUNEPATHS.
 
171
 
 
172
V.   PORTS
163
173
     -----
164
174
 
165
175
     v3.0 is a complete rewrite. As of this version it has only been tested
166
176
     on Linux.
167
177
 
168
178
 
169
 
V.   AUTHOR AND BUGS
 
179
VI.  AUTHOR AND BUGS
170
180
     ---------------
171
181
 
172
182
     Author:      Kevin Lindsay