~ubuntu-branches/ubuntu/gutsy/slocate/gutsy

« back to all changes in this revision

Viewing changes to doc/slocate.1

  • Committer: Bazaar Package Importer
  • Author(s): Kevin Lindsay
  • Date: 2006-01-06 09:36:28 UTC
  • mfrom: (1.1.2 upstream)
  • Revision ID: james.westby@ubuntu.com-20060106093628-cq82c695r3st8xkv
Tags: 3.0.beta.r3-1
* The environment variable LOCATE_PATH was not being used properly. It will
  now be used the same as in v2.7. Closes: #345646
* slocate was returning non zero for -h, --help, -V and --version. It now
  returns zero.
* PRUNEFS was being ignored in /etc/updatedb.conf
* Added documentation describing how /etc/updatedb.conf is used and what
  is supported to the README and the slocate.1 and updatedb.1 man pages.
* README.debian was removed in 3.0.beta.r1-1 to close bug 272131, but it was
  accidently readded in 3.0.beta.r2-1. I now have a use for it, so it is now
  here to stay.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
.TH SLOCATE 1
 
1
.TH SLOCATE 1 "January 6, 2006" 
2
2
.SH NAME
3
3
slocate \- Security Enhanced version of the GNU Locate
4
4
.SH SYNOPSIS
41
41
Exclude files on specific file systems from the slocate database.
42
42
.TP
43
43
.I \-c
44
 
Parse '/etc/updatedb.conf' when updating the slocate database.
 
44
Parse '/etc/updatedb.conf' when updating the slocate database. (see 
 
45
.SM
 
46
.B CONFIGURATION FILE
 
47
below).
45
48
.TP
46
49
.I \-l <level>
47
50
Security level.
86
89
.TP
87
90
LOCATE_PATH 
88
91
        Colon-separated list of databases to search.
 
92
.SH CONFIGURATION FILE
 
93
Secure Locate will parse GNU Locate's 
 
94
.I /etc/updatedb.conf
 
95
when the 
 
96
.I-c
 
97
argument is provided. But please be aware that Secure Locate currently
 
98
does NOT support all options provided by GNU Locate's configuration file.
 
99
 
 
100
Options currently supported by Secure Locate are
 
101
.B PRUNEFS
 
102
and
 
103
.B PRUNEPATHS
89
104
.SH VERSION
90
105
Secure Locate v3.0 beta
91
106
.SH AUTHOR