~ubuntu-branches/ubuntu/hardy/logrotate/hardy-updates

« back to all changes in this revision

Viewing changes to debian/patches/cpp-crossbuild.patch

  • Committer: Bazaar Package Importer
  • Author(s): Paul Martin
  • Date: 2006-04-08 23:02:19 UTC
  • mfrom: (3.1.1 dapper)
  • Revision ID: james.westby@ubuntu.com-20060408230219-7moi9qw2g42w1nye
Tags: 3.7.1-3
* Patch debian/control to fix FTBFS on kfreebsd-amd64. Perhaps we need
  a build-depends macro for !kfreebsd. (Closes: #361465)
* Use and depend on debhelper version 5.
* Switch from dpatch to quilt.
* cpp-crossbuild.patch: change from using $(CPP) to $(CC) -E.
  Thanks to NIIBE Yutaka. (Closes: #284040)
* dst.patch: fix mktime initialisation so that daylight savings is
  taken into account. Thanks to Holger Weiss. (Closes: #278591)
* man-333996.patch: fix typos in logrotate.8 where "then" should be
  "than". Thanks to Adrian Knoth. (Closes: #333996)
* manpage.patch: Apply missed fixes from #101272. Thanks to J S Bygott.
  (Closes: #335060)
* script-argument.patch: Allow the use of $1 in scripts again.
  (Closes: #330783)
* README.Debian: Document that sysklogd does its own log rotation.
  (Closes: #308963)
* README.Debian: Document how scripts are called. (Closes: #308920)
* Update the copyright file.
* debian/control: remove versioned dependency on cron. The version of
  cron forbidden pre-dates woody (currently "oldstable") by several
  years. This versioned dependency is preventing logrotate being
  installed with bcron. (Closes: #304038, #349150)
* debian/rules: Fix backports, allowing them to use selinux.
  (Closes: #340363)
* uncompressChild-warning.patch: Fix a "might be used uninitialised" 
  warning from gcc.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Closes: #284040
 
2
Patch from: NIIBE Yutaka <gniibe@fsij.org>
 
3
 
 
4
Cross-building logrotate with dpkg-cross, I encountered a problem.
 
5
dpkg-cross sets CPP variable, and compilation failures, because
 
6
the executable 'cpp' does not accept multiple input files.
 
7
 
 
8
 
 
9
Index: logrotate-3.7.1/Makefile
 
10
===================================================================
 
11
--- logrotate-3.7.1.orig/Makefile       2003-10-09 21:05:07.000000000 +0100
 
12
+++ logrotate-3.7.1/Makefile    2006-04-08 21:21:31.333853922 +0100
 
13
@@ -88,7 +88,7 @@
 
14
        rm -f $(OBJS) $(PROG) core* .depend
 
15
 
 
16
 depend:
 
17
-       $(CPP) $(CFLAGS) -M $(SOURCES) > .depend
 
18
+       $(CC) -E $(CFLAGS) -M $(SOURCES) > .depend
 
19
 
 
20
 .PHONY : test
 
21
 test: $(TARGET)