~ubuntu-branches/ubuntu/intrepid/gstreamer0.10-ffmpeg/intrepid

« back to all changes in this revision

Viewing changes to debian/patches/03_disable-wavpack.patch

  • Committer: Bazaar Package Importer
  • Author(s): Emilio Pozuelo Monfort
  • Date: 2008-01-09 13:04:18 UTC
  • Revision ID: james.westby@ubuntu.com-20080109130418-dw3u5mj9vrux0xhc
Tags: 0.10.3-4ubuntu1
* Sync with Debian.
  - debian/rules:
    + Point out that this is Ubuntu and not Debian.
  - debian/control:
    + Modify Maintainer value to match the DebianMaintainerField
      specification.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
--- ext/ffmpeg/gstffmpegdec.c.old       2008-01-07 19:44:04.000000000 +0100
 
2
+++ ext/ffmpeg/gstffmpegdec.c   2008-01-07 19:45:42.000000000 +0100
 
3
@@ -2253,6 +2253,10 @@
 
4
             in_plugin->id <= CODEC_ID_PCM_S24DAUD)) {
 
5
       goto next;
 
6
     }
 
7
+    if (!strcmp (in_plugin->name, "wavpack")) {
 
8
+      GST_LOG ("Ignoring decoder %s", in_plugin->name);
 
9
+      goto next;
 
10
+    }
 
11
 
 
12
     /* only decoders */
 
13
     if (!in_plugin->decode) {
 
14
--- ext/ffmpeg/gstffmpegdemux.c.old     2008-01-07 19:44:25.000000000 +0100
 
15
+++ ext/ffmpeg/gstffmpegdemux.c 2008-01-07 19:46:11.000000000 +0100
 
16
@@ -1481,7 +1481,7 @@
 
17
 
 
18
     /* these don't do what one would expect or
 
19
      * are only partially functional/useful */
 
20
-    if (!strcmp (in_plugin->name, "aac"))
 
21
+    if (!strcmp (in_plugin->name, "aac") || !strcmp (in_plugin->name, "wv"))
 
22
       goto next;
 
23
 
 
24
     /* Don't use the typefind functions of formats for which we already have