~ubuntu-branches/ubuntu/karmic/mp3val/karmic

« back to all changes in this revision

Viewing changes to debian/patches/20_bts-442679_FTBFS_build_twice.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Sandro Tosi
  • Date: 2008-01-23 09:11:35 UTC
  • mfrom: (3.1.3 hardy)
  • Revision ID: james.westby@ubuntu.com-20080123091135-r10vczs51d63e8p0
Tags: 0.1.7-3
* debian/control
  - bump Standards-Version to 3.7.3
  - bump dependency against debhelper to >=5
* debian/compat
  - bump to 5
* debian/dirs
  - removed since not needed
* debian/rules
  - do not ignore anymore clean error due to missing makefile
* debian/copyright
  - clear separation of upstream author, license and copyright
  - link to /usr/share/common-licenses/GPL file
* debian/mp3val.1
  - escaped minus signs (lintian warning)

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
#! /bin/sh /usr/share/dpatch/dpatch-run
 
2
## 20_bts-442679_FTBFS_build_twice.dpatch by Sandro Tosi <matrixhasu@gmail.com>
 
3
##
 
4
## All lines beginning with `## DP:' are a description of the patch.
 
5
## DP: No description.
 
6
 
 
7
@DPATCH@
 
8
diff -urNad mp3val~/Makefile.gcc mp3val/Makefile.gcc
 
9
--- mp3val~/Makefile.gcc        2007-09-20 20:43:07.000000000 +0200
 
10
+++ mp3val/Makefile.gcc 2007-09-20 20:43:54.000000000 +0200
 
11
@@ -1,6 +1,5 @@
 
12
 mp3val.exe: main.o mpegparse.o out.o report.o crossapi.o crc.o
 
13
        g++ $(CFLAGS) -Wall main.o mpegparse.o out.o report.o crossapi.o -o mp3val
 
14
-       strip mp3val.exe
 
15
 main.o: main.cpp
 
16
        g++ $(CFLAGS) -Wall -c main.cpp
 
17
 mpegparse.o: mpegparse.cpp
 
18
@@ -15,4 +14,4 @@
 
19
        g++ $(CFLAGS) -Wall -c crc.cpp
 
20
 clean:
 
21
        rm *.o
 
22
-       rm *.exe
 
23
+       rm mp3val