~ubuntu-branches/ubuntu/natty/libgpg-error/natty

« back to all changes in this revision

Viewing changes to debian/patches/06_Makefile.in.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Jonas Meurer
  • Date: 2011-01-03 02:23:00 UTC
  • mfrom: (2.1.5 experimental)
  • Revision ID: james.westby@ubuntu.com-20110103022300-o65gv8tvqsuhglut
Tags: 1.10-0.2
* Non-maintainer upload
* Add libgpg-error0-udeb package for debian-installer
* change 'XC-Package-Type' to 'Package-Type' for udeb in debian/control
* empty dependency_libs in .la file (thanks to Ubuntu)
* Install .la file and .so link to /usr/lib after discussion on #debian-devel
  and debian-devel@lists.debian.org.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
#! /bin/sh -e
2
 
## 06_Makefile.in.dpatch by Jose Carlos Garcia Sogo <jsogo@debian.org>
3
 
##
4
 
## All lines beginning with `## DP:' are a description of the patch.
5
 
## DP: No description.
6
 
 
7
 
if [ $# -lt 1 ]; then
8
 
    echo "`basename $0`: script expects -patch|-unpatch as argument" >&2
9
 
    exit 1
10
 
fi
11
 
 
12
 
[ -f debian/patches/00patch-opts ] && . debian/patches/00patch-opts
13
 
patch_opts="${patch_opts:--f --no-backup-if-mismatch} ${2:+-d $2}"
14
 
 
15
 
case "$1" in
16
 
    -patch) patch -p1 ${patch_opts} < $0;;
17
 
    -unpatch) patch -R -p1 ${patch_opts} < $0;;
18
 
    *)
19
 
        echo "`basename $0`: script expects -patch|-unpatch as argument" >&2
20
 
        exit 1;;
21
 
esac
22
 
 
23
 
exit 0
24
 
 
25
 
@DPATCH@
26
 
diff -urNad /home/jose/devel/libgpg-error/libgpg-error-1.0/Makefile.in libgpg-error-1.0/Makefile.in
27
 
--- /home/jose/devel/libgpg-error/libgpg-error-1.0/Makefile.in  2004-08-02 12:57:44.000000000 +0200
28
 
+++ libgpg-error-1.0/Makefile.in        2004-08-02 12:57:45.000000000 +0200
29
 
@@ -158,7 +158,7 @@
30
 
 sysconfdir = @sysconfdir@
31
 
 target_alias = @target_alias@
32
 
 
33
 
-SUBDIRS = m4 src tests po
34
 
+SUBDIRS = src tests po
35
 
 
36
 
 ACLOCAL_AMFLAGS = -I m4
37
 
 
38
 
@@ -199,7 +199,7 @@
39
 
 $(srcdir)/configure: @MAINTAINER_MODE_TRUE@ $(srcdir)/configure.ac $(ACLOCAL_M4) $(CONFIGURE_DEPENDENCIES)
40
 
        cd $(srcdir) && $(AUTOCONF)
41
 
 
42
 
-$(ACLOCAL_M4): @MAINTAINER_MODE_TRUE@ configure.ac m4/ac_prog_cc_for_build.m4 m4/codeset.m4 m4/gettext.m4 m4/glibc21.m4 m4/iconv.m4 m4/intdiv0.m4 m4/inttypes-pri.m4 m4/inttypes.m4 m4/inttypes_h.m4 m4/isc-posix.m4 m4/lcmessage.m4 m4/lib-ld.m4 m4/lib-link.m4 m4/lib-prefix.m4 m4/libtool.m4 m4/nls.m4 m4/po.m4 m4/progtest.m4 m4/stdint_h.m4 m4/uintmax_t.m4 m4/ulonglong.m4
43
 
+$(ACLOCAL_M4): @MAINTAINER_MODE_TRUE@ configure.ac m4/ac_prog_cc_for_build.m4 m4/codeset.m4 m4/gettext.m4 m4/glibc21.m4 m4/iconv.m4 m4/intdiv0.m4 m4/inttypes-pri.m4 m4/inttypes.m4 m4/inttypes_h.m4 m4/isc-posix.m4 m4/lcmessage.m4 m4/lib-ld.m4 m4/lib-link.m4 m4/lib-prefix.m4 m4/nls.m4 m4/po.m4 m4/progtest.m4 m4/stdint_h.m4 m4/uintmax_t.m4 m4/ulonglong.m4
44
 
        cd $(srcdir) && $(ACLOCAL) $(ACLOCAL_AMFLAGS)
45
 
 
46
 
 config.h: stamp-h1