~ubuntu-branches/ubuntu/natty/lighttpd/natty

« back to all changes in this revision

Viewing changes to debian/patches/debian-changes-1.4.28-1

  • Committer: Bazaar Package Importer
  • Author(s): Bhavani Shankar
  • Date: 2010-11-21 12:09:27 UTC
  • mfrom: (6.1.12 sid)
  • Revision ID: james.westby@ubuntu.com-20101121120927-7tlcueke98p0y25r
Tags: 1.4.28-2ubuntu1
* Merge from debian unstable. Remaining changes:
  - debian/control:
    + libgamin-dev rather than libfam-dev to fix startup warning.
    + debhelper Build-depends bumped to (>= 7.0.50) for
      overrides in rules file.
  - debian/index.html: s/Debian/Ubuntu/g branding on the default page.
  - Added a UFW profile set:
    + debian/lighttpd.dirs: added etc/ufw/applications.d
    + debian/rules: install the ufw profile.
    + debian/control: Suggests on ufw.
  - Add lighttpd-dev package:
    + debian/control: Added lighttpd-dev package; Build-depends on
      automake, libtool
    + debian/lighttpd-dev.install: Added.
  - debian/rules:
    + Add override_dh_installinit to set "defaults 91 09" to not start
      before apache2 but in the same runlevel with the same priority.
  - debian/patches/build-dev-package.patch: Updated
  - debian/lighttpd.conf: Comment 'use-ipv6.pl' by default, which causes
    failure to bind port in ipv4 (LP: #551211)

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
Description: Upstream changes introduced in version 1.4.28-1
2
 
 This patch has been created by dpkg-source during the package build.
3
 
 Here's the last changelog entry, hopefully it gives details on why
4
 
 those changes were made:
5
 
 .
6
 
 lighttpd (1.4.28-1) unstable; urgency=low
7
 
 .
8
 
   [ Olaf van der Spek ]
9
 
   * New upstream release (closes: 521235, 572031, 564556)
10
 
   * Add check_syntax() from Ubuntu (closes: 589200)
11
 
 .
12
 
 The person named in the Author field signed this changelog entry.
13
 
Author: Thijs Kinkhorst <thijs@debian.org>
14
 
Bug-Debian: http://bugs.debian.org/521235
15
 
Bug-Debian: http://bugs.debian.org/564556
16
 
Bug-Debian: http://bugs.debian.org/572031
17
 
Bug-Debian: http://bugs.debian.org/589200
18
 
 
19
 
---
20
 
The information above should follow the Patch Tagging Guidelines, please
21
 
checkout http://dep.debian.net/deps/dep3/ to learn about the format. Here
22
 
are templates for supplementary fields that you might want to add:
23
 
 
24
 
Origin: <vendor|upstream|other>, <url of original patch>
25
 
Bug: <url in upstream bugtracker>
26
 
Bug-Debian: http://bugs.debian.org/<bugnumber>
27
 
Bug-Ubuntu: https://launchpad.net/bugs/<bugnumber>
28
 
Forwarded: <no|not-needed|url proving that it has been forwarded>
29
 
Reviewed-By: <name and email of someone who approved the patch>
30
 
Last-Update: <YYYY-MM-DD>
31
 
 
32
 
--- lighttpd-1.4.28.orig/src/configparser.c
33
 
+++ lighttpd-1.4.28/src/configparser.c
34
 
@@ -4,7 +4,7 @@
35
 
 /* First off, code is include which follows the "include" declaration
36
 
 ** in the input file. */
37
 
 #include <stdio.h>
38
 
-#line 5 "../../src/configparser.y"
39
 
+#line 5 "./configparser.y"
40
 
 
41
 
 #include "configfile.h"
42
 
 #include "buffer.h"
43
 
@@ -518,42 +518,42 @@ static void yy_destructor(YYCODETYPE yym
44
 
     case 23:
45
 
     case 24:
46
 
     case 25:
47
 
-#line 144 "../../src/configparser.y"
48
 
+#line 144 "./configparser.y"
49
 
 { buffer_free((yypminor->yy0)); }
50
 
 #line 523 "configparser.c"
51
 
       break;
52
 
     case 35:
53
 
-#line 135 "../../src/configparser.y"
54
 
+#line 135 "./configparser.y"
55
 
 { (yypminor->yy41)->free((yypminor->yy41)); }
56
 
 #line 528 "configparser.c"
57
 
       break;
58
 
     case 36:
59
 
-#line 136 "../../src/configparser.y"
60
 
+#line 136 "./configparser.y"
61
 
 { (yypminor->yy41)->free((yypminor->yy41)); }
62
 
 #line 533 "configparser.c"
63
 
       break;
64
 
     case 37:
65
 
-#line 137 "../../src/configparser.y"
66
 
+#line 137 "./configparser.y"
67
 
 { (yypminor->yy41)->free((yypminor->yy41)); }
68
 
 #line 538 "configparser.c"
69
 
       break;
70
 
     case 39:
71
 
-#line 138 "../../src/configparser.y"
72
 
+#line 138 "./configparser.y"
73
 
 { array_free((yypminor->yy40)); }
74
 
 #line 543 "configparser.c"
75
 
       break;
76
 
     case 40:
77
 
-#line 139 "../../src/configparser.y"
78
 
+#line 139 "./configparser.y"
79
 
 { array_free((yypminor->yy40)); }
80
 
 #line 548 "configparser.c"
81
 
       break;
82
 
     case 41:
83
 
-#line 140 "../../src/configparser.y"
84
 
+#line 140 "./configparser.y"
85
 
 { buffer_free((yypminor->yy43)); }
86
 
 #line 553 "configparser.c"
87
 
       break;
88
 
     case 42:
89
 
-#line 141 "../../src/configparser.y"
90
 
+#line 141 "./configparser.y"
91
 
 { buffer_free((yypminor->yy43)); }
92
 
 #line 558 "configparser.c"
93
 
       break;
94
 
@@ -823,7 +823,7 @@ static void yy_reduce(
95
 
         /* No destructor defined for global */
96
 
         break;
97
 
       case 5:
98
 
-#line 117 "../../src/configparser.y"
99
 
+#line 117 "./configparser.y"
100
 
 { yymsp[-1].minor.yy78 = NULL; }
101
 
 #line 828 "configparser.c"
102
 
   yy_destructor(1,&yymsp[0].minor);
103
 
@@ -838,7 +838,7 @@ static void yy_reduce(
104
 
   yy_destructor(1,&yymsp[0].minor);
105
 
         break;
106
 
       case 9:
107
 
-#line 146 "../../src/configparser.y"
108
 
+#line 146 "./configparser.y"
109
 
 {
110
 
   if (ctx->ok) {
111
 
     buffer_copy_string_buffer(yymsp[0].minor.yy41->key, yymsp[-2].minor.yy43);
112
 
@@ -866,7 +866,7 @@ static void yy_reduce(
113
 
   yy_destructor(2,&yymsp[-1].minor);
114
 
         break;
115
 
       case 10:
116
 
-#line 170 "../../src/configparser.y"
117
 
+#line 170 "./configparser.y"
118
 
 {
119
 
   array *vars = ctx->current->value;
120
 
   data_unset *du;
121
 
@@ -909,7 +909,7 @@ static void yy_reduce(
122
 
   yy_destructor(3,&yymsp[-1].minor);
123
 
         break;
124
 
       case 11:
125
 
-#line 209 "../../src/configparser.y"
126
 
+#line 209 "./configparser.y"
127
 
 {
128
 
   if (strchr(yymsp[0].minor.yy0->ptr, '.') == NULL) {
129
 
     yygotominor.yy43 = buffer_init_string("var.");
130
 
@@ -924,7 +924,7 @@ static void yy_reduce(
131
 
 #line 924 "configparser.c"
132
 
         break;
133
 
       case 12:
134
 
-#line 221 "../../src/configparser.y"
135
 
+#line 221 "./configparser.y"
136
 
 {
137
 
   yygotominor.yy41 = configparser_merge_data(yymsp[-2].minor.yy41, yymsp[0].minor.yy41);
138
 
   if (NULL == yygotominor.yy41) {
139
 
@@ -938,7 +938,7 @@ static void yy_reduce(
140
 
   yy_destructor(5,&yymsp[-1].minor);
141
 
         break;
142
 
       case 13:
143
 
-#line 231 "../../src/configparser.y"
144
 
+#line 231 "./configparser.y"
145
 
 {
146
 
   yygotominor.yy41 = yymsp[0].minor.yy41;
147
 
   yymsp[0].minor.yy41 = NULL;
148
 
@@ -946,7 +946,7 @@ static void yy_reduce(
149
 
 #line 946 "configparser.c"
150
 
         break;
151
 
       case 14:
152
 
-#line 236 "../../src/configparser.y"
153
 
+#line 236 "./configparser.y"
154
 
 {
155
 
   yygotominor.yy41 = NULL;
156
 
   if (strncmp(yymsp[0].minor.yy43->ptr, "env.", sizeof("env.") - 1) == 0) {
157
 
@@ -976,7 +976,7 @@ static void yy_reduce(
158
 
 #line 976 "configparser.c"
159
 
         break;
160
 
       case 15:
161
 
-#line 263 "../../src/configparser.y"
162
 
+#line 263 "./configparser.y"
163
 
 {
164
 
   yygotominor.yy41 = (data_unset *)data_string_init();
165
 
   buffer_copy_string_buffer(((data_string *)(yygotominor.yy41))->value, yymsp[0].minor.yy0);
166
 
@@ -986,7 +986,7 @@ static void yy_reduce(
167
 
 #line 986 "configparser.c"
168
 
         break;
169
 
       case 16:
170
 
-#line 270 "../../src/configparser.y"
171
 
+#line 270 "./configparser.y"
172
 
 {
173
 
   yygotominor.yy41 = (data_unset *)data_integer_init();
174
 
   ((data_integer *)(yygotominor.yy41))->value = strtol(yymsp[0].minor.yy0->ptr, NULL, 10);
175
 
@@ -996,7 +996,7 @@ static void yy_reduce(
176
 
 #line 996 "configparser.c"
177
 
         break;
178
 
       case 17:
179
 
-#line 276 "../../src/configparser.y"
180
 
+#line 276 "./configparser.y"
181
 
 {
182
 
   yygotominor.yy41 = (data_unset *)data_array_init();
183
 
   array_free(((data_array *)(yygotominor.yy41))->value);
184
 
@@ -1006,7 +1006,7 @@ static void yy_reduce(
185
 
 #line 1006 "configparser.c"
186
 
         break;
187
 
       case 18:
188
 
-#line 282 "../../src/configparser.y"
189
 
+#line 282 "./configparser.y"
190
 
 {
191
 
   yygotominor.yy40 = array_init();
192
 
 }
193
 
@@ -1015,7 +1015,7 @@ static void yy_reduce(
194
 
   yy_destructor(9,&yymsp[0].minor);
195
 
         break;
196
 
       case 19:
197
 
-#line 285 "../../src/configparser.y"
198
 
+#line 285 "./configparser.y"
199
 
 {
200
 
   yygotominor.yy40 = yymsp[-1].minor.yy40;
201
 
   yymsp[-1].minor.yy40 = NULL;
202
 
@@ -1025,7 +1025,7 @@ static void yy_reduce(
203
 
   yy_destructor(9,&yymsp[0].minor);
204
 
         break;
205
 
       case 20:
206
 
-#line 290 "../../src/configparser.y"
207
 
+#line 290 "./configparser.y"
208
 
 {
209
 
   if (buffer_is_empty(yymsp[0].minor.yy41->key) ||
210
 
       NULL == array_get_element(yymsp[-2].minor.yy40, yymsp[0].minor.yy41->key->ptr)) {
211
 
@@ -1046,7 +1046,7 @@ static void yy_reduce(
212
 
   yy_destructor(10,&yymsp[-1].minor);
213
 
         break;
214
 
       case 21:
215
 
-#line 307 "../../src/configparser.y"
216
 
+#line 307 "./configparser.y"
217
 
 {
218
 
   yygotominor.yy40 = yymsp[-1].minor.yy40;
219
 
   yymsp[-1].minor.yy40 = NULL;
220
 
@@ -1055,7 +1055,7 @@ static void yy_reduce(
221
 
   yy_destructor(10,&yymsp[0].minor);
222
 
         break;
223
 
       case 22:
224
 
-#line 312 "../../src/configparser.y"
225
 
+#line 312 "./configparser.y"
226
 
 {
227
 
   yygotominor.yy40 = array_init();
228
 
   array_insert_unique(yygotominor.yy40, yymsp[0].minor.yy41);
229
 
@@ -1064,7 +1064,7 @@ static void yy_reduce(
230
 
 #line 1064 "configparser.c"
231
 
         break;
232
 
       case 23:
233
 
-#line 318 "../../src/configparser.y"
234
 
+#line 318 "./configparser.y"
235
 
 {
236
 
   yygotominor.yy41 = yymsp[0].minor.yy41;
237
 
   yymsp[0].minor.yy41 = NULL;
238
 
@@ -1072,7 +1072,7 @@ static void yy_reduce(
239
 
 #line 1072 "configparser.c"
240
 
         break;
241
 
       case 24:
242
 
-#line 322 "../../src/configparser.y"
243
 
+#line 322 "./configparser.y"
244
 
 {
245
 
   buffer_copy_string_buffer(yymsp[0].minor.yy41->key, yymsp[-2].minor.yy43);
246
 
   buffer_free(yymsp[-2].minor.yy43);
247
 
@@ -1090,7 +1090,7 @@ static void yy_reduce(
248
 
       case 26:
249
 
         break;
250
 
       case 27:
251
 
-#line 334 "../../src/configparser.y"
252
 
+#line 334 "./configparser.y"
253
 
 {
254
 
   data_config *dc;
255
 
   dc = (data_config *)array_get_element(ctx->srv->config_context, "global");
256
 
@@ -1101,7 +1101,7 @@ static void yy_reduce(
257
 
   yy_destructor(12,&yymsp[0].minor);
258
 
         break;
259
 
       case 28:
260
 
-#line 341 "../../src/configparser.y"
261
 
+#line 341 "./configparser.y"
262
 
 {
263
 
   data_config *cur;
264
 
 
265
 
@@ -1119,7 +1119,7 @@ static void yy_reduce(
266
 
   yy_destructor(14,&yymsp[0].minor);
267
 
         break;
268
 
       case 29:
269
 
-#line 352 "../../src/configparser.y"
270
 
+#line 352 "./configparser.y"
271
 
 {
272
 
   if (yymsp[-3].minor.yy78->context_ndx >= yymsp[0].minor.yy78->context_ndx) {
273
 
     fprintf(stderr, "unreachable else condition\n");
274
 
@@ -1136,7 +1136,7 @@ static void yy_reduce(
275
 
   yy_destructor(15,&yymsp[-1].minor);
276
 
         break;
277
 
       case 30:
278
 
-#line 364 "../../src/configparser.y"
279
 
+#line 364 "./configparser.y"
280
 
 {
281
 
   yygotominor.yy78 = yymsp[0].minor.yy78;
282
 
   yymsp[0].minor.yy78 = NULL;
283
 
@@ -1144,7 +1144,7 @@ static void yy_reduce(
284
 
 #line 1144 "configparser.c"
285
 
         break;
286
 
       case 31:
287
 
-#line 369 "../../src/configparser.y"
288
 
+#line 369 "./configparser.y"
289
 
 {
290
 
   data_config *cur;
291
 
 
292
 
@@ -1162,7 +1162,7 @@ static void yy_reduce(
293
 
   yy_destructor(14,&yymsp[0].minor);
294
 
         break;
295
 
       case 32:
296
 
-#line 380 "../../src/configparser.y"
297
 
+#line 380 "./configparser.y"
298
 
 {
299
 
   data_config *dc;
300
 
   buffer *b, *rvalue, *op;
301
 
@@ -1318,7 +1318,7 @@ static void yy_reduce(
302
 
   yy_destructor(19,&yymsp[-2].minor);
303
 
         break;
304
 
       case 33:
305
 
-#line 529 "../../src/configparser.y"
306
 
+#line 529 "./configparser.y"
307
 
 {
308
 
   yygotominor.yy27 = CONFIG_COND_EQ;
309
 
 }
310
 
@@ -1326,7 +1326,7 @@ static void yy_reduce(
311
 
   yy_destructor(20,&yymsp[0].minor);
312
 
         break;
313
 
       case 34:
314
 
-#line 532 "../../src/configparser.y"
315
 
+#line 532 "./configparser.y"
316
 
 {
317
 
   yygotominor.yy27 = CONFIG_COND_MATCH;
318
 
 }
319
 
@@ -1334,7 +1334,7 @@ static void yy_reduce(
320
 
   yy_destructor(21,&yymsp[0].minor);
321
 
         break;
322
 
       case 35:
323
 
-#line 535 "../../src/configparser.y"
324
 
+#line 535 "./configparser.y"
325
 
 {
326
 
   yygotominor.yy27 = CONFIG_COND_NE;
327
 
 }
328
 
@@ -1342,7 +1342,7 @@ static void yy_reduce(
329
 
   yy_destructor(22,&yymsp[0].minor);
330
 
         break;
331
 
       case 36:
332
 
-#line 538 "../../src/configparser.y"
333
 
+#line 538 "./configparser.y"
334
 
 {
335
 
   yygotominor.yy27 = CONFIG_COND_NOMATCH;
336
 
 }
337
 
@@ -1350,7 +1350,7 @@ static void yy_reduce(
338
 
   yy_destructor(23,&yymsp[0].minor);
339
 
         break;
340
 
       case 37:
341
 
-#line 542 "../../src/configparser.y"
342
 
+#line 542 "./configparser.y"
343
 
 {
344
 
   yygotominor.yy43 = NULL;
345
 
   if (ctx->ok) {
346
 
@@ -1370,7 +1370,7 @@ static void yy_reduce(
347
 
 #line 1370 "configparser.c"
348
 
         break;
349
 
       case 38:
350
 
-#line 559 "../../src/configparser.y"
351
 
+#line 559 "./configparser.y"
352
 
 {
353
 
   if (ctx->ok) {
354
 
     if (0 != config_parse_file(ctx->srv, ctx, yymsp[0].minor.yy43->ptr)) {
355
 
@@ -1384,7 +1384,7 @@ static void yy_reduce(
356
 
   yy_destructor(24,&yymsp[-1].minor);
357
 
         break;
358
 
       case 39:
359
 
-#line 569 "../../src/configparser.y"
360
 
+#line 569 "./configparser.y"
361
 
 {
362
 
   if (ctx->ok) {
363
 
     if (0 != config_parse_cmd(ctx->srv, ctx, yymsp[0].minor.yy43->ptr)) {
364
 
@@ -1424,7 +1424,7 @@ static void yy_parse_failed(
365
 
   while( yypParser->yyidx>=0 ) yy_pop_parser_stack(yypParser);
366
 
   /* Here code is inserted which will be executed whenever the
367
 
   ** parser fails */
368
 
-#line 108 "../../src/configparser.y"
369
 
+#line 108 "./configparser.y"
370
 
 
371
 
   ctx->ok = 0;
372
 
 
373
 
--- lighttpd-1.4.28.orig/src/mod_ssi_exprparser.c
374
 
+++ lighttpd-1.4.28/src/mod_ssi_exprparser.c
375
 
@@ -4,7 +4,7 @@
376
 
 /* First off, code is include which follows the "include" declaration
377
 
 ** in the input file. */
378
 
 #include <stdio.h>
379
 
-#line 6 "../../src/mod_ssi_exprparser.y"
380
 
+#line 6 "./mod_ssi_exprparser.y"
381
 
 
382
 
 #include "mod_ssi_expr.h"
383
 
 #include "buffer.h"
384
 
@@ -347,7 +347,7 @@ static void yy_destructor(YYCODETYPE yym
385
 
     case 10:
386
 
     case 11:
387
 
     case 12:
388
 
-#line 22 "../../src/mod_ssi_exprparser.y"
389
 
+#line 22 "./mod_ssi_exprparser.y"
390
 
 { buffer_free((yypminor->yy0)); }
391
 
 #line 352 "mod_ssi_exprparser.c"
392
 
       break;
393
 
@@ -578,7 +578,7 @@ static void yy_reduce(
394
 
   **     break;
395
 
   */
396
 
       case 0:
397
 
-#line 29 "../../src/mod_ssi_exprparser.y"
398
 
+#line 29 "./mod_ssi_exprparser.y"
399
 
 {
400
 
   ctx->val.bo = ssi_val_tobool(yymsp[0].minor.yy29);
401
 
   ctx->val.type = SSI_TYPE_BOOL;
402
 
@@ -588,7 +588,7 @@ static void yy_reduce(
403
 
 #line 588 "mod_ssi_exprparser.c"
404
 
         break;
405
 
       case 1:
406
 
-#line 36 "../../src/mod_ssi_exprparser.y"
407
 
+#line 36 "./mod_ssi_exprparser.y"
408
 
 {
409
 
   int cmp;
410
 
 
411
 
@@ -617,14 +617,14 @@ static void yy_reduce(
412
 
 #line 617 "mod_ssi_exprparser.c"
413
 
         break;
414
 
       case 2:
415
 
-#line 61 "../../src/mod_ssi_exprparser.y"
416
 
+#line 61 "./mod_ssi_exprparser.y"
417
 
 {
418
 
   yygotominor.yy29 = yymsp[0].minor.yy29;
419
 
 }
420
 
 #line 624 "mod_ssi_exprparser.c"
421
 
         break;
422
 
       case 3:
423
 
-#line 64 "../../src/mod_ssi_exprparser.y"
424
 
+#line 64 "./mod_ssi_exprparser.y"
425
 
 {
426
 
   int e;
427
 
 
428
 
@@ -639,7 +639,7 @@ static void yy_reduce(
429
 
   yy_destructor(1,&yymsp[-1].minor);
430
 
         break;
431
 
       case 4:
432
 
-#line 75 "../../src/mod_ssi_exprparser.y"
433
 
+#line 75 "./mod_ssi_exprparser.y"
434
 
 {
435
 
   int e;
436
 
 
437
 
@@ -654,7 +654,7 @@ static void yy_reduce(
438
 
   yy_destructor(2,&yymsp[-1].minor);
439
 
         break;
440
 
       case 5:
441
 
-#line 86 "../../src/mod_ssi_exprparser.y"
442
 
+#line 86 "./mod_ssi_exprparser.y"
443
 
 {
444
 
   int e;
445
 
 
446
 
@@ -668,7 +668,7 @@ static void yy_reduce(
447
 
   yy_destructor(9,&yymsp[-1].minor);
448
 
         break;
449
 
       case 6:
450
 
-#line 95 "../../src/mod_ssi_exprparser.y"
451
 
+#line 95 "./mod_ssi_exprparser.y"
452
 
 {
453
 
   yygotominor.yy29 = yymsp[-1].minor.yy29;
454
 
 }
455
 
@@ -677,7 +677,7 @@ static void yy_reduce(
456
 
   yy_destructor(11,&yymsp[0].minor);
457
 
         break;
458
 
       case 7:
459
 
-#line 99 "../../src/mod_ssi_exprparser.y"
460
 
+#line 99 "./mod_ssi_exprparser.y"
461
 
 {
462
 
   yygotominor.yy29 = ssi_val_init();
463
 
   yygotominor.yy29->str = yymsp[0].minor.yy19;
464
 
@@ -686,14 +686,14 @@ static void yy_reduce(
465
 
 #line 686 "mod_ssi_exprparser.c"
466
 
         break;
467
 
       case 8:
468
 
-#line 105 "../../src/mod_ssi_exprparser.y"
469
 
+#line 105 "./mod_ssi_exprparser.y"
470
 
 {
471
 
   yygotominor.yy19 = yymsp[0].minor.yy0;
472
 
 }
473
 
 #line 693 "mod_ssi_exprparser.c"
474
 
         break;
475
 
       case 9:
476
 
-#line 109 "../../src/mod_ssi_exprparser.y"
477
 
+#line 109 "./mod_ssi_exprparser.y"
478
 
 {
479
 
   yygotominor.yy19 = yymsp[-1].minor.yy19;
480
 
   buffer_append_string_buffer(yygotominor.yy19, yymsp[0].minor.yy0);
481
 
@@ -702,37 +702,37 @@ static void yy_reduce(
482
 
 #line 702 "mod_ssi_exprparser.c"
483
 
         break;
484
 
       case 10:
485
 
-#line 115 "../../src/mod_ssi_exprparser.y"
486
 
+#line 115 "./mod_ssi_exprparser.y"
487
 
 { yygotominor.yy8 = SSI_COND_EQ; }
488
 
 #line 707 "mod_ssi_exprparser.c"
489
 
   yy_destructor(3,&yymsp[0].minor);
490
 
         break;
491
 
       case 11:
492
 
-#line 116 "../../src/mod_ssi_exprparser.y"
493
 
+#line 116 "./mod_ssi_exprparser.y"
494
 
 { yygotominor.yy8 = SSI_COND_NE; }
495
 
 #line 713 "mod_ssi_exprparser.c"
496
 
   yy_destructor(4,&yymsp[0].minor);
497
 
         break;
498
 
       case 12:
499
 
-#line 117 "../../src/mod_ssi_exprparser.y"
500
 
+#line 117 "./mod_ssi_exprparser.y"
501
 
 { yygotominor.yy8 = SSI_COND_LE; }
502
 
 #line 719 "mod_ssi_exprparser.c"
503
 
   yy_destructor(8,&yymsp[0].minor);
504
 
         break;
505
 
       case 13:
506
 
-#line 118 "../../src/mod_ssi_exprparser.y"
507
 
+#line 118 "./mod_ssi_exprparser.y"
508
 
 { yygotominor.yy8 = SSI_COND_GE; }
509
 
 #line 725 "mod_ssi_exprparser.c"
510
 
   yy_destructor(6,&yymsp[0].minor);
511
 
         break;
512
 
       case 14:
513
 
-#line 119 "../../src/mod_ssi_exprparser.y"
514
 
+#line 119 "./mod_ssi_exprparser.y"
515
 
 { yygotominor.yy8 = SSI_COND_LT; }
516
 
 #line 731 "mod_ssi_exprparser.c"
517
 
   yy_destructor(7,&yymsp[0].minor);
518
 
         break;
519
 
       case 15:
520
 
-#line 120 "../../src/mod_ssi_exprparser.y"
521
 
+#line 120 "./mod_ssi_exprparser.y"
522
 
 { yygotominor.yy8 = SSI_COND_GT; }
523
 
 #line 737 "mod_ssi_exprparser.c"
524
 
   yy_destructor(5,&yymsp[0].minor);
525
 
@@ -764,7 +764,7 @@ static void yy_parse_failed(
526
 
   while( yypParser->yyidx>=0 ) yy_pop_parser_stack(yypParser);
527
 
   /* Here code is inserted which will be executed whenever the
528
 
   ** parser fails */
529
 
-#line 14 "../../src/mod_ssi_exprparser.y"
530
 
+#line 14 "./mod_ssi_exprparser.y"
531
 
 
532
 
   ctx->ok = 0;
533