~ubuntu-branches/ubuntu/oneiric/hal/oneiric

« back to all changes in this revision

Viewing changes to debian/patches/00upstream_video4linux_check.patch

  • Committer: Bazaar Package Importer
  • Author(s): Martin Pitt
  • Date: 2011-02-14 11:45:59 UTC
  • Revision ID: james.westby@ubuntu.com-20110214114559-g5ti3fxottbysekt
Tags: 0.5.14-5+svn1
Upload current Debian svn head to fix FTBFS.

* Add 00upstream_video4linux_check.patch: Do not build
  hald-probe-video4linux if v4l1 is not available. (LP: #721399)
* Refresh 99-autoreconf.patch for above.
* 45-fix-libusb-detection.patch: Unfuzz.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
From 8f624253f0135ca77a893ad4e8168f51ef90d4da Mon Sep 17 00:00:00 2001
 
2
From: Martin Pitt <martin.pitt@ubuntu.com>
 
3
Date: Mon, 14 Feb 2011 11:26:22 +0100
 
4
Subject: Do not build hald-probe-video4linux if v4l1 is not available.
 
5
 
 
6
The old v4l1 API is gone from current kernels (2.6.38), and thus
 
7
linux/videodev.h does not exist any more. Add a configure check for the include
 
8
and do not build hald-probe-video4linux if it is not available.
 
9
---
 
10
 configure.in                   |    3 +++
 
11
 hald/linux/probing/Makefile.am |    7 +++++--
 
12
 2 files changed, 8 insertions(+), 2 deletions(-)
 
13
 
 
14
Index: hal/configure.in
 
15
===================================================================
 
16
--- hal.orig/configure.in       2009-08-24 14:42:29.000000000 +0200
 
17
+++ hal/configure.in    2011-02-14 11:42:54.931499233 +0100
 
18
@@ -479,6 +479,9 @@
 
19
 fi 
 
20
 AM_CONDITIONAL([HAVE_LIBPCI], [test "x$USE_LIBPCI" = "xyes"])
 
21
 
 
22
+AC_CHECK_HEADERS([linux/videodev.h], [have_videodev_h=yes], [])
 
23
+AM_CONDITIONAL(HAVE_V4L1, [test "x$have_videodev_h" = "xyes"])
 
24
+
 
25
 USE_LIBUSB20=no
 
26
 USE_LIBUSB=no
 
27
 LIBUSB20_LIBS=""
 
28
Index: hal/hald/linux/probing/Makefile.am
 
29
===================================================================
 
30
--- hal.orig/hald/linux/probing/Makefile.am     2009-11-09 16:33:53.000000000 +0100
 
31
+++ hal/hald/linux/probing/Makefile.am  2011-02-14 11:43:33.141499233 +0100
 
32
@@ -19,8 +19,11 @@
 
33
        hald-probe-smbios               \
 
34
        hald-probe-serial               \
 
35
        hald-probe-ieee1394-unit        \
 
36
-       hald-probe-net-bluetooth        \
 
37
-       hald-probe-video4linux
 
38
+       hald-probe-net-bluetooth
 
39
+
 
40
+if HAVE_V4L1
 
41
+libexec_PROGRAMS += hald-probe-video4linux
 
42
+endif
 
43
 endif
 
44
 
 
45
 hald_probe_smbios_SOURCES = probe-smbios.c ../../logger.c