~ubuntu-branches/ubuntu/precise/gnome-vfs/precise

« back to all changes in this revision

Viewing changes to debian/patches/06_blacklist-directories.patch

  • Committer: Bazaar Package Importer
  • Author(s): Robert Ancell
  • Date: 2009-09-11 11:35:43 UTC
  • mfrom: (0.1.7 sid)
  • Revision ID: james.westby@ubuntu.com-20090911113543-mwucsk0doxzikb1c
Tags: 1:2.24.1-4ubuntu1
* Merge from Debian unstable, remaining changes: (LP: #427654)
  * debian/control:
      - don't Build-Depends on type-handling
      - Build-Depends and Recommends gamin before fam
      - libgnomevfs2-dev Replaces libgnomevfs2-common (<< 1:2.20.0-0ubuntu2)
  * renamed debian/libgnomevfs2-common.links debian/libgnomevfs2-dev.links
  * debian/libgnomevfs2-common.install,
    debian/libgnomevfs2-dev.install:
      - install the API documentation in the dev package
  * debian/libgnomevfs2-common.gconf-defaults:
      - firefox is the default Ubuntu webbrowser
  * debian/patches/11_network-volumes-in-network.patch:
      - ubuntu changes
  * debian/patches/16_improve_volume_labels.patch:
      - Ignore '/' volume labels, they lead to much confusion.
  * debian/patches/21_proxy_ignore_local.patch:
      - ignore .local for proxy
  * debian/patches/23_ignore_ltspfs_volumes.patch: 
     - Ignore ltspfs mounts since the current ltspfs implementation creates
       associated bind mounts to /media. This prevents generating two volumes
       for the same mount.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
Index: gnome-vfs-2.18.1/libgnomevfs/gnome-vfs-hal-mounts.c
 
1
unchanged:
 
2
Index: gnome-vfs-2.24.1-ubuntu/libgnomevfs/gnome-vfs-hal-mounts.c
2
3
===================================================================
3
 
--- gnome-vfs-2.18.1.orig/libgnomevfs/gnome-vfs-hal-mounts.c    2007-05-03 23:07:30.686398250 +0200
4
 
+++ gnome-vfs-2.18.1/libgnomevfs/gnome-vfs-hal-mounts.c 2007-05-03 23:12:04.779528000 +0200
5
 
@@ -645,6 +645,14 @@
 
4
--- gnome-vfs-2.24.1-ubuntu.orig/libgnomevfs/gnome-vfs-hal-mounts.c     2009-09-11 11:39:48.000000000 +1000
 
5
+++ gnome-vfs-2.24.1-ubuntu/libgnomevfs/gnome-vfs-hal-mounts.c  2009-09-11 11:39:51.000000000 +1000
 
6
@@ -645,6 +645,19 @@
6
7
                "/var",
7
8
                "/proc",
8
9
                "/sbin",
12
13
+               "/var/mail",
13
14
+               "/var/run",
14
15
+               "/var/tmp",
15
 
+               "/live/cow",
16
 
+               "/live/image",
 
16
+               NULL
 
17
+       };
 
18
+
 
19
+       const char *fhs23_recursive_toplevel_mount_points[] = {
 
20
+               "/live/cow",
 
21
+               "/live/image",
 
22
+               "/live/installer",
17
23
                NULL
18
24
        };
19
25
 
 
26
@@ -694,6 +707,12 @@
 
27
                                if (strcmp (mount_point, fhs23_toplevel_mount_points[i]) == 0)
 
28
                                        goto out;
 
29
                        }
 
30
+
 
31
+                       for (i = 0; fhs23_recursive_toplevel_mount_points[i] != NULL; i++) {
 
32
+                               if (strncmp (mount_point, fhs23_recursive_toplevel_mount_points[i],
 
33
+                                           strlen(fhs23_recursive_toplevel_mount_points[i])) == 0)
 
34
+                                       goto out;
 
35
+                       }
 
36
                }
 
37
        }
 
38
 #if 0