~ubuntu-branches/ubuntu/saucy/clamav/saucy-backports

« back to all changes in this revision

Viewing changes to debian/patches/0006-Fix-underlinking-with-llvm-in-libclamav-c-Makefile.a.patch

  • Committer: Package Import Robot
  • Author(s): Scott Kitterman
  • Date: 2014-07-15 01:08:10 UTC
  • mfrom: (0.35.47 sid)
  • Revision ID: package-import@ubuntu.com-20140715010810-ru66ek4fun2iseba
Tags: 0.98.4+dfsg-2~ubuntu13.10.1
No-change backport to saucy (LP: #1341962)

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
From 99c9268c3969c8c98be96eb21dc04395c590652b Mon Sep 17 00:00:00 2001
 
2
From: Sebastian Andrzej Siewior <sebastian@breakpoint.cc>
 
3
Date: Sat, 17 May 2014 20:10:40 +0200
 
4
Subject: Fix underlinking with llvm in libclamav/c++/Makefile.am
 
5
 
 
6
This is the patch that went in as:
 
7
 
 
8
|  [ Adam Conrad ]
 
9
|  * Fix underlinking with llvm in libclamav/c++/Makefile.am
 
10
 
 
11
Signed-off-by: Sebastian Andrzej Siewior <sebastian@breakpoint.cc>
 
12
---
 
13
 libclamav/c++/Makefile.am | 2 +-
 
14
 1 file changed, 1 insertion(+), 1 deletion(-)
 
15
 
 
16
diff --git a/libclamav/c++/Makefile.am b/libclamav/c++/Makefile.am
 
17
index d8c8244..8cdd6c5 100644
 
18
--- a/libclamav/c++/Makefile.am
 
19
+++ b/libclamav/c++/Makefile.am
 
20
@@ -39,7 +39,7 @@ if BUILD_LLVM3
 
21
 libclamavcxx_la_CXXFLAGS += -DLLVM30
 
22
 endif
 
23
 libclamavcxx_la_CXXFLAGS += -DLLVM_VERSION=${LLVM_VERSION}
 
24
-libclamavcxx_la_LDFLAGS = @LLVMCONFIG_LDFLAGS@ @LLVMCONFIG_LIBS@
 
25
+libclamavcxx_la_LDFLAGS = @LLVMCONFIG_LDFLAGS@ @LLVMCONFIG_LIBS@ @LLVMCONFIG_LDFLAGS@
 
26
 libclamavcxx_la_DEPENDENCIES = @LLVMCONFIG_LIBFILES@
 
27
 noinst_LTLIBRARIES = libclamavcxx.la
 
28
 libclamavcxx_la_SOURCES += PointerTracking.cpp