~ubuntu-branches/ubuntu/saucy/joystick/saucy

« back to all changes in this revision

Viewing changes to debian/patches/hardening.patch

  • Committer: Package Import Robot
  • Author(s): Stephen Kitt
  • Date: 2013-05-06 23:03:26 UTC
  • mfrom: (3.1.12 sid)
  • Revision ID: package-import@ubuntu.com-20130506230326-po18icz4mtaa25k1
Tags: 1:1.4.6-1
* New upstream release:
  - Disable CRTSCTS on ELO touchscreens. Closes: #699030. Thanks Thierry
    Bultel!
  - Handle long device names correctly. Closes: #706744. Thanks Ralf
    Jung!
* Drop hardening.patch, merged upstream.
* Standards-Version 3.9.4, no change required.
* Switch to my Debian address.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
Description: Pass flags required to enable hardened builds
2
 
Author: Stephen Kitt <steve@sk2.org>
3
 
Forwarded: yes
4
 
 
5
 
--- joystick.orig/utils/Makefile
6
 
+++ joystick/utils/Makefile
7
 
@@ -26,7 +26,7 @@
8
 
 #
9
 
 
10
 
 CC             = gcc
11
 
-CFLAGS         = -g -O2 -Wall -I../linux/include
12
 
+CPPFLAGS       += -I../linux/include
13
 
 
14
 
 PROGRAMS       = inputattach jstest jscal fftest ffmvforce ffset \
15
 
                  ffcfstress jscal-restore jscal-store
16
 
@@ -40,7 +40,7 @@
17
 
        $(RM) *.o *.swp $(PROGRAMS) *.orig *.rej map *~
18
 
 
19
 
 ffcfstress: ffcfstress.c
20
 
-       $(CC) -O2 -funsigned-char ffcfstress.c -lm -o ffcfstress
21
 
+       $(CC) $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) -funsigned-char ffcfstress.c -lm -o ffcfstress
22
 
 
23
 
 ffmvforce.o: ffmvforce.c
24
 
        $(CC) -c $(CFLAGS) $(CPPFLAGS) $^ -o $@ `sdl-config --cflags`
25
 
@@ -53,14 +53,14 @@
26
 
 jscal.o: jscal.c axbtnmap.h
27
 
 
28
 
 jscal: jscal.o axbtnmap.o
29
 
-       $(CC) $(CFLAGS) $(CPPFLAGS) $^ -lm -o $@
30
 
+       $(CC) $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) $^ -lm -o $@
31
 
 
32
 
 jstest.o: jstest.c axbtnmap.h
33
 
 
34
 
 jstest: jstest.o axbtnmap.o
35
 
 
36
 
 gencodes: gencodes.c scancodes.h
37
 
-       $(CC) $(CFLAGS) $(CPPFLAGS) gencodes.c -o gencodes
38
 
+       $(CC) $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) gencodes.c -o gencodes
39
 
 
40
 
 jscal-restore: jscal-restore.in
41
 
        sed "s^@@PREFIX@@^$(PREFIX)^g" < $^ > $@