~ubuntu-branches/ubuntu/trusty/grub2/trusty-updates

« back to all changes in this revision

Viewing changes to debian/patches/quick_boot.patch

  • Committer: Package Import Robot
  • Author(s): Colin Watson
  • Date: 2014-01-20 15:53:36 UTC
  • mfrom: (17.6.40 experimental)
  • Revision ID: package-import@ubuntu.com-20140120155336-xy8j2nvdplsj4egn
Tags: 2.02~beta2-4
* Remove redundant build-dependencies on autoconf and automake, covered by
  dh-autoreconf.
* In --enable-quick-boot mode, restore previous behaviour of using a
  hidden timeout if GRUB_HIDDEN_TIMEOUT=0 (thanks to Sebastien Bacher for
  the report).
* Disable cpio test on kFreeBSD again for now; it fails within cpio itself
  with "field width not sufficient for storing rdev minor".
* Copy shim.efi.signed to the correct path in UEFI Secure Boot mode.
  Thanks to syscon-hh for the report.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
From b49b075322ed0313063adc899d20296f95e6c178 Mon Sep 17 00:00:00 2001
 
1
From 6b17b4884b52e6809d6ae0852e41ada7468b679b Mon Sep 17 00:00:00 2001
2
2
From: Colin Watson <cjwatson@ubuntu.com>
3
3
Date: Mon, 13 Jan 2014 12:13:28 +0000
4
4
Subject: Add configure option to bypass boot menu if possible
18
18
 
19
19
Author: Richard Laager <rlaager@wiktel.com>
20
20
Forwarded: no
21
 
Last-Update: 2013-12-25
 
21
Last-Update: 2014-01-17
22
22
 
23
23
Patch-Name: quick_boot.patch
24
24
---
25
25
 configure.ac                | 11 +++++++++
26
 
 docs/grub.texi              |  9 ++++++++
27
 
 grub-core/normal/menu.c     | 24 ++++++++++++++++++++
 
26
 docs/grub.texi              |  9 +++++++
 
27
 grub-core/normal/menu.c     | 24 +++++++++++++++++++
28
28
 util/grub-mkconfig.in       |  3 ++-
29
 
 util/grub.d/00_header.in    | 55 ++++++++++++++++++++++++++++++++++++---------
 
29
 util/grub.d/00_header.in    | 58 +++++++++++++++++++++++++++++++++++----------
30
30
 util/grub.d/10_linux.in     |  4 ++++
31
 
 util/grub.d/30_os-prober.in | 21 +++++++++++++++++
32
 
 7 files changed, 115 insertions(+), 12 deletions(-)
 
31
 util/grub.d/30_os-prober.in | 21 ++++++++++++++++
 
32
 7 files changed, 117 insertions(+), 13 deletions(-)
33
33
 
34
34
diff --git a/configure.ac b/configure.ac
35
35
index 7c8d0af..2a7e410 100644
123
123
 if test "x${grub_cfg}" != "x"; then
124
124
   rm -f "${grub_cfg}.new"
125
125
diff --git a/util/grub.d/00_header.in b/util/grub.d/00_header.in
126
 
index 0c82f23..f6016a8 100644
 
126
index 0c82f23..8dc5592 100644
127
127
--- a/util/grub.d/00_header.in
128
128
+++ b/util/grub.d/00_header.in
129
129
@@ -21,6 +21,8 @@ prefix="@prefix@"
175
175
 function load_video {
176
176
 EOF
177
177
 if [ -n "${GRUB_VIDEO_BACKEND}" ]; then
178
 
@@ -282,6 +309,11 @@ fi
 
178
@@ -282,10 +309,16 @@ fi
179
179
 
180
180
 make_timeout ()
181
181
 {
187
187
     if [ "x${3}" != "x" ] ; then
188
188
        timeout="${2}"
189
189
        style="${3}"
190
 
@@ -304,26 +336,27 @@ make_timeout ()
 
190
-    elif [ "x${1}" != "x" -a "x${1}" != "x0" ] ; then
 
191
+    elif [ "x${1}" != "x" ] && \
 
192
+        ([ "$quick_boot" = 1 ] || [ "x${1}" != "x0" ]) ; then
 
193
        # Handle the deprecated GRUB_HIDDEN_TIMEOUT scheme.
 
194
        timeout="${1}"
 
195
        if [ "x${2}" != "x0" ] ; then
 
196
@@ -304,26 +337,27 @@ make_timeout ()
191
197
        style="menu"
192
198
     fi
193
199
     cat << EOF