~ubuntu-branches/ubuntu/trusty/libgeo-metar-perl/trusty

« back to all changes in this revision

Viewing changes to debian/patches/visibility.patch

  • Committer: Bazaar Package Importer
  • Author(s): Martín Ferrari
  • Date: 2008-06-13 02:42:42 UTC
  • mfrom: (0.1.2 upstream)
  • Revision ID: james.westby@ubuntu.com-20080613024242-2be2lbxarhx8sglx
Tags: 1.15-1
* New upstream release, new upstream maintainer.
* debian/docs: removed HACKING.
* debian/copyright: updated CP info, plus new format.
* debian/control: added myself to Uploaders, fixed case in short desc. Fix
  incorrect Build-Depends{,-Indep} distribution.
* debian/patches: finally merged all the patches from #304962 and #262397
  with the new upstream release! Also, sent the patches upstream as
  CPAN#36708. (Closes: #304962).

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Index: libgeo-metar-perl/METAR.pm
 
2
===================================================================
 
3
--- libgeo-metar-perl.orig/METAR.pm
 
4
+++ libgeo-metar-perl/METAR.pm
 
5
@@ -1282,7 +1282,7 @@ sub _process
 
6
     ## Visibility.
 
7
     ##
 
8
 
 
9
-    {
 
10
+    if($self->{visibility}) {
 
11
         my $vis = $self->{visibility};
 
12
                # test for statute miles
 
13
                if ($vis =~ /SM$/){
 
14
@@ -1290,7 +1290,7 @@ sub _process
 
15
                        if ($vis =~ /M(\d\/\d)/o) {
 
16
                                $self->{VISIBILITY} = "Less than $1 statute miles";
 
17
                        } else {
 
18
-                               $self->{VISIBILITY} = $vis . " Statute Miles";
 
19
+                               $self->{VISIBILITY} = $vis . " statute miles";
 
20
                        } # end if
 
21
                # auto metars can have non-directional visibility reports
 
22
                } elsif (($self->{MOD} eq 'AUTO') and ($vis =~ /(\d+)NDV$/)){