~ubuntu-branches/ubuntu/trusty/rcs/trusty

« back to all changes in this revision

Viewing changes to debian/patches/0006-Make-ident-accept-numbers-in-identifiers.patch

  • Committer: Bazaar Package Importer
  • Author(s): Romain Francoise
  • Date: 2008-03-23 12:48:22 UTC
  • mfrom: (4.1.3 hardy)
  • Revision ID: james.westby@ubuntu.com-20080323124822-gfnnupnyappiwm0k
Tags: 5.7-23
* The "fourteen degrees below" release.

* Repackage with debhelper and a patch system.
* debian/control: Build-depend on debhelper (>= 6).
* debian/rules: Rewrite using debhelper.
* debian/{compat,rcs.docs}: New files.
* debian/patches/: New directory, contains patches split off the previous
  monolithic Debian diff.

* Include patch by Justin Pryzby <justinpryzby@users.sourceforge.net>
  fixing minor formatting errors in merge.1 (closes: #471243).

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
From bc7666830e154f7f5fd2bc80b30ca8cf7f0bd9d6 Mon Sep 17 00:00:00 2001
 
2
From: Romain Francoise <rfrancoise@debian.org>
 
3
Date: Sun, 23 Mar 2008 00:54:00 +0100
 
4
Subject: [PATCH] Make ident accept numbers in identifiers
 
5
 
 
6
Debian bug #157891.
 
7
---
 
8
 src/ident.c |    2 +-
 
9
 1 files changed, 1 insertions(+), 1 deletions(-)
 
10
 
 
11
diff --git a/src/ident.c b/src/ident.c
 
12
index 612544c..67954f3 100644
 
13
--- a/src/ident.c
 
14
+++ b/src/ident.c
 
15
@@ -234,7 +234,7 @@ match(fp)   /* group substring between two KDELIM's; then do pattern match */
 
16
       if (c == EOF  &&  feof(fp) | ferror(fp))
 
17
         return c;
 
18
       switch (ctab[c]) {
 
19
-        case LETTER: case Letter:
 
20
+        case LETTER: case Letter: case DIGIT:
 
21
            *tp++ = c;
 
22
            if (tp < line+sizeof(line)-4)
 
23
               break;
 
24
-- 
 
25
1.5.4.4
 
26