1
From e815298b6abff3ac1cf58c360e03ee9a849a9614 Mon Sep 17 00:00:00 2001
2
From: Nobuhiro Iwamatsu <iwamatsu@nigauri.org>
3
Date: Mon, 16 Jul 2012 01:56:58 +0900
4
Subject: [PATCH] Add build target to Makefile
6
Signed-off-by: Nobuhiro Iwamatsu <iwamatsu@nigauri.org>
8
Makefile | 15 +++++++++++----
9
1 file changed, 11 insertions(+), 4 deletions(-)
11
diff --git a/Makefile b/Makefile
12
index 1fda878..b11dccf 100644
16
-.PHONY: dialyzer_warnings xref_warnings
17
+.PHONY: all build clean install
28
@@ -9,7 +13,7 @@ clean:
32
-check: debug xref dialyzer
33
+check: debug # xref dialyzer
37
@@ -24,4 +28,7 @@ dialyzer_warnings:
38
binary: VSN = $(shell ./rebar -V)
40
cp rebar ../rebar.wiki/rebar
41
- (cd ../rebar.wiki && git commit -m "Update $(VSN)" rebar)
42
\ No newline at end of file
43
+ (cd ../rebar.wiki && git commit -m "Update $(VSN)" rebar)
46
+ install -D -m 755 ./rebar $(DESTDIR)/usr/bin/rebar