~ubuntu-branches/ubuntu/trusty/rebar/trusty

« back to all changes in this revision

Viewing changes to debian/patches/Add-build-target-to-Makefile.patch

  • Committer: Package Import Robot
  • Author(s): Nobuhiro Iwamatsu
  • Date: 2012-07-15 12:10:52 UTC
  • Revision ID: package-import@ubuntu.com-20120715121052-uoht7dtyiufg1fex
Tags: 2.0.0-1
Initial release. (Closes: #683350)

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
From e815298b6abff3ac1cf58c360e03ee9a849a9614 Mon Sep 17 00:00:00 2001
 
2
From: Nobuhiro Iwamatsu <iwamatsu@nigauri.org>
 
3
Date: Mon, 16 Jul 2012 01:56:58 +0900
 
4
Subject: [PATCH] Add build target to Makefile
 
5
 
 
6
Signed-off-by: Nobuhiro Iwamatsu <iwamatsu@nigauri.org>
 
7
---
 
8
 Makefile |   15 +++++++++++----
 
9
 1 file changed, 11 insertions(+), 4 deletions(-)
 
10
 
 
11
diff --git a/Makefile b/Makefile
 
12
index 1fda878..b11dccf 100644
 
13
--- a/Makefile
 
14
+++ b/Makefile
 
15
@@ -1,6 +1,10 @@
 
16
-.PHONY: dialyzer_warnings xref_warnings
 
17
+.PHONY: all build clean install
 
18
 
 
19
-all:
 
20
+all: build
 
21
+
 
22
+build: bootstrap
 
23
+
 
24
+bootstrap:
 
25
        ./bootstrap
 
26
 
 
27
 clean:
 
28
@@ -9,7 +13,7 @@ clean:
 
29
 debug:
 
30
        @./bootstrap debug
 
31
 
 
32
-check: debug xref dialyzer
 
33
+check: debug # xref dialyzer
 
34
 
 
35
 xref:
 
36
        @./rebar xref
 
37
@@ -24,4 +28,7 @@ dialyzer_warnings:
 
38
 binary: VSN = $(shell ./rebar -V)
 
39
 binary: clean all
 
40
        cp rebar ../rebar.wiki/rebar
 
41
-       (cd ../rebar.wiki && git commit -m "Update $(VSN)" rebar)
 
42
\ No newline at end of file
 
43
+       (cd ../rebar.wiki && git commit -m "Update $(VSN)" rebar)
 
44
+
 
45
+install: build
 
46
+       install -D -m 755 ./rebar $(DESTDIR)/usr/bin/rebar
 
47
-- 
 
48
1.7.10.4
 
49